Вход | Регистрация

1С:Предприятие ::

Метки: 

Расшифровка в СКД

Я
   winterbear
 
07.06.18 - 15:37
в отчете на скд делаю расшифровку на другой отчет. на форме есть поле Результат в обработчике прописываю

Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
     
    Заказ = ПолучитьРасшифровкуНаСервере(Расшифровка, );
    
    Если Заказ = Неопределено Тогда 
        Возврат;
    КонецЕсли;
    
    СтандартнаяОбработка = Ложь;
    
    ОтборХ = Новый Структура("Заказ",Заказ);
    
    ПараметрыФормыХ = Новый Структура("СформироватьПриОткрытии,Отбор,КлючВарианта", Истина,ОтборХ,  "ДляРасшифровки");
    
    ОткрытьФорму("Отчет.РасшПоступлениеТоваровУслуг.Форма", ПараметрыФормыХ, ЭтаФорма);
    
         
КонецПроцедуры



Функция ПолучитьРасшифровкуНаСервере(Расшифровка, ЭтоГруппа = Ложь)
    
    Данные = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);  
    Поля = Данные.Элементы.Получить(Расшифровка).ПолучитьПоля();  
    ПолеНоменклатура = Поля.Найти("ЗаказПоставщику");
    
    Если ПолеНоменклатура = Неопределено Тогда
        
        Возврат Неопределено;
        
    Иначе
        
        ЭтоГруппа = ПолеНоменклатура.Значение.ЭтоГруппа;
        
        Возврат ПолеНоменклатура.Значение;
        
    КонецЕсли;
    
КонецФункции

Вылетает ошибка 

Данные = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
Неправильный путь к файлу 'ДанныеРасшифровкиКомпоновкиДанных'


Где нужно заполнить ДанныеРасшифровки ?
делал по этому примеру

http://catalog.mista.ru/public/161994/
 
  Рекламное место пустует
   winterbear
 
1 - 07.06.18 - 15:46
делаю в обычном приложении


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует