Вход | Регистрация


Как в СКД дл 8.2 сделать заполнение параметра по умолчанию?

Как в СКД дл 8.2 сделать заполнение параметра по умолчанию?
Я
   Мисти
 
06.06.18 - 15:59
Чтобы отчет открывался, а в нем ДатаОтчета = ТекущаяДата().
Это где задать?
 
 
   Гипервизор
 
1 - 06.06.18 - 16:02
Попробуйте в выражении параметра написать ТекущаяДата()
   Мисти
 
2 - 06.06.18 - 16:08
не сработало.
И еще - пока не пойму, что не так - у меня выводится только итог по всему, а детальные записи не выводятся (до этого - наоборот, вывелись все строки, но с одним столбцом.)
   Малыш Джон
 
3 - 06.06.18 - 16:15
(2)>>не сработало

Странно, у меня вот так работает:
http://pics.rsh.ru/img/_sf23sh8s.png
   dvva
 
4 - 06.06.18 - 16:57
ИМХО лучше заполнять этот параметр в "ПриКомпоновкеРезультата"
   dvva
 
5 - 06.06.18 - 16:58
СхемаКомпоновкиДанных.Параметры.ХХХ.Значение    = Значение;
   Мисти
 
6 - 06.06.18 - 17:22
Решила сделать отчет заново - а до этого я сильно-сильно меняла существующий, иногда там где-то не те данные застревают...
В итоге у меня вообще пропала страничка с параметрами.
Почему??
   Ник080808
 
7 - 06.06.18 - 17:29
(6) включить нужно доступность параметров
   Вафель
 
8 - 06.06.18 - 17:33
а в 8.2 разве нет типа "стандартный период" ?
   Малыш Джон
 
9 - 06.06.18 - 18:02
(4) по-разному бывает; иногда это лучше, иногда это хуже

в данном случае, если вопрос в том, чтобы в параметр установить текущую дату, то делать ради этого целое событие  - это не есть гут
   Малыш Джон
 
10 - 06.06.18 - 18:13
И кстати, изначальные требования - "Чтобы отчет открывался, а в нем ДатаОтчета = ТекущаяДата()"

Так что - делать свою форму и при открытии заполнять)
 
 Рекламное место пустует
   craxx
 
11 - 06.06.18 - 18:32
(0) Стандартный период, не?
   SleepyHead
 
12 - 07.06.18 - 06:16
(11) скорее, стандартная дата начала
   MihailShesternev
 
13 - 07.06.18 - 08:22
Делал так

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
    Настройки = КомпоновщикНастроек.ПолучитьНастройки();
    
    Если Настройки.ПараметрыДанных.Элементы[0].Значение = Дата(1,1,1) Тогда
        Настройки.ПараметрыДанных.Элементы[2].Значение.ДатаНачала = Дата("20010101");
    КонецЕсли;
    Если Настройки.ПараметрыДанных.Элементы[1].Значение = Дата(1,1,1) Тогда
        Настройки.ПараметрыДанных.Элементы[2].Значение.ДатаОкончания = ТекущаяДата();
    КонецЕсли;

КонецПроцедуры
   MihailShesternev
 
14 - 07.06.18 - 08:22
В модуле отчета
   MihailShesternev
 
15 - 07.06.18 - 08:23
Сорри в продолжение

    КомпоновщикМакет = Новый КомпоновщикМакетаКомпоновкиДанных;
    Макет = КомпоновщикМакет.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(Макет, , ДанныеРасшифровки);
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);
   MihailShesternev
 
16 - 07.06.18 - 08:24
Чет савсем запарился
еще СтандартнаяОбработка=Ложь

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует