Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Итоги

Итоги
Я
   Евгения93
 
05.06.18 - 15:31
здравствуйте! Подскажите как сделать? Есть документ поступления в котором табличная часть  "товары" заполняется при выборе основания(реквизит основание-ссылка документ оплаты), нужно посчитать итог по количеству, всё бы хорошо и я воспользовалась "отображать итоги в подвале" но в табличную часть встают строки где наименование ссылка артикулы и наименовпние ссылка услуги, вот нужно чтобы не считалось где ссылки итоги, я пробовала так:
Процедура ТоварыПриПолученииДанных(элемент, оформление строк)
Для каждого стр из товары цикл
Если ТипЗнч(стр.Артикул)= тип("справочникссылка. Артикулы")  тогда 
ИтогоКоличество = Товары. Итог("количество ") ;
КонецЕсли ; 
КонецЦикла;
Пробовала ставить в разные процедуры  либо вообще не считает, либо считает и строки где наименование ссылка услуги
 
 
   Boleev
 
1 - 05.06.18 - 15:35
5 раз прочитал. Попробую позже..
   DDwe
 
2 - 05.06.18 - 15:37
(1) 6, 6 раз прочитано и все впустую. Больше пробовать не буду. Пусть переформулирует эту кашу.
   bolobol
 
3 - 05.06.18 - 15:40
Даже не читал, но осуждаю
   DrShad
 
4 - 05.06.18 - 15:41
услуги нужно добавлять в таб часть услуги и будет вам счастие
   DDwe
 
5 - 05.06.18 - 15:42
(4) телепат?
   exwill
 
6 - 05.06.18 - 15:43
(1) (2) Тренируйтесь, друзья. Тяжело в учении, легко в походе. Не такой уж сложный текст у Жени.
   Евгения93
 
7 - 05.06.18 - 15:44
Да, писатель из меня плохой, как и программист :(
Попробую так.
При выборе основания в документе Поступления, у меня заполняется автоматически табличная часть Товары данного документа Поступление. Нужно посчитать итоги в табличной части по колонке количество, но нужно чтобы не учитывались те строки где либо тип данных ссылка.услуги либо номенклатура 1
   Гипервизор
 
8 - 05.06.18 - 15:44
(2) 6 раз обновил профиль, а фотки так и нет
   Buster007
 
9 - 05.06.18 - 15:45
(8) может фотограф тоже не очень?)
   DDwe
 
10 - 05.06.18 - 15:45
(8) И не будет.
 
 Рекламное место пустует
   Buster007
 
11 - 05.06.18 - 15:45
А куда итоги надо вывести то?
   Buster007
 
12 - 05.06.18 - 15:46
(10) откуда такая уверенность?
   DDwe
 
13 - 05.06.18 - 15:46
(11) В подвал вестимо.
   DrShad
 
14 - 05.06.18 - 15:46
(11) в подвале ТЧ ей надо
   exwill
 
15 - 05.06.18 - 15:46
(11) В офшор.
   DDwe
 
16 - 05.06.18 - 15:46
(12) Была бы уже.
   bolobol
 
17 - 05.06.18 - 15:46
В чём-то явно есть скрытый смысл подобного кода:

Процедура ТоварыПриПолученииДанных(элемент, оформление строк)// В момент получения данных каких-то данных...

Для каждого стр из товары цикл// для каждой строки Товаров 

Если ТипЗнч(стр.Артикул)= тип("справочникссылка. Артикулы")  тогда// убеждаемся, что в поле Артикул - значение из справочника Артикул

ИтогоКоличество = Товары. Итог("количество ") ;// Заполняем переменную итогом по колонке Количество

КонецЕсли ; 
КонецЦикла;

И чо? Один и тот же Итог посчитан столько раз, сколько Артикулов с типом Справочик.Артикул. За Чем?
   DDwe
 
18 - 05.06.18 - 15:47
(17) Это тайное знание.
   bolobol
 
19 - 05.06.18 - 15:50
(18) Отнюдь. Увы.
   Buster007
 
20 - 05.06.18 - 15:52
сделай реквизит формы, в который посчитай итог. Потом этот реквизит укажи в качестве пути к данным подвала у нужной тебе колонки
   hhhh
 
21 - 05.06.18 - 15:58
(0) что за ...?

Итог("количество ")  ??

у вас есть колонка такая?
   Масянька
 
22 - 05.06.18 - 16:01
В (0) не совсем понятно...
А потом - вообще запуталась... То фотка, то код, то колдовство...
Вообще-то, лето уже на дворе.
   bolobol
 
23 - 05.06.18 - 16:06
(22) Лето - время фоток!
   Евгения93
 
24 - 05.06.18 - 16:06
Итоги нужно вывести в отдельный реквизит ИтогоКоличество. Я бы вывела в подвале, но тогда будет учитывать все строки, а мне нужно только там где стоит тип данных справочник артикул
   Масянька
 
25 - 05.06.18 - 16:06
(23) А весна - время обострений...
   hhhh
 
26 - 05.06.18 - 16:08
(24) зачем "количество " пишешь с пробелом? бзик такой?
   Масянька
 
27 - 05.06.18 - 16:09
(24) А сделать в подвале еще один итог? Низя?
   bolobol
 
28 - 05.06.18 - 16:48
ИтогоКоличество = ИтогоКоличество + Стр.Количество; // разве, нет?
   spiller26
 
29 - 05.06.18 - 17:19
Сделай доп.реквизит ТЧ, где нужно количество, а где не нужно то по нулям ставь при заполнении, сделай невидимой для пользователя, Итог по этому реквизиту в подвале.
   azernot
 
30 - 05.06.18 - 17:27
Для каждого стр из товары цикл
Если ТипЗнч(стр.Артикул)= тип("справочникссылка. Артикулы")  тогда 
ИтогоКоличество = ИтогоКоличество  + Стр.количество;
КонецЕсли ; 
КонецЦикла;
   Евгения93
 
31 - 06.06.18 - 11:35
(30) спасибо! Тему можно закрыть


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует