Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

отчет по сотрудникам с фото в word

отчет по сотрудникам с фото в word
Я
   pedagog
 
05.06.18 - 15:12
Нужно создать отчет, который будет выводиться в word. выводить нужно кадровую информацию и фото сотрудника, т.е. фото, под ним кадровая информация. фото у меня получилось вывести, а вот инфу под ним нет.
 
 
   pedagog
 
1 - 05.06.18 - 15:13
номерПП  = 1; списокСотр = Неопределено;
    если ТипЗнч(работник) = тип("СправочникСсылка.СотрудникиОрганизаций") тогда
        списокСотр = новый СписокЗначений;
        списокСотр.Добавить(работник);
    иначе
        списокСотр = работник;
    КонецЕсли;
    если списокСотр<> Неопределено  тогда
            // Создание COM 

            Word1C = Новый COMОбъект("Word.Application"); 
            // Установим видимости объекта 

            Word1C.Visible = Истина; 
            // Добавим документ в приложение 

            Word1C.Documents.Add(); 
            // Придаем объекту статус активности 

            ТекущийДокумент = Word1C.ActiveDocument(); 
            ТекущийДокумент.Paragraphs(1).Range.InsertAfter("ПРИЕМ НА РАБОТУ нового сотрудника"); 
            ТекущийДокумент.Paragraphs(1).Range.Font.Size = 30; 
            ТекущийДокумент.Paragraphs(1).Range.Font.Bold = -1;//активируем документ Word1C.Activate();

                            
            для каждого ТекСотрудник из списокСотр цикл
                                
                ВыборкаРезультата = получитьДанные(Тексотрудник.Значение);
                
                Если ВыборкаРезультата.Следующий() тогда
                    
                                    //выводим в первый абзац наш текст, выделяем его и делаем шрифт 30 размера 

                    ИдентификаторОбласти = "{v8 " + "!!!!!!!!!!!" + "}";
                    ТекущийДокумент.Content.Select();
                    Поиск = ТекущийДокумент.Application.Selection.Find;
                    Поиск.Text = ИдентификаторОбласти;
                    Поиск.ClearFormatting();
                    Поиск.Forward = Истина;
                    Поиск.execute();
                    Сел =  ТекущийДокумент.Application.Selection;
                    Фото = ВыборкаРезультата.ФизлицоОсновноеИзображение.Хранилище.Получить();
                    ВременныйФайлКартинки = ПолучитьИмяВременногоФайла(".JPEG");
                    Попытка
                        Фото.Записать(ВременныйФайлКартинки);
                        ЗаписьПрошла = Истина;
                    Исключение
                        ЗаписьПрошла = Ложь;
                    КонецПопытки;
                    
                    Если ЗаписьПрошла Тогда
                        ТекущийДокумент.Tables(2).cell(2,5).Range.InlineShapes.AddPicture(ВременныйФайлКартинки, False, True);
    ТекущийДокумент.tables(2).cell(2,5).range.InlineShapes(1).Width = 100;
    ТекущийДокумент.tables(2).cell(2,5).range.InlineShapes(1).Height = 130;
                        УдалитьФайлы(ВременныйФайлКартинки);
                    КонецЕсли;
                    ТекущийДокумент.Paragraphs(1).Range.InsertAfter("ПРИЕМ НА РАБОТУ нового сотрудника"); 
            ТекущийДокумент.Paragraphs(1).Range.Font.Size = 30; 
            ТекущийДокумент.Paragraphs(1).Range.Font.Bold = -1;//активируем документ Word1C.Activate();

            
                    //ТекущийДокумент.Paragraphs(1).Range.InsertAfter(ВыборкаРезультата.ФизлицоОсновноеИзображение); 

                    //ТекущийДокумент.Paragraphs(1).Range.Font.Size = 30; 

                    //ТекущийДокумент.Paragraphs(1).Range.Font.Bold = -1; //активируем документ Word1C.Activate();

                            
                КонецЕсли;
                        
                        
            КонецЦикла;
    КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует