Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Периодическое "нет связи" на ККМ Штрих-Лайт-01Ф (02Ф)

v7: Периодическое "нет связи" на ККМ Штрих-Лайт-01Ф (02Ф)
Я
   san4ez1008
 
05.06.18 - 04:30
Не выходит банковский чек касса онлайн (модернизированая)
В продолжение данной темы, с банком-то разобрались, теперь проблема собственно с фискальным чеком.. И когда оплата идет бонусами Спасибо+доплата наличкой, после печати чека о начислении бонусов должен печататься фискальный чек, но видимо ККМ еще не готова к печати и выдает ошибку в сабже. Увеличил пустой цикл 
Для й=1 по 50000 цикл
конеццикла;
в 100 раз, еще один пробный заход..пока не знаю как будет. Господин lodger упомянул, что есть "метод спрашивающий у ККМ - "ало, ты готовая?" ", собственно, интересует, что это за метод.
Самое интересное, что до модернизации ККМ никаких проблем не было, т.е. после смены прошивки поменялись какие-то параметры. Может кто-то что-то знает?
 
 
   BalBess
 
1 - 05.06.18 - 06:34
(0) Есть метод ПолучитьКороткийЗапросСостоянияККМ и анализировать состояние РежимККМ (как вариант)
только мне кажется не нужно в цикле без задержки спрашивать состояние, так касса может повесится
   LeXXik
 
2 - 05.06.18 - 08:14
Несовпадение скорости обмена устройства и порта?
Т.е. по железу скорость, предположим 115200, а на порт выставлена 33600. Ну и плюсом - кабель не меняли?
   san4ez1008
 
3 - 05.06.18 - 08:24
(2) подобная проблема на ВСЕХ ККМ,которые были модернизированы. в диспетчере устройств не смотрел,какая скорость выставлена,скорее всего стандартная 4800 а в драйвере ККМ 115200. Не думаю,что в кабеле дело..
   san4ez1008
 
4 - 25.06.18 - 02:16
(2) Кст,заметил разницу,что на новых ККМ (маленькие которые) необходимо более большее количество шагов пустого цикла,чем для старых (длинных). Помимо этого,выставил в диспетчере скорость 115200-изменений к сожалению нет. Это происходит на всех ККМ, так что дело точно не в кабеле. Остается только пробовать метод,описанный в (1)
   Масянька
 
5 - 25.06.18 - 08:23
(0) Ошибка какая?
   tgu82
 
6 - 25.06.18 - 08:44
(4) посмотрите таймаут. Для о2Ф мы увеличивали кажется до 3000. Иначе не хватало времени ему проснуться
   Salimbek
 
7 - 25.06.18 - 10:26
Для й=1 по 50000 цикл
конеццикла;

Не делай так, потому, что 1) для некоторых процессоров этот цикл - вообще плевое дело и почти незаметен, 2) а для слабых процов - будет выполнятся намного дольше - и при этом на 100% загрузит процессор "ничем".
Лучше подключи внешнюю компоненту 1с++ и используй оттуда:

Срв = СоздатьОбъект("Система");
Срв.Уснуть(300);// задержка на 300 мс


Или делишь процедуру на две части. Выполняешь первую часть и в конце подключаешь Обработчик ожидания с периодом вызова в 1 секунду. А в обработчике - выполняешь вторую часть и останавливаешь Обработку ожидания.
   san4ez1008
 
8 - 03.07.18 - 01:52
(5) "ошибка при печати чека,нет связи,чек ККМ не пробит".
(6) поставил таймаут 3000,вроде все норм но жалуются что чек "долго выходит",типа напечатает,остановится и продолжит печатать,поставил 1000-вроде пока не жаловались. Спасибо за подсказку,долго искал где эти таймауты искать,думал вообще в таблицах
   kupec
 
9 - 04.07.18 - 10:22
// Выполнение задержки не менее Сек секунд

Процедура Задержка(Знач Сек) Экспорт 
    Нач=_GetPerformanceCounter();
    Пока 1=1 Цикл
        Если _GetPerformanceCounter()-Нач>=1000*Сек Тогда
            Возврат;
        КонецЕсли;                                   
    КонецЦикла;
КонецПроцедуры
// Проверка ККМ на вывод данных

Функция ПроверкаНаВыводДанных()
    Попытка
        Для Н=1 По 30 Цикл    
            Задержка(1);
            FR.GetECRStatus();
            РежимККМ=FR.ECRAdvancedMode; 
            Если РежимККМ=0 Тогда                                 
                Возврат 1;
            КонецЕсли;
        КонецЦикла;
        Предупреждение("Ошибка вывода данных на печать !!!"+РазделительСтрок+"Порт ККМ занят !!!");
        Возврат 0;
    Исключение
        Предупреждение("Ошибка вывода даных на печать !!!"+РазделительСтрок+СокрЛП(ОписаниеОшибки()));
        Возврат 0;
    КонецПопытки;    
КонецФункции
   Масянька
 
10 - 04.07.18 - 10:25
(8) Подключена по com? В драйвере.
 
 Рекламное место пустует
   Salimbek
 
11 - 04.07.18 - 12:50
(9) И так тоже не делай.
   san4ez1008
 
12 - 05.07.18 - 01:58
(10) ну естественно по COM-порту
(11) не буду) таймаут поставил 1000 и 2000, пока полет нормальный
   Масянька
 
13 - 05.07.18 - 08:27
(12) А через com-порт или эмулятор?
   NikeArz
 
14 - 05.07.18 - 09:03
Для Штрихов можно использовать стандартный метод:
Объект.WaitForPrinting();
Следующий документ не будет печататься пока идет печать предыдущего
   Масянька
 
15 - 05.07.18 - 09:17
+ (13) Я почему интересуюсь: клиент = ТиС 7.7, штрих. Изначально настроили и подключили по Usb +RNDIS. Но - у клиента свисток (сотовый инет) и свисток включается в другой комп. Поэтому ЦТО воткнули com (эмулятор). И вот как воткнули com - чеки то печатает, то нет связи.
Пока был Usb - печатал четко.
   Масянька
 
16 - 05.07.18 - 12:19
Хоть и не моя тема, я тут буду писать.
Притопал спец ЦТО.
Полез в логи: все норм (открытие, товар, цена, колв-о, закрыть) и тут, бац, в конце "Аннулировать"...
   Kigo_Kigo
 
17 - 05.07.18 - 12:48
(16) Верните RDIS, а кассу зацепите ком портом, а не эммулятором,  это первый варик, второй для свистка поставить роутер зиксель 4 джи, и к нему цепануть компы, и работать опять через рдис, у мня так 6 точек работает, полет отличный !
   Масянька
 
18 - 05.07.18 - 12:57
(17) Я пыталась сказать спец из ЦТО (про возврат RNDIS). Но они же самые умные....
Касса, вроде, с вафлей.
Инета нет на компе (комп - 1). И не будет - политика партии.
Есть ноут (дира), в него втыкается свисток - вот такая схема.
Я не пойму - чем RNDIS мешает вафле?
   Kigo_Kigo
 
19 - 05.07.18 - 13:03
(18) Я не пойму - чем RNDIS мешает вафле?
айпиадресом
   Масянька
 
20 - 05.07.18 - 13:04
(19) Понятно...
   Kigo_Kigo
 
21 - 05.07.18 - 13:06
При РДИС выставляеться статический алрес 192.168.137.111 а на компе появляеться типа ДХСП 192.168.137.1, и мост к подключению, а при вафле на машинке ствиться DHCP=1 чтобы фаля дала свой IP  и пустила в интернет, так что физический ком порт решает все проблемы, у меня так и сделано для касс с вафлей
   Kigo_Kigo
 
22 - 05.07.18 - 13:07
Едиственная бядя, у меня уже все запасы планок компортов закончились :)
   Масянька
 
23 - 05.07.18 - 13:11
(21) Спасибо!
   san4ez1008
 
24 - 06.07.18 - 01:49
(13) через эмулятор не пробовали,схема уже отработанная,стоит машина, на ней ККМ подключена по COM-порту,так же в COM-порт втыкаем пин-пад сбербанка и сканер ШК,все отлично работает


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует