Вход | Регистрация


1C Мобильная платформа как открыть окно формы?

1C Мобильная платформа как открыть окно формы?
Я
   ig0z
 
04.06.18 - 17:02
Собственно код ниже не работает, и найти не могу...

НаСервере
Функция СоздатьПоступлениеНаСервере()
    Док = Документы.Поступление.СоздатьДокумент();
    Возврат(Док.ПолучитьФорму("ФормаДокумента"));
КонецФункции

&НаКлиенте
Процедура СоздатьПоступление(Команда)
    ПрекрасныеФормы = СоздатьПоступлениеНаСервере();
    ПрекрасныеФормы.Открыть();
КонецПроцедуры
 
 
   spacehelp
 
1 - 04.06.18 - 17:08
&НаКлиенте
Процедура СоздатьПоступление(Команда)
СтруктураПараметры = Новый Структура;
ОткрытьФорму("Документ.Поступление.ФормаДокумента", СтруктураПараметры);
КонецПроцедуры
   ig0z
 
2 - 04.06.18 - 17:46
(1) Да нифига ... ни так ни так

&НаСервере
Функция СоздатьПоступлениеНаСервере()
    Док = Документы.Поступление.СоздатьДокумент();
    Возврат(Док)//.ПолучитьФорму("ФормаДокумента"));

КонецФункции

&НаКлиенте
Процедура СоздатьПоступление(Команда)
    Параметры = Новый Структура("Ключ",СоздатьПоступлениеНаСервере());
    //ПрекрасныеФормы = СоздатьПоступлениеНаСервере();

    //ПрекрасныеФормы.Открыть();

    ПрекраснаяФорма = ПолучитьФорму("Документ.Поступление.Форма.ФормаДокумента", Параметры);
    ПрекраснаяФорма.Открыть();    
    //ОткрытьФорму("Документ.Поступление.Форма.ФормаДокумента");

КонецПроцедуры
   Cyberhawk
 
3 - 04.06.18 - 17:50
Кончай говнокодить уже: ОткрытьФорму с параметрами + ОбработкаЗаполнения объекта
   Cyberhawk
 
4 - 04.06.18 - 17:51
Ему уже расписали, а он осмеливается писать тут "нифига" и в таком роде...
https://memepedia.ru/wp-content/uploads/2017/06/мем-обама.jpeg

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует