Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

отбор по умолчанию во внешнем отчете в подсистеме ВариантыОтчетов

отбор по умолчанию во внешнем отчете в подсистеме ВариантыОтчетов
Я
   novichok79
 
04.06.18 - 12:49
доброго времени суток, уважаемые коллеги.
имеется УТ 11.4.3.167, с небольшими костылями по специфике предприятия. сделал внешний отчет, формы отчета и настроек - типовые. нужно при открытии отчета формировать список особой номенклатуры программно (попросили запилить отчет быстро, поэтому список этот ищется по сложным дополнительным полям), а потом передавать его в вариант отчета по умолчанию. как такое сделать? заранее благодарю за помощь.
 
 
   novichok79
 
1 - 04.06.18 - 12:51
код модуля объекта отчета


#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда

    
#Область СлужебныеПроцедурыИФункции


// Для внутреннего использования.

Функция СведенияОВнешнейОбработке() Экспорт
КонецФункции

#КонецОбласти

#Область СлужебныйПрограммныйИнтерфейс


// Настройки общей формы отчета подсистемы "Варианты отчетов".

//
// Параметры:

//   Форма - УправляемаяФорма - Форма отчета.
//   КлючВарианта - Строка - Имя предопределенного варианта отчета или уникальный идентификатор пользовательского.

//   Настройки - Структура - см. возвращаемое значение ОтчетыКлиентСервер.ПолучитьНастройкиОтчетаПоУмолчанию().
//

Процедура ОпределитьНастройкиФормы(Форма, КлючВарианта, Настройки) Экспорт
    
    //попробуем устанавливать отборы перед загрузкой варианта отчета

    Настройки.События.ПередЗагрузкойВариантаНаСервере = Истина;
    //Настройки.События.ПриСозданииНаСервере = Истина;

    //Настройки.События.ПриЗагрузкеПользовательскихНастроекНаСервере = Истина;

    
КонецПроцедуры

// Вызывается в одноименном обработчике формы отчета после выполнения кода формы.

//
// Подробнее - см. ОтчетыПереопределяемый.ПередЗагрузкойВариантаНаСервере

//
Процедура ПередЗагрузкойВариантаНаСервере(ЭтаФорма, НовыеНастройкиКД) Экспорт

    Отчет = ЭтаФорма.Отчет;
    КомпоновщикНастроекФормы = Отчет.КомпоновщикНастроек;
    
    // Изменение настроек по функциональным опциям

    НастроитьОтборыПоУмолчанию(КомпоновщикНастроекФормы);
    
    НовыеНастройкиКД = КомпоновщикНастроекФормы.Настройки;
    
КонецПроцедуры

#КонецОбласти
   novichok79
 
2 - 04.06.18 - 12:51
отладчиком в вышеобозначенные функции не попадает, ни фоновым заданием, ни клиентом. по идее в модуле менеджера еще надо прописать пару функций, чтобы оно взлетело. но как это сделать для внешнего отчета?
   novichok79
 
3 - 04.06.18 - 12:55
а все понял, в СведенияОВнешнейОбработке надо вставлять параметр ОпределитьНастройкиФормы

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует