Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Создание кнопки на форме с помощью внешней обработки

Создание кнопки на форме с помощью внешней обработки
Я
   Dev
 
04.06.18 - 08:55
Добрый день интересует такой вопрос, можно ли с помощью внешней обработки добавить кнопку на форме, скажем ввода на основании, при этом не правя конфигурацию, а просто подгрузить внешнюю обработку через стандартный механизм и увидеть после этого кнопку на форме. Или если придется править конфу то по минимуму. Заранее спасибо.
 
 
   shuhard
 
1 - 04.06.18 - 08:57
(0) ты только что открыл для себя механизм расширений
   triviumfan
 
2 - 04.06.18 - 09:03
(0) БСП, внешняя обработка типа "Создание связанных объектов". Гугль в помощь
   Dev
 
3 - 04.06.18 - 09:12
Что то типа этого ?
 ТаблицаКоманд = ПолучитьТаблицуКоманд();

    ДобавитьКоманду(ТаблицаКоманд,
    "Счет-фактура на аванс",
    "Счет-фактура на аванс",
    "ВызовКлиентскогоМетода",
    Истина);

    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

    Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Истина, Модификатор = "")
  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры
   Dev
 
4 - 04.06.18 - 09:25
То есть можно получить список команд я так понимаю, добавить в нее свою и определить ее действие во внешней обработке, верно ?
   FIXXXL
 
5 - 04.06.18 - 09:41
(3) нет, это совсем про другое
а что за "кнопка" нужна? может хватит самой внешней обработки, загруженной в справочник?
   Dev
 
6 - 04.06.18 - 10:48
Нужно чтобы появилась кнопка на форме документа, скажем реализации, чтобы кликая по ней открывался другой док и заполнялся на основании этой реализации
   Cyberhawk
 
7 - 04.06.18 - 10:50
Можно
   Dev
 
8 - 04.06.18 - 10:50
(5) Как не про это, вот, я от сюда взял http://catalog.mista.ru/public/84001/, там как раз приводят пример создания такой обработки
   Dev
 
9 - 04.06.18 - 10:54
(7) Ну вот и хорошо, осталось только сделать
   Cyberhawk
 
10 - 04.06.18 - 11:03
(9) Сколько платишь?
 
 Рекламное место пустует
   Dev
 
11 - 04.06.18 - 11:03
Много, не унесешь ))
   Dev
 
12 - 04.06.18 - 11:22
Подключить, подключил, команда появилась, отладить не получается, пишу в общем модуле ДополнительныеОтчетыИОбработки  ИмяОбработки = Менеджер.Создать("c:\МояОбработка.epf", Ложь); В итоге не создает, вылетает ошибка что файл не обнаружен
   Dev
 
13 - 04.06.18 - 11:23
Может кто сталкивался уже
   Dev
 
14 - 04.06.18 - 11:24
(12) Пишу это в функции ПодключитьВнешнююОбработку
   FIXXXL
 
15 - 04.06.18 - 12:23
(6) как вариант, сделать внешнюю обработку для заполнения ТЧ и в ней извращаться
в общих модулях не надо ничего писать
   Dev
 
16 - 04.06.18 - 12:33
Это нужно было для отладки, а потом нужно было все удалить, для отладки обработки нужно чтобы она физически где то была, поэтому я и хотел создать
   Dev
 
17 - 04.06.18 - 12:39
Этот код я нашел вот здесь http://www.obrabotki.com/otladka-bsp-1s/, но он не работает
   Dev
 
18 - 04.06.18 - 13:01
В общем все работает, просто обработка оказывается уже должна там находиться

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует