Вход | Регистрация


Переместить файлы из каталога в каталог на FTP

Переместить файлы из каталога в каталог на FTP
Я
   Pro1001C
 
01.06.18 - 16:13
Добрый день

Подскажите такой момент. Пытаюсь перемести файлы с одного каталога на фтп в другой каталог.
СоединениеFTP = ПодключитьсяКFTPСерверу();
СоединениеFTP.УстановитьТекущийКаталог("/otkuda");
ФайлыXML = СоединениеFTP.НайтиФайлы(СоединениеFTP.ТекущийКаталог(),"*.xml");
    
Для Каждого Файл Из ФайлыXML Цикл
        
        СоединениеFTP.Переместить("/otkuda/"+Файл.Имя,"/kuda/"+Файл.Имя);
        
КонецЦикла;

Первый раз перемещение отрабатывает как надо. Из каталога otkuda все файлы удаляются, в каталог kudaвсе файлы перемещаются. 
Но когда делаю второй раз, те же файлы перемещаю из каталога otkudaв каталог kuda (а в каталоге kuda файлы такие же уже лежат) выдает ошибку 
Ошибка работы с Интернет:  ftp://мойадрес" target="_blank" rel="nofollow" class="extralink">ftp://мойадрес Quote command returned error

Все необходимые права на чтение, изменение, удаление есть. В чем может быть дело?
 
 
   Pro1001C
 
1 - 01.06.18 - 16:15
Так подключаюсь

Функция ПодключитьсяКFTPСерверу()
 
    Соединение = Новый FTPСоединение(
        "00.000.00.00",// адрес ftp сервера

        21,// порт сервера

        "user",// имя пользователя

        "passvord",// пароль пользователя

        Неопределено,// прокси не используется

        Истина,// пассивный режим работы

        0,// таймаут (0 - без ограничений)

        Неопределено// незащищенное соединение

    );
         
    Возврат Соединение;
 
КонецФункции
   piter3
 
2 - 01.06.18 - 16:16
   lubitelxml
 
3 - 01.06.18 - 16:17
ты пытаешься переместить файл в папку, где такой файл уже существует?
   Cool_Profi
 
4 - 01.06.18 - 16:17
Логи сервера что говорят?
   Pro1001C
 
5 - 01.06.18 - 16:18
(3) да
   lubitelxml
 
6 - 01.06.18 - 16:19
(5) текущий каталог переопределяешь после первого прохода?
   Pro1001C
 
7 - 01.06.18 - 16:26
(6) не совсем понял. Код в (0) открыл обработку, запустил, первый раз все сработало как нужно. Через браузер зашел в каталог kuda, скопировал вручную файлы в каталог otkuda. Открыл опять обработку с кодом из (0), запустил, вышло сообщение
   Pro1001C
 
8 - 01.06.18 - 16:54
При этом удаление спокойно отрабатывает 


Для Каждого Файл Из ФайлыXML Цикл
        
Попытка         СоединениеFTP.Переместить("/otkuda/"+Файл.Имя,"/kuda/"+Файл.Имя);
Исключение
СоединениеFTP.Удалить("/otkuda/",Файл.Имя);
КонецПопытки
        
КонецЦикла;



Но все же хотелось бы переместить с перезаписью файлов. Может есть другие варианты?
   lubitelxml
 
9 - 01.06.18 - 18:46
а если попробовать их сохранить в каталог временных файлов и оттуда перезапись на фтп? ЗЫ: https://forum.infostart.ru/forum9/topic70655/
   lubitelxml
 
10 - 01.06.18 - 19:01
FTPСоединение (FTPConnection)
Переместить (Move)
Синтаксис:

Переместить(<Источник>, <Приемник>)
Параметры:

<Источник> (обязательный)

Тип: Строка.
Имя файла или каталога источника на сервере. 
<Приемник> (обязательный)

Тип: Строка. 
Имя файла или каталога приемника на сервере.
Описание:

Переименовывает файлы и каталоги на сервере.

Доступность:

Тонкий клиент, сервер, толстый клиент, внешнее соединение

Обрати внимание на слово "Переименовывает файлы и каталоги на сервере"
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует