Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Сообщение пользователю с привязкой к реквизиту формы типа СписокЗначений

Сообщение пользователю с привязкой к реквизиту формы типа СписокЗначений
Я
   Mr Man
 
01.06.18 - 15:59
Добрый день. Упр. формы. На форме обработки есть реквизит типа СписокЗначений.

Каким образом сделать привязку на незаполненную конкретную строку этого списка?? Делаю так:

&НаКлиенте
Процедура Команда1(Команда)
    НомСтр = 1;
    Для каждого стрТЗ Из ВладельцыФорма Цикл
        Если Не ЗначениеЗаполнено(стрТЗ.Значение) Тогда
            Сообщение = новый СообщениеПользователю;
                                
            Сообщение.Текст = "В строке №" + НомСтр +" владелец должен быть заполнен!";
            Сообщение.Поле = "ВладельцыФорма["+НомСтр+"].Значение";            
            Сообщение.Сообщить();
            
            Отказ = Истина;    
        КонецЕсли; 
        НомСтр = НомСтр + 1;
    КонецЦикла;     

КонецПроцедуры

Не делает привязку на пустую строку.
 
 
   Mr Man
 
1 - 01.06.18 - 16:31
ап

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует