Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Сделать недоступной строку таб. поля

Сделать недоступной строку таб. поля
Я
   lirt82
 
01.06.18 - 15:49
Всем привет, в конфе на обычных формах есть самописный регистр сведении, у него есть ФормаСписка на форме есть РегистрСведенийСписок тип Табличное поле в табличном поле есть колонка Утвержден тип Булево. Задачка нужно не давать изменить строку если в ней Утвержден = Истина конкретному пользаку. Проблема в том что не могу подобрать метод табличного поля чтоб заблокировать строку от изменения. Выбрал ПередНачаломИзменения(<Отказ>) Описание: Возникает перед началом интерактивного изменения существующей строки табличного поля. Код отрабатывает но у меня все табличное поле становиться недоступным:)
Если Элемент.ТекущиеДанные.Утвержден Тогда
        Отказ = Истина;
    КонецЕсли; 
А у ТекущейСтроки нет свойства ТолькоПросмотр. Что посоветуете, какое событие выбрать?
 
 
   spiller26
 
1 - 01.06.18 - 15:57
Попробуйте обработать событие ПриВыводеСтроки()

 ОформлениеСтроки.Ячейки.Утвержден.ТолькоПросмотр = Истина;
   spiller26
 
2 - 01.06.18 - 16:02
Процедура ТабличнаяЧастьПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
   Если Не РольДоступна("ПолныеПрава") Тогда
      Если ЭтоНовый() ИЛИ ЭтотОбъект.Модифицированность() Тогда
          ОформлениеСтроки.Ячейки.ДатаЗавершения.ТолькоПросмотр = Ложь;
      Иначе
          Если  ЗначениеЗаполнено(ДанныеСтроки.ДатаЗавершения) Тогда 
             ОформлениеСтроки.Ячейки.ДатаЗавершения.ТолькоПросмотр = Истина;
          Иначе
             ОформлениеСтроки.Ячейки.ДатаЗавершения.ТолькоПросмотр = Ложь;
          КонецЕсли;
      КонецЕсли;
   КонецЕсли;
КонецПроцедуры
   hhhh
 
3 - 01.06.18 - 16:06
(0) ПриАктивизацииСтроки можно
   youalex
 
4 - 01.06.18 - 16:29
У Оформления строки кажись было, или у ячеек оформления, или (и) у самого оформления

Список тем форума
Рекламное место пустует  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует