Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Запрет добавления пустой строки в табличную часть

Запрет добавления пустой строки в табличную часть
Я
   Mr Man
 
01.06.18 - 12:48
Доброго времени суток. Управляемые формы. Есть ТЧ у справочника.

Каким образом запретить программно добавление пустых строк в эту ТЧ??

Делаю событием 

&НаКлиенте
Процедура ВладельцыФормаПередОкончаниемРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования, Отказ)
    Если Элемент.ТекущиеДанные <> Неопределено Тогда
        Если НЕ ЗначениеЗаполнено(Элемент.ТекущиеДанные.Значение) Тогда     
            ОтменаРедактирования = Истина;     
            НоваяСтрока = Ложь;
            Отказ = Истина;                 
        КонецЕсли;
    КонецЕсли;
 КонецПроцедуры

Но система снова предлагает после выполнения процедуры ввести значение.
 
 
   butterbean
 
1 - 01.06.18 - 12:50
а ты что от нее ждешь?
   catena
 
2 - 01.06.18 - 12:56
Отказ = Истина;  - запрещаете закончить редактирование? Даже если случайно кто-то на кнопку инсерт сел?
   Малыш Джон
 
3 - 01.06.18 - 12:59
(0) сама постановка задачи не очень верная, отсюда и решение неверное

как можно запретить добавлять пустую строку? Если строка добавляется не копированием - она по умолчанию пустая.
   mistеr
 
4 - 01.06.18 - 13:00
(2) Пусть пересядет на кнопку Esc.
   Mr Man
 
5 - 01.06.18 - 13:35
(3) если пользователь добавляет строку, не выбирает значение то нужно не давать создавать эту пустую строку системе.
   novichok79
 
6 - 01.06.18 - 13:37
перед записью удаляй пустые строки и все.
   novichok79
 
7 - 01.06.18 - 13:37
перед записью объекта имелось в виду
   novichok79
 
8 - 01.06.18 - 13:38
при доработке подобных заданий всегда надо думать что делать, если пользователь не откроет форму а перезапишет объект программно или через контекстное меню
   Mr Man
 
9 - 01.06.18 - 13:43
(8) да, спасибо, так и поступлю. Не нашел обработчика, в котором можно было бы удалить пустую новую добавленную строку.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует