Вход | Регистрация


Как при открытии в пустом форматированном док. установить шрифт?

Как при открытии в пустом форматированном док. установить шрифт?
Я
   RomaH
 
31.05.18 - 12:21
В конфигураторе добавлен реквизит формы
выведен на форму
задан шрифт 14

но при открытии шрифт в ФД маленький

после заполнения ФД делаю код:

    ШрифтВставляемогоТекста = Элементы.МикроскопическоеОписаниеФД.Шрифт;
    
    Для Каждого ПараграфФД Из МикроскопическоеОписаниеФД.Элементы Цикл
        Для Каждого ЭлементФД из ПараграфФД.Элементы Цикл

            Если ТипЗнч(ЭлементФД) = Тип("ТекстФорматированногоДокумента") Тогда
                ЭлементФД.Шрифт = ШрифтВставляемогоТекста;
            КонецЕсли;
            
        КонецЦикла;
    КонецЦикла;


и шрифт ставится 

но при создании новго документа элементов в ФД нет
как ему шрифт установить?
 
 
   RomaH
 
1 - 31.05.18 - 13:09
мда

пока только так:

        ФорматированнаяСтрока = Новый ФорматированнаяСтрока(" ");
        МакроскопическоеОписаниеФД.УстановитьФорматированнуюСтроку(ФорматированнаяСтрока);

    Для Каждого ПараграфФД Из МакроскопическоеОписаниеФД.Элементы Цикл
        Для Каждого ЭлементФД из ПараграфФД.Элементы Цикл

            Если ТипЗнч(ЭлементФД) = Тип("ТекстФорматированногоДокумента") Тогда
                ЭлементФД.Шрифт = ШрифтВставляемогоТекста;
                Если ПустаяСтрока(ЭлементФД.Текст) Тогда
                    ЭлементФД.Текст = "";
                КонецЕсли;
            КонецЕсли;
            
        КонецЦикла;
    КонецЦикла;
   RomaH
 
2 - 31.05.18 - 19:45
а к то-нибудь по серьёзному ФД использует?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует