Вход | Регистрация


Ошибка информации расшифровки

Ошибка информации расшифровки
Я
   Сергей Роспатнюк
 
31.05.18 - 09:51
подскажите добрые люди где я допустил ошибку при нажатии на поле отчета выдает ошибка информации расшифровки: не найдена расшифровываемая группировка.


&НаКлиенте
Процедура Выгрузить(Команда)
    
    СформироватьОтчётПрограммно();
        
КонецПроцедуры

Функция СформироватьОтчётПрограммно()
        
    ОтчетОбъект = РеквизитФормыВЗначение("Отчет");        // Упр. прил.

    
    //--- Инициализация СКД

    Если Истина Тогда
        
        ДанныеРасшифровки_Вр    = Новый ДанныеРасшифровкиКомпоновкиДанных;    
        СхемаКомпоновкиДанных    = ОтчетОбъект.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");    
        Компоновщик                = Новый КомпоновщикНастроекКомпоновкиДанных;
        Компоновщик.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));    
        Компоновщик.ЗагрузитьНастройки(СхемаКомпоновкиДанных.НастройкиПоУмолчанию);        
        
    КонецЕсли;
    //--- Инициализация СКД (Конец)

    
    //------------------

    
    Настройки    = Компоновщик.ПолучитьНастройки();
    
    Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("НачалоПериода",                    Отчет.НачалоПериода);
    Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("КонецПериода",                    Отчет.КонецПериода);    
    Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Организация",                    Отчет.Организация);
    Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Сотрудник_Наименование",            Отчет.Сотрудник);
    
    //--- Вывод результата СКД    

    Если Истина Тогда
        ДанныеРасшифровкиОтчета     = Новый ДанныеРасшифровкиКомпоновкиДанных;
        
        КомпоновщикМакета             = Новый КомпоновщикМакетаКомпоновкиДанных;    
        МакетКомпоновкиДанных        = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки_Вр);    
        ДанныеРасшифровки             = ПоместитьВоВременноеХранилище(ДанныеРасшифровкиОтчета, УникальныйИдентификатор);
        
        
        //------------------    

        ПроцессорКомпоновкиДанных     = Новый ПроцессорКомпоновкиДанных;
        ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновкиДанных,,ДанныеРасшифровкиОтчета);      //ДанныеРасшифровки_Вр

        
        //Результат = ЭлементыФормы.Результат;        // Об. прил.

        Результат.Очистить();
        
        Результат_Вр                = Новый ТабличныйДокумент();
        
        ПроцессорВывода                = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
        ПроцессорВывода.УстановитьДокумент(Результат);
        ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
        
    КонецЕсли;        
    //--- Вывод результата СКД (Конец)

    
    Элементы.Результат.ОтображениеСостояния.Видимость = Ложь; 
    Элементы.Результат.ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.НеИспользовать;
    
КонецФункции
 
 
   DrShad
 
1 - 31.05.18 - 09:54
во-первых это нужно было делать не в форме
во-вторых забыл по этой конструкции ОтчетОбъект = РеквизитФормыВЗначение("Отчет");        // Упр. прил.


сделать обратную ЗначениеВРеквизитФормы
   Сергей Роспатнюк
 
2 - 31.05.18 - 09:58
(1) то есть это все необходимо делать в модуле объекта?
   DrShad
 
3 - 31.05.18 - 10:00
в ПриКомпоновкеРезультата

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует