Вход | Регистрация


Печатные формы 1с ЗУП

Печатные формы 1с ЗУП
Я
   nikast
 
30.05.18 - 13:51
Здравствуйте, имеется ЗУП 3.1 типовая, необходимо изменить стандартный трудовой договор.
Если честно мне не хотелось бы менять стандартный а добавить свой..
Поэтому возник вопрос как лучше сделать ? Почитал что есть возможность через Печатные формы и отчеты. Может есть возможность добавить макеты печатных форм из конфигуратора. Спасибо.
 
 
   Amra
 
1 - 30.05.18 - 13:55
Про такую вещь, как внешняя печатная форма знаешь?
   shuhard
 
2 - 30.05.18 - 13:56
(0)[ Стаж: 6 лет 5 месяцев 23 дня ]
а казачок то засланный (с)
   SleepyHead
 
3 - 30.05.18 - 13:56
(0) "как лучше сделать"

А насколько своя форма отличается от стандарта? Есть ли в "своей" печатной форме реквизиты, которых нет в стандартной?

Отличается только формулировками, а состав показателей тот же - один случай.

Есть особые показатели, которых нет в стандарте - другой случай.
   nikast
 
4 - 30.05.18 - 14:00
(3) Состав показателей тот же, возможно, что-то потребуется добавить в будущем, но пока так.
   SleepyHead
 
5 - 30.05.18 - 14:01
(4) Тогда сделайте свой макет в печатных формах. Возможно, позднее вам придется добавить ВПФ.
   Boleev
 
6 - 30.05.18 - 14:05
Есть много трудовых договоров для ЗУП 3.1 на внешних печатных формах
   nikast
 
7 - 30.05.18 - 14:06
(5) Просто я пытаюсь понять в чем ограничение, создавая макет. Т.е лучше сразу смотреть в сторону ВПФ ?
   nikast
 
8 - 30.05.18 - 14:07
(6) Есть возможность найти free ?
   d4rkmesa
 
9 - 30.05.18 - 14:07
(0) Лучше сразу сделайте внешнюю печатную форму. Команда/процедура печати примерно так будет выглядеть:

Функция ПечатьТрудовогоДоговора(МассивОбъектов, ОбъектыПечати, ПараметрыВывода, МестоРаботыИГрафик = 0)
    
    Макет = ПолучитьМакет("ПФ_MXL_МакетТрудовойДоговорВПФ");
    
    ДокументРезультат = Новый ТабличныйДокумент;
    НомерСтрокиНачало = ДокументРезультат.ВысотаТаблицы + 1;
    
    ДокументРезультат.КлючПараметровПечати = "ПараметрыПечати_ТрудовойДоговорВПФ2018";
    ДанныеДоговоров = КадровыйУчет.ДанныеТрудовыхДоговоров(МассивОбъектов, Ложь, Ложь);    
    
    Для каждого ДанныеДоговора Из ДанныеДоговоров Цикл
        
        Если МассивОбъектов.Количество() = 1
            И ЗначениеЗаполнено(ДанныеДоговора.EMail) Тогда
            
            ПараметрыВывода.ПараметрыОтправки.Получатель = ДанныеДоговора.EMail;
            ПараметрыВывода.ПараметрыОтправки.Тема = НСтр("ru='Трудовой договор'");
            
            Если ЗначениеЗаполнено(ДанныеДоговора.ТрудовойДоговорНомер) Тогда
                ПараметрыВывода.ПараметрыОтправки.Тема = ПараметрыВывода.ПараметрыОтправки.Тема + " №" + ДанныеДоговора.ТрудовойДоговорНомер;
            КонецЕсли;
            
            Если ЗначениеЗаполнено(ДанныеДоговора.ТрудовойДоговорДата) Тогда
                
                ПараметрыВывода.ПараметрыОтправки.Тема = ПараметрыВывода.ПараметрыОтправки.Тема
                    + " " + НСтр("ru='от'") + " " + ДанныеДоговора.ТрудовойДоговорДата;
                
            КонецЕсли;
            
        КонецЕсли;
        
        НомерСтрокиНачало = ДокументРезультат.ВысотаТаблицы + 1;
        
        Если НомерСтрокиНачало > 1 Тогда
            ДокументРезультат.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        
        //ПараметрыНумерации = Новый Структура;

        //УстановитьНомерРазделаВПараметрахНумерации(ПараметрыНумерации, 1);

        //УстановитьНомерПунктаВПараметрахНумерации(ПараметрыНумерации, 1);        

        
        ВыводимаяОбласть = Макет.ПолучитьОбласть("ОблДокумент");        
        ВыводимаяОбласть.Параметры.Заполнить(ДанныеДоговора);        
        
        ДокументРезультат.Вывести(ВыводимаяОбласть);
        
        УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ДокументРезультат, НомерСтрокиНачало, ОбъектыПечати, ДанныеДоговора.Ссылка);
        
    КонецЦикла;    
    
    Возврат ДокументРезультат;
    
КонецФункции
   SleepyHead
 
10 - 30.05.18 - 14:08
(7) Ограничение в составе показателей, выводимых в отчет.
 
 Рекламное место пустует
   d4rkmesa
 
11 - 30.05.18 - 14:09
Однако, стандартные процедуры, вроде КадровыйУчет.ДанныеТрудовыхДоговоров заточены под стандартный договор, так буквально ничего лишнего. Если понадобится что-то еще, нужно будет свое наваять.
   nikast
 
12 - 30.05.18 - 14:14
Все понял, спасибо большое за ответы.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует