Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Изменение должности сотрудника.

↓ [Serg_1960, 30.05.18 - 12:07]
Изменение должности сотрудника.
Я
   palima
 
30.05.18 - 11:20
Привет, растолкуйте пожалуйста, почему программа вызывает ошибку "{Форма.Форма.Форма(50)}: Поле объекта недоступно для записи (Должность)
                Выборка.Должность = ДолжностьВ;
"



    Запрос = Новый Запрос;
    Запрос.Текст = "
    |ВЫБРАТЬ
    |    Сотрудники.Ссылка КАК Сотрудник,
    |    Сотрудники.Должность.Наименование КАК Должность
    |ИЗ
    |    Справочник.Сотрудники КАК Сотрудники";
    Выборка = Запрос.Выполнить().Выбрать();
    СотрудникВ = "Иванов";
    ДолжностьВ = "водитель";
    Пока Выборка.Следующий() Цикл
        Если Выборка.Сотрудник = СотрудникВ Тогда
            Выборка.Должность = ДолжностьВ;
        КонецЕсли;
    КонецЦикла;
 
 
   Beduin
 
1 - 30.05.18 - 11:21
(0) Ты пишешь в запрос
   piter3
 
2 - 30.05.18 - 11:21
получитьобъект
   palima
 
3 - 30.05.18 - 11:27
Пока Выборка.Следующий() Цикл
Если Выборка.Сотрудник = СотрудникВ Тогда
Док = Выборка.ПолучитьОбъект();
Док.Должность = ДолжностьВ;
Док.Записать();
КонецЕсли;
КонецЦикла;
   palima
 
4 - 30.05.18 - 11:29
{Форма.Форма.Форма(50)}: Метод объекта не обнаружен (ПолучитьОбъект)
                Док = Выборка.ПолучитьОбъект();
   palima
 
5 - 30.05.18 - 11:29
я уже не знаю что делать(
   Beduin
 
6 - 30.05.18 - 11:31
(4) Выборка.Ссылка.ПолучитьОбъект().Должность = ДолжностьВ;
   Джинн
 
7 - 30.05.18 - 11:33
(5) Что делать понятно - ЖКК читать.
   Numerus Mikhail
 
8 - 30.05.18 - 11:34
(6) а записать потом как?
   Serg_1960
 
9 - 30.05.18 - 11:46
Все советы - в урну. Кроме (7)
Автору назад в школу - учиться гуглить, читать и правильно вопросы задавать.
   Serg_1960
 
10 - 30.05.18 - 12:05
СотрудникОбъект = Справочники.Сотрудники.НайтиПоНаименованию("Иванов").ПолучитьОбъект();
СотрудникОбъект.Должность = Справочники.Должности.НайтиПоНаименованию("водитель");
СотрудникОбъект.Записать();
 
 Рекламное место пустует
   palima
 
11 - 30.05.18 - 16:12
(10) спасибо большое, с вашей подачи все получилось и даже больше :)
   Serg_1960
 
12 - 30.05.18 - 21:58
Не благодари. Этот алгоритм допустим только на начальном этапе освоения и обучения, но абсолютно не подходит для использования в реальной работе.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует