Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Добавление строки в файл

Добавление строки в файл
Я
   b-dm
 
30.05.18 - 10:53
Почему то не добавляются строки в файл,всегда одна строка,
добавление не происходит подскажите по возможности плз:
Если НачалоКвартала(Источник.Дата)<>НачалоКвартала(ТекущаяДата()) Тогда
        КаталогЗагрузки=СтрокаСоединенияИнформационнойБазы();
        МассивФайлов=НайтиФайлы("d:\base","*.lg")//Найти в заданном каталоге все файлы с расширением *.lg

        лФлаг=Ложь;
        Для Каждого ИмяФайла Из МассивФайлов Цикл

            Текст=Новый ТекстовыйДокумент();
            Текст.ДобавитьСтроку(ИмяПользователя()+"  "+СтрокаСоединенияИнформационнойБазы()+"   "+Строка(Источник));
            Текст.Записать("d:\base\lg.lg");
           
            лФлаг=Истина;
            Прервать;
        КонецЦикла;
        Если лФлаг=Ложь Тогда
            Текст=Новый ТекстовыйДокумент();
            Текст.ДобавитьСтроку(ИмяПользователя()+"  "+СтрокаСоединенияИнформационнойБазы()+"   "+Строка(Источник));
            Текст.Записать("d:\base\lg.lg");
        КонецЕсли;
    КонецЕсли;
 
 
   1Сергей
 
1 - 30.05.18 - 10:54
а где Прочитать?
   b-dm
 
2 - 30.05.18 - 10:56
(1) - можно развернутее ?
   1Сергей
 
3 - 30.05.18 - 10:57
(2) ну, ты каждый раз создаёшь документ заново. Либо создавай один раз, и дописывай. Либо каждый раз перед добавлением строки считывай из файла
   1Сергей
 
4 - 30.05.18 - 10:58
ТекстовыйДокумент (TextDocument)
Прочитать (Read)
Синтаксис:

Прочитать(<ИмяФайла>, <ТипФайла>, <РазделительСтрок>) 

© СП

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует