Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Не отрабатывает расширение в клиент-серверном варианте

Не отрабатывает расширение в клиент-серверном варианте
Я
   Gladiator4021
 
30.05.18 - 08:51
Добрый день. У клиента была конфигурация УНФ 1.6 с дописанным функционалом с помощью расширений. Перенесли базу на сервер Postgre расширения которые были при переносе работают исправно , но если добавляеш ,допустим, кнопку она на форме появляется но код её не отрабатывает и отладка не останавливается. Скажите в чем может быть проблема.
 
 
   Flover
 
1 - 30.05.18 - 09:09
(0)+ тоже интересно.
перетащили базу ЕРП на новый сервер, добавляемые процедуры не работают. Если снимать галочку "Безопасный режим" с расширения - система удаляет расширение.
Проблемой вплотную не занимался, но есть интерес что за чертовщина такая.
   Gladiator4021
 
2 - 30.05.18 - 09:32
(1) что значит на новый сервер? выгрузить dt и загрузить в новую чтоли?
   Flover
 
3 - 31.05.18 - 08:35
(2) Да.
   Фрэнки
 
4 - 31.05.18 - 08:43
(0)//  и отладка не останавливается


в серверном режиме нужно "включить отладку на сервере"

Вряд ли это будет для заказчика удобно (держать постоянно включенным режим отладки на продакшн-сервере), поэтому часто отладку делают на файловой версии и устанавливают расширения в режиме предприятия в администрировании. Ставят также отдельный сервак для разработчиков, чтоб на нем были возможности для запуска отладки.
   Flover
 
5 - 31.05.18 - 08:47
(0) Свой случай поборол следующим образом вчера:

выгрузил расширение в файл, удалил расширение из базы, создал новое расширение в базе, через "сравнить объединить" залил из файла со снятыми галочками на "Свойства"
Все заработало.
Если делать "загрузить из файла" - не работает.
   Flover
 
6 - 31.05.18 - 08:52
(4) это глюк с расширением, отладка не перехватывает события в расширении - как бы его не видит, и код расширения не отрабатывается, хотя реквизиты, добавленные в расширении видны в режиме клиента, включение отладки на сервере не причем тут. Я то же это словил.
   Фрэнки
 
7 - 31.05.18 - 09:19
(6) Так я не отрицаю того, что это может быть глюк и задаю вопрос о том, какие версии платформы используются.

У меня работает и в отладке на сервере тоже. У всех оно работает или не у всех - не знаю. Но поведение расширений очень сильно от версии платформы зависит. И от режима совместимости, кстати. Указано, что это УНФ 1.6, а случайно в нем какой-то режим совместимости указан или нет? Сто лет в УНФ не заглядывал :)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует