Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Сравнение двух ТЗ по общей колонке

Сравнение двух ТЗ по общей колонке
Я
   palima
 
29.05.18 - 10:58
Всем привет. Есть ТЗ_1 и ТЗ_2. Обе таблицы значений имеют колонки Сотрудник и Должность.
Нужно по полному соответствию ВРег(Строка(Сотрудник)) перенести должность из ТЗ_1 в ТЗ_2. Помогите пожалуйста это сделать :(
 
 
   vicof
 
1 - 29.05.18 - 10:59
Сдаётся мне, решение задачи выбрано изначально черезжопное
   anatoly
 
2 - 29.05.18 - 11:00
бюджет и полные условия?
   Гипервизор
 
3 - 29.05.18 - 11:01
(0) Сотрудник строкового типа?
   palima
 
4 - 29.05.18 - 11:02
(1) предложите получше...
(3) да
   craxx
 
5 - 29.05.18 - 11:05
(0) запросы уже упразднили?
   impulse9
 
6 - 29.05.18 - 11:05
Я бы запросом сделал
   1Сергей
 
7 - 29.05.18 - 11:07
можно запросом, можно перебором. На что мозгов хватит
   _Дайвер_
 
8 - 29.05.18 - 11:08
(0) Либо запросом делай через соединение, оптимальный вариант... Либо что-то как-то так...
Для каждого ТекСтрока Из ТЗ_1 Цикл
Сотрудник = ВРег(ТекСтрока.Сотрудник);
Должность = ТекСтрока.Должность;
Для каждого ТекСтрока Из ТЗ_2 Цикл
Сотрудник2 = Врег(ТекСтрока.Сотрудник);
Если Сотрудник = Сотрудник 2 Тогда
ТекСтрока.Должность = Должность;
КонецЕсли; 
КонецЦикла;
КонецЦикла;
   shadow_sw
 
9 - 29.05.18 - 11:09
сразу ответы сдали...
   _Дайвер_
 
10 - 29.05.18 - 11:09
(8) Врег() тут нахер не нужен, а вот СокрЛП будет не лишним
 
 Рекламное место пустует
   palima
 
11 - 29.05.18 - 11:11
(7) к сожалению мозгов хватает максимум на перебор
(8) спасибо за подсказку, а при сравнении строк регистр не учитывается? Тогда действительно не нужен..
   1Сергей
 
12 - 29.05.18 - 11:17
в запросе не учитывается. В коде учитывается
   anatoly
 
13 - 29.05.18 - 11:24
подготовить 2 ТЗ - запросом их объединить - профит.

но я уже сказал - могут быть всякие еще условия в задаче...
   palima
 
14 - 29.05.18 - 11:29
(13) Если упрощенно, то есть ТЗ (Сотрудник,Должность), взятая из другой базы через COMConnector. А моя задача в моем справочнике сотрудников позаменять должности если имя сотрудника полностью совпадает...
   1Сергей
 
15 - 29.05.18 - 11:31
(14) тебе ж дали рыбу в (8)
   palima
 
16 - 29.05.18 - 11:31
(15) да, я этой штукой и воспользовалась :)
   1Сергей
 
17 - 29.05.18 - 11:38
(16) ну и норм. поздравляю. А запросы учи
   palima
 
18 - 29.05.18 - 11:41
(17) Спасибо
Всем больше спасибо за помощь!
   МихаилМ
 
19 - 29.05.18 - 11:50
(0)
http://catalog.mista.ru/public/326983/

но там не лучшие есть еще построитель запроса и скд

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует