Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Установить поле флажка в программно формируемой ТЗ на форме

Установить поле флажка в программно формируемой ТЗ на форме
Я
   Len1vec
 
29.05.18 - 09:04
Добрый день!
Подскажите, пожалуйста, как правильно установить тип поля таблицы значений "Поле флажка", выводимой на форме, для поля "Печатать" типа "Булево" передаваемой таблицы значений?
Может не в том месте это делаю?

&НаСервере
Процедура СоздатьТаблицуФормы(Знач ИмяПоляТаблицыФормы, Знач ИмяРеквизитаДанныеФормыКоллекция, Знач ТаблицаЗначений)
    Если Элементы.Найти(ИмяПоляТаблицыФормы) = Неопределено Тогда
        ЭлементРеквизита = Элементы.Добавить(ИмяПоляТаблицыФормы, Тип("ТаблицаФормы"),);
        ЭлементРеквизита.ПутьКДанным = ИмяРеквизитаДанныеФормыКоллекция;
    КонецЕсли;
    
    УдаляемыеРеквизиты = Новый Массив;
    РеквизитыДляУдаления = ПолучитьРеквизиты(ИмяРеквизитаДанныеФормыКоллекция);
    Для Каждого РеквизитУдаления Из РеквизитыДляУдаления Цикл
        УдаляемыеРеквизиты.Добавить(ИмяРеквизитаДанныеФормыКоллекция+"."+РеквизитУдаления.Имя);
        
        Элементы.Удалить(Элементы[ИмяПоляТаблицыФормы+РеквизитУдаления.Имя]);
    КонецЦикла;
    
    ДобавляемыеРеквизиты = Новый Массив;
    Для каждого Колонка Из ТаблицаЗначений.Колонки Цикл
        ДобавляемыеРеквизиты.Добавить(Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения, ИмяРеквизитаДанныеФормыКоллекция, Колонка.Заголовок));
    КонецЦикла;
    ИзменитьРеквизиты(ДобавляемыеРеквизиты,УдаляемыеРеквизиты);
    
    Для каждого Колонка Из ТаблицаЗначений.Колонки Цикл
        ЭлементРеквизита = Элементы.Добавить(ИмяПоляТаблицыФормы + Колонка.Имя, Тип("ПолеФормы"), Элементы[ИмяПоляТаблицыФормы]);
        ЭлементРеквизита.ПутьКДанным = ИмяРеквизитаДанныеФормыКоллекция + "." + Колонка.Имя;
        Если Колонка.Имя = "Печатать" Тогда
            ЭлементРеквизита.Вид = ВидПоляФормы.ПолеФлажка;
        Иначе    
            ЭлементРеквизита.Вид = ВидПоляФормы.ПолеВвода;
        КонецЕсли; 
        
    КонецЦикла;
    
    ЗначениеВРеквизитФормы(ТаблицаЗначений, ИмяРеквизитаДанныеФормыКоллекция);      
КонецПроцедуры
 
 
   Trebamne
 
1 - 29.05.18 - 09:11
Добрый день пишите сюда
https://apdate.by/forum
Тут Вам без стеба помогут
   ildary
 
2 - 29.05.18 - 09:21
(1) Сейчас вас со стебом (или без него) забанят.
   Len1vec
 
3 - 29.05.18 - 09:52
(2) в пень его)))
   Trebamne
 
4 - 29.05.18 - 09:55
Не проблема пройти регистрацию ещё и ещё раз )))
   Len1vec
 
5 - 29.05.18 - 10:00
Может по теме лучше пообщаемся? Я не понимаю, как реализовать данный функционал(
   hhhh
 
6 - 29.05.18 - 10:08
(4) не надоело вам подобное дерьмо рекламировать?
   Воронеж2019
 
7 - 29.05.18 - 15:48
(6) а чем он дерьмо то? Я уже два года там и меня там все устраивает (3) вот вы написали и что дальше Вам помогли? Нет а на том форуме быстро отвечают
   dezss
 
8 - 29.05.18 - 15:52
(0) так что не получается...лучше скрины покажи...
   ildary
 
9 - 29.05.18 - 15:57
(7) Вы охренели? Этот форум тырит контент мисты. Удивляюсь, почему модеры спят и не чистят ссылки на него.
   dezss
 
10 - 29.05.18 - 16:06
(9) да и выглядит он как...хм...мамонта)
 
 Рекламное место пустует
   Воронеж2019
 
11 - 29.05.18 - 16:10
Ну не знаю мне он нравится и удобный в работе с мобильного
   Воронеж2019
 
12 - 29.05.18 - 16:10
Да и не банят там )
   dezss
 
13 - 29.05.18 - 16:11
(12) это минус

Модеры, забаньте тролля, плиз.
   ildary
 
14 - 29.05.18 - 16:13
(12) там не банят, потому что там два живых пользователя -  Trebamne и Воронеж2019. И то скорей всего это создатель сайта, Aleksandr_Nikonov
   Воронеж2019
 
15 - 29.05.18 - 17:57
С чего Вы взяли то?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует