Вход | Регистрация



Проблема с запросом

Проблема с запросом
Я
   s_IDR
 
27.05.18 - 17:58
Мне нужно помочь в написании кода.
Сразу дам данные:
    Таблица:https://pastenow.ru/0efecd0847fd848402dab05640b825be в 1С
    Таблица:https://pastenow.ru/cd6624c686e150eb7c5fb09537db135a в Конфигураторе
        Код:
&НаКлиенте
Процедура СформироватьОтчёт(Команда)
ЗаполнитьТабДок(ТабДок);   
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ЗаполнитьТабДок(ТабДок)
   ТабДок.Очистить();
   Макет = Отчеты.ОтчетПоЗаказам.ПолучитьМакет("Отчёт");
   ОблШапка = Макет.ПолучитьОбласть("Шапка");
   ОблЭлемент = Макет.ПолучитьОбласть("Элемент");
   ОблИтого = Макет.ПолучитьОбласть("Итого");
   
   ОблШапка.Параметры.ДатаОтчёта = Формат(ТекущаяДата(),"ДЛФ=DD" );
   ТабДок.Вывести(ОблШапка);
   
   
Выборка = Документы.РасходнаяНакладная.Выбрать();
Пока Выборка.Следующий()  Цикл
  ОблЭлемент.Параметры.Заполнить(Выборка);
  ТабДок.Вывести(ОблЭлемент);
КонецЦикла;

Запрос = Новый Запрос;
   Запрос.Текст = ("Выбрать");
      Результат = Запрос.Выполнить();
   Итог = Результат.Выбрать();   
   Пока Итог.Следующий()  Цикл
   ОблИтого.Параметры.Заполнить(Итог);
      ТабДок.Вывести(ОблИтого)
   КонецЦикла;

====================================================|
Мне нужно что бы все заявки водителей(во втором столбце) складывались и выводились в строке "Итого" под заявками, у меня не получается написать запрос что бы он сложил все заявки и вывел их в строке Итого, не получается сижу мучаюсь какой час помогите если не сложно:)
 
 
   drei
 
1 - 27.05.18 - 18:12
Ты действительно думаешь, что если начать плодить темы, то все всё бросят и в воскресенье вечером побегут тебе помогать?
   shuhard
 
2 - 27.05.18 - 19:21
(0)[не получается сижу мучаюсь какой час ]
форуму розовые сопли пофигу
   quest
 
3 - 27.05.18 - 19:49
ну а в самом запросе то есть итоги?
   craxx
 
4 - 27.05.18 - 19:56
(0) Текст вывода итога запроса отдельно доставил. Товарищ, вы точно программист 1С?
   s_IDR
 
5 - 28.05.18 - 12:09
Да я случайно Итого перенёс за цикл, Итогои находятся в цикле.
   Ёпрст
 
6 - 28.05.18 - 12:29
(0) делать отчет сразу встроенным в конфу..это пять!
   Ёпрст
 
7 - 28.05.18 - 12:30
ну а так, весь в код в топку, пишешь обычный запрос к своему документу, в котором сразу всё считаешь, потом выводишь.
   s_IDR
 
8 - 28.05.18 - 12:31
Да, а как?
   Ёпрст
 
9 - 28.05.18 - 12:37
(8) что именно, а как ?
   s_IDR
 
10 - 28.05.18 - 12:38
Сделать запрос, я ещё не очень умею делать запросы
 
 Рекламное место пустует
   Ёпрст
 
11 - 28.05.18 - 12:38
Создаешь внешний отчет, далее открываешь конструктор запроса (можешь и конструктор отчета, если осилишь) и творишь.
   Ёпрст
 
12 - 28.05.18 - 12:38
и оно само, всё нарисует
   s_IDR
 
13 - 28.05.18 - 12:38
Где бы его скачать
   Ёпрст
 
14 - 28.05.18 - 12:38
(10) тогда начни с малого - почитай жкк на ночь
   Ёпрст
 
15 - 28.05.18 - 12:39
(13) кого скачать ?
   s_IDR
 
16 - 28.05.18 - 12:40
Конструктор запроса
   1Сергей
 
17 - 28.05.18 - 12:40
То СП воровали, теперь конструктор спёрли. Ну, что за народ?
   s_IDR
 
18 - 28.05.18 - 12:41
Или его  не надо скачивать ?
   Ёпрст
 
19 - 28.05.18 - 12:43
(18) могу продать, за недорога )
   1Сергей
 
20 - 28.05.18 - 12:43
(18) Оно встроено в 1С
   s_IDR
 
21 - 28.05.18 - 12:44
Просто я когда его искал  мне везде предлагали его скачать
   s_IDR
 
22 - 28.05.18 - 12:44
А где его открыть ?
   s_IDR
 
23 - 28.05.18 - 12:45
Или как?
   Ёпрст
 
24 - 28.05.18 - 12:46
(22) меню-текст-..далее по расписанию
   igorPetrov
 
25 - 28.05.18 - 12:46
(22) Поручик Ржевский, молчать!!!!
   Ёпрст
 
26 - 28.05.18 - 12:46
пофигуратор то открой хоть
   Гипервизор
 
27 - 28.05.18 - 12:47
(21) Не путайте конструктор с консолью.
Контекстное меню в модуле изучите внимательно.
   s_IDR
 
28 - 28.05.18 - 12:47
Ага спасибо)
   s_IDR
 
29 - 28.05.18 - 12:47
Что помогли
   _stay true_
 
30 - 28.05.18 - 12:54
Запрос.Текст = ("Выбрать");

Новые возможности 8.3.12?
   craxx
 
31 - 28.05.18 - 13:03
(22) позови уже программиста
   _stay true_
 
32 - 28.05.18 - 13:09
(0) Если боишься или по каким-либо предрассудкам не желаешь использовать итоги в запросе, подскажу бяку одну:
Твой код будет выглядеть примерно так:


   Запрос = Новый Запрос;
   Запрос.Текст = "Тут должен быть нормальный текст запроса";
 
   Результат = Запрос.Выполнить().Выгрузить();
   Итог = Результат.Итог("ПолеПоКоторомуНуженИтог"); 
   ОблИтого.Параметры.Заполнить(Итог);
   ТабДок.Вывести(ОблИтого);
   s_IDR
 
33 - 28.05.18 - 20:54
Не понимаю какое поле нужно указать(
 
 
   hhhh
 
34 - 29.05.18 - 08:08
(33) держись там. Тяни время. Пятьдесят на пятьдесят, что они про эту задачу забудут, дадут другую.
   Гипервизор
 
35 - 29.05.18 - 08:31
(34) Правило трех гвоздей?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует