Вход | Регистрация


Ошибка в запросах

Ошибка в запросах
Я
   s_IDR
 
27.05.18 - 14:11
Пишу код в котором должны суммироваться количество заявок у водителей, но выводит ошибку.
&НаКлиенте
Процедура СформироватьОтчёт(Команда)
ЗаполнитьТабДок(ТабДок);    
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ЗаполнитьТабДок(ТабДок)
    ТабДок.Очистить();
    Макет = Отчеты.ОтчетПоЗаказам.ПолучитьМакет("Отчёт");
    ОблШапка = Макет.ПолучитьОбласть("Шапка");
    ОблЭлемент = Макет.ПолучитьОбласть("Элемент");
    ОблИтого = Макет.ПолучитьОбласть("Итого");
    
    ОблШапка.Параметры.ДатаОтчёта = Формат(ТекущаяДата(),"ДЛФ=DD" );
    ТабДок.Вывести(ОблШапка);
    
    
Выборка = Документы.РасходнаяНакладная.Выбрать();
Пока Выборка.Следующий()  Цикл
  ОблЭлемент.Параметры.Заполнить(Выборка);
  ТабДок.Вывести(ОблЭлемент);
КонецЦикла;

Запрос = Новый Запрос;
    Запрос.Текст = ("Выбрать
             |Водитель,
             |Сумма(КолвоЗаявок)
             |Из
             |Документы.РасходнаяНакладная
             |СГРУППИРОВАТЬ ПО
             |Итого");
        Результат = Запрос.Выполнить();
    Выборка_Б = Результат.Выбрать();
    
    Пока Выборка_Б.Следующий()  Цикл
    ОблИтого.Параметры.Заполнить(Выборка_Б);    
    ТабДок.Вывести(ОблИтого)    
        КонецЦикла;
    


КонецПроцедуры

{Отчет.ОтчетПоЗаказам.Форма.ФормаОтчета.Форма(33)}: Ошибка при вызове метода контекста (Выполнить)
        Результат = Запрос.Выполнить();
по причине:
{(5, 1)}: Таблица не найдена "Документы.РасходнаяНакладная"
<<?>>Документы.РасходнаяНакладная
 
 
   jsmith82
 
1 - 27.05.18 - 14:13
Документ.РасходнаяНакладная
   Wirtuozzz
 
2 - 27.05.18 - 14:16
(0)
Перепиши вот это:
Выборка = Документы.РасходнаяНакладная.Выбрать();
Пока Выборка.Следующий()  Цикл
  ОблЭлемент.Параметры.Заполнить(Выборка);
  ТабДок.Вывести(ОблЭлемент);
КонецЦикла;

Запрос = Новый Запрос;
    Запрос.Текст = ("Выбрать
             |Водитель,
             |Сумма(КолвоЗаявок)
             |Из
             |Документы.РасходнаяНакладная
             |СГРУППИРОВАТЬ ПО
             |Итого");
        Результат = Запрос.Выполнить();
    Выборка_Б = Результат.Выбрать();
    
    Пока Выборка_Б.Следующий()  Цикл
    ОблИтого.Параметры.Заполнить(Выборка_Б);    
    ТабДок.Вывести(ОблИтого)    
        КонецЦикла;
    
Сделай 1 запрос без "Документы.РасходнаяНакладная.Выбрать();"
   s_IDR
 
3 - 27.05.18 - 14:52
Ещё вопрос если я хочу обратится к столбцу в таблице который по заполнению является текстом, то как мне это изобразить в коде ?
   Хотабыч
 
4 - 27.05.18 - 16:36
(0) почитай здесь о запросах https://apdate.by/forum/search?q=Ошибка+в+запросах
   Хотабыч
 
5 - 27.05.18 - 17:09
(4) прикольный форум пишешь вопрос а он сразу предлагает тебе выбрать похожие темы, а когда находишься на странице темы он показывает так же список похожих вопросов

но вот только активность на нем маленькая (
   Wirtuozzz
 
6 - 27.05.18 - 17:30
(5) сейчас воскресенье, в этот день можно в качестве ответа на свой вопрос получить следующее. Не думай, наливай и пей.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует