Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Подключение из 7.7 к 8.3 (как получить документ)

v7: Подключение из 7.7 к 8.3 (как получить документ)
Я
   StackOverflow
 
25.05.18 - 13:14
Вот код:

Процедура Подключение() 
    
    БазаОЛЕ=СоздатьОбъект("V83.COMConnector");
    
    РезультатПодключения= БазаОЛЕ.Connect("File=""" + СокрЛП(ПутьПодключения) + """; Usr=""" + СокрЛП(Пользователь) + """; Pwd=""" + СокрЛП(Пароль) + """");
    
    Если РезультатПодключения = 0 Тогда
        Предупреждение("Не удалось подключится к указанной базе");
    КонецЕсли;
    
    Сообщить("Подключились к базе");
    
    ДокОтражение = БазаОЛЕ.NewObject("Документ.ОтражениеЗарплатыВБухучете");
    Сообщить("Документ получен");
    
КонецПроцедуры

Подключается успешно, и ругается что не может получить документ, а именно на строку 
ДокОтражение = БазаОЛЕ.NewObject("Документ.ОтражениеЗарплатыВБухучете");

Как правильно, подскажите пожалуйста
 
 
   1Сергей
 
1 - 25.05.18 - 13:17
Что значит "получить документ"? получить некоторые реквизиты конкретного документа?
   StackOverflow
 
2 - 25.05.18 - 13:20
(1) Да, задумка была такая: создать обработку в бухгалтерии 7.7 с табличным полем и туда заполнить данные из 8 ошного документа. Но там и табличные поля есть.
   Aleksandr N
 
3 - 25.05.18 - 13:22
Документ = БазаОЛЕ.Документы.ОтражениеЗарплатыВБухучете.СоздатьДокумент();
   1Сергей
 
4 - 25.05.18 - 13:23
(2) Может того, запросом получить всё?
   Aleksandr N
 
5 - 25.05.18 - 13:23
(4) Точно, не увидел уточнение в (2)
   StackOverflow
 
6 - 25.05.18 - 13:24
(3) Не, Поле агрегатного объекта не обнаружено (Документ) =((
   StackOverflow
 
7 - 25.05.18 - 13:25
(4) А как? Через Оле?
   1Сергей
 
8 - 25.05.18 - 13:26
(6) ДокументЫ
   1Сергей
 
9 - 25.05.18 - 13:26
(7) да, точно так же
   StackOverflow
 
10 - 25.05.18 - 13:27
(8) я пробовал и документы а потом решил просто документ попробовать. никак не пашет
 
 Рекламное место пустует
   Михаил Козлов
 
11 - 25.05.18 - 13:27
(6) Что-то Вы неверно написали.
(7) запрос = БазаОле.NewObject("Запрос");
   StackOverflow
 
12 - 25.05.18 - 13:28
(9) а можно наводочку, а то пока не понял каким образом
   StackOverflow
 
13 - 25.05.18 - 13:28
(11) Спасибо
   StackOverflow
 
14 - 25.05.18 - 13:29
(11) Поле агрегатного объекта не обнаружено (NewObject)
   StackOverflow
 
15 - 25.05.18 - 13:29
или туда запрос уже передавать?
   ПегийЛунь
 
16 - 25.05.18 - 13:36
(10)Всё таки "Документы"
http://capitally.ru/exchange/podklyuchenie-1s-k-1s/
   1Сергей
 
17 - 25.05.18 - 13:41
РезультатПодключения.NewObject("Запрос");
   Михаил Козлов
 
18 - 25.05.18 - 13:44
(15) БазеОле у Вас, скорее всего, не того типа. Попробуйте вместо БазаОле РезультатПодключения.
   StackOverflow
 
19 - 25.05.18 - 13:45
(17) Спасибо заработало. Но я по другому сделал 
Документ = РезультатПодключения.Документы.ОтражениеЗарплатыВБухучете.СоздатьДокумент();
   StackOverflow
 
20 - 25.05.18 - 13:45
Всё, всем спасибо )
   HawkEye
 
21 - 25.05.18 - 22:01
(20) что-то типа:
       База = "";  
    Если глИнициализацияБазы(база, 1) = 0 Тогда
            Возврат;
        КонецЕсли;   
        ВидДока = База.Документы.ТребованиеНакладная;
        СоздалиНовый = 0;
        Если СокрЛП(номерБух8) <> "" Тогда
            //есть номер бух

            док = ВидДока.НайтиПоНомеру(номерБух8,ДатаДок); 
            Если док.пустая() = -1 Тогда
                создалиновый = 1;  
                ДокБП = ВидДока.СоздатьДокумент(); 
                ДокБП.Номер = номерБух8;   
            Иначе
                ДокБП = Док.ПолучитьОбъект();   
            КонецЕсли;
        Иначе
            создалиновый = 1;  
            ДокБП = ВидДока.СоздатьДокумент(); 
        КонецЕсли;
   Franchiser
 
22 - 26.05.18 - 00:56
Запихни все в модуль внешнего соединения


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует