Вход | Регистрация



Внешняя печатная форма для заполнения документа Word, как ?

Внешняя печатная форма для заполнения документа Word, как ?
Я
   Trotter
 
25.05.18 - 12:15
Задача, выводить определённые реквизиты в шаблон документа Word.
Документ подготовлен.
Как лучше реализовать ? Решил попробовать с использованием внешней печатной формы, почему бы и нет ? Но:
Всё настроил подключил, но выводит ошибку.
"В обработке печати не был сформирован табличный документ для "
Как отключить это сообщение ?
 
 
   DrShad
 
1 - 25.05.18 - 12:17
не нужно формировать никаких табличных документов
нужно открывать шаблон и в него вносить изменения
   Fragster
 
2 - 25.05.18 - 12:18
   Trotter
 
3 - 25.05.18 - 12:22
(2) Ёмаё, спасибо конечно, а попроще не как ?)
   Fragster
 
4 - 25.05.18 - 12:23
(3) да там несложно. Из демо базы БСП 70% когда можно взять
   dka80
 
5 - 25.05.18 - 12:49
Функция Печать() Экспорт
    
    ТвояОбработка();
    
КонецФункции
   Serg_1960
 
6 - 25.05.18 - 13:06
(5) Не в тему. У автора БСП.
   Serg_1960
 
7 - 25.05.18 - 13:16
На самом деле ничего сложного. Практически всё тоже самое как и раньше, плюс пару бантиков и рюшечек для современных конфигураций. Свою печатную форму формируешь и выводишь на экран/печать - самостоятельно.

А для работы БСП добавляешь пустой макет (например, с именем "Макет") и прописываешь его в функции СведенияОВнешнейОбработке() в качестве основного.
Далее в функции Печать() создаешь таб.документ; открываешь макет; вставляешь туда, например, строку "Сформирован документ Word" и это безобразие возвращаешь в качестве печатной формы - мне,например, не жалко, пусть эта тупая БСП им подавится :)
   Trotter
 
9 - 25.05.18 - 13:38
БСП не трогую, документ Word - в каталоге с базой лежит.
   bolobol
 
11 - 25.05.18 - 14:13
Опачки, а где сообщения?
   Trotter
 
12 - 25.05.18 - 14:14
(11) А что за рекомендация была ?
   bolobol
 
13 - 25.05.18 - 14:17
(12) Долго повторять, да и "шедевры не повторяются"
   Trotter
 
14 - 25.05.18 - 14:25
(7) Пример можно ?
   dka80
 
15 - 25.05.18 - 14:38
(7) так я а о чем написал в (5)? "Далее в функции Печать() создаешь таб.документ" - там даже возвращать ничего не надо для БСП.

(14) у тебя проблема только с сообщением или ты в принципе не знаешь как сделать?
   Trotter
 
16 - 25.05.18 - 14:55
(15)С сообщением, раздражает, а так всё отрабатывает.
   Trotter
 
17 - 25.05.18 - 15:02
Процедура Печать(МасивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    ТабДок = Новый ТабличныйДокумент;
    Макет = ЭтотОбъект.ПолучитьМакет("Макет");
    мСтрока = Макет.ПолучитьОбласть("Строка");
    мСтрока.Параметры.Информация = "Word";
    ТабДок.Вывести(мСтрока);    
    ЗаполнитьWord();
КонецПроцедуры

Процедура ЗаполнитьWord()
    
КонецПроцедуры
   Trotter
 
18 - 25.05.18 - 15:02
так ?)
   dka80
 
19 - 25.05.18 - 15:04
Да
   Trotter
 
20 - 25.05.18 - 15:05
(19) Ошибка осталась. (
   Trotter
 
21 - 25.05.18 - 15:09
// Проверим, все ли макеты были сформированы.

    Для Каждого ПечатнаяФорма Из КоллекцияПечатныхФорм Цикл
        Если ПечатнаяФорма.ТабличныйДокумент = Неопределено Тогда
            ТекстСообщенияОбОшибке = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                НСтр("ru = 'В обработчике печати не был сформирован табличный документ для: %1'"),
                ПечатнаяФорма.ИмяМакета);
            ВызватьИсключение(ТекстСообщенияОбОшибке);
        КонецЕсли;
        
        ПечатнаяФорма.ТабличныйДокумент.КоличествоЭкземпляров = ПечатнаяФорма.Экземпляров;
    КонецЦикла;
В КоллекцияПечатныхФорм нету моего макета почему - то.
   bolobol
 
22 - 25.05.18 - 15:53
Либо не добавлен макет, либо КомандаПечати.Идентификатор = "СчетЗаказ"; - не соответствует названию макета. В любом случае - в ссылке (2) есть где покопаться. А в (17) - нет ни строчки из (2)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует