Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Формула вычисления для 1С

↓ [Asmody, 25.05.18 - 09:30]
Формула вычисления для 1С
Я
   StanislavPrihodko
 
25.05.18 - 08:35
Если в табличной части Уроки реквизит табличной части Урок не заполнен больше чем в трех строках, тогда нужно проверить в табличной части Курсовые работы заполнен реквизит табличной части курс во всех полях. (Тогда нужно проверить, что у всех курсовых работ заполнен курс).
Если курс заполнен у всех, тогда проверить заполнен ли учебный год.
Если учебный год не заполнен сообщить ошибка.
Если в табличной части Уроки реквизит табличной части Урок не заполнен меньше либо ровно чем в трех строках (сообщать привет)
Где:   Если в табличной части Уроки реквизит табличной части Урок не заполнен больше чем в трех строках - ПО ФОРМУЛЕ СИМВОЛ - А

тогда нужно проверить в табличной части Курсовые работы заполнен реквизит табличной части курс во всех полях. (Тогда нужно проверить, что у всех курсовых работ заполнен курс).  ПО ФОРМУЛЕ СИМВОЛ - B

Если курс заполнен у всех, тогда проверить заполнен ли учебный год.
Если учебный год не заполнен (сообщить ошибка) - ПО ФОРМУЛЕ СИМВОЛ С

Иначе в табличной части Уроки реквизит табличной части Урок не заполнен меньше либо ровно чем в трех строках (сообщить привет)

Вот что у меня вышло проверьте и скажите что не так:

Если А тогда
  Если B тогда
    Если С тогда
      Сообщить("Ошибка");
Иначе 
     Сообщить("Привет");
 
 
   igorPetrov
 
1 - 25.05.18 - 08:39
(0) Халявщики подтянулись.
"Вот что у меня вышло проверьте и скажите что не так:
" как минимум, пожалуйста просят, а не приказывают.
Но помогать тебе дело гиблое и не благодарное.
   SleepyHead
 
2 - 25.05.18 - 08:39
У вас первая и последняя строка перепутаны. Сначала "Привет", потом вопрос.
   SleepyHead
 
3 - 25.05.18 - 08:40
(1) ты что, он же лучший студент и его валят преподавателем (цитата из соседней ветки). Имей уважение к человеку.
   ildary
 
4 - 25.05.18 - 08:41
(3) Сценарий тянет на Оскар. Осталось поработать над актерской игрой.
   igorPetrov
 
5 - 25.05.18 - 08:48
(3) Точно! Забыл совсем. Но если это лучший, то стесняюсь спросить, какие худшие?
Но, что радует, так это то, что конкуренты молодые и энергичные не растут.)))
   user-ok
 
6 - 25.05.18 - 08:49
когда ж ты угомонишься?
   МимохожийОднако
 
7 - 25.05.18 - 08:50
Жаль, что подобные темы не только по пятницам.
   StanislavPrihodko
 
8 - 25.05.18 - 08:52
90% как обычно пишут тупо бред, а помочь или сказать где ошибка никто не может. Базарить не мешки воротить
   0xFFFFFF
 
9 - 25.05.18 - 08:52
Нахрапом решил взять...

(0) А я еще на 7.7 начинал с Сообщить("Хеллоу ворлд"), с дальнейшим последовательным изучением всех методов объектов по синтаксис помощнику (благо их в 7.7 мизерное количество)...
   Cool_Profi
 
10 - 25.05.18 - 08:53
(9) А в 77 начинал с загрузки из dbf... )))
 
 Рекламное место пустует
   0xFFFFFF
 
11 - 25.05.18 - 08:54
(8) ошибка у тебя в том, что ты пытаешься оперировать какими то "уроками", "курсами" и прочими сущностями и пытаешься при этом изучить основные конструкции Если КонецЕсли

Начни с простого. Например с чисел.
   ildary
 
12 - 25.05.18 - 08:55
(5) без притока свежей крови отрасль захиреет. Кто будет покупать продукт, если его будут сопровождать такие вот "лучшие студенты"?

(8) Какие мы тонкие, ранимые натуры. Сидел бы в Фейсбуке, если так страшно.

(9)+(10) Причем был только синтакс помощник, т.к. ЖКК под рукой не было, литературы в интернете не было, и даже форумы еще не появились. И ничего, брат не умер.
   0xFFFFFF
 
13 - 25.05.18 - 08:56
(10) это понятно, что на второй день изучения можно и ДБФ погрузить.
Тут проблема в том, что чувак уже неделю барахтается, а конструкцию "Если" не понимает. А если бы зашел "последовательно" уже давно бы таких вопросов не задавал.
   0xFFFFFF
 
14 - 25.05.18 - 08:57
(12) я через форум тогда желтые книжки нашел и купил за 900 рублей (2001 год) - считал большой удачей :)
   dezss
 
15 - 25.05.18 - 08:57
е-мое...опять он...
   фросия
 
16 - 25.05.18 - 08:58
(8) напроситесь, сейчас вам скажут что ошибка в ДНК
   ildary
 
17 - 25.05.18 - 08:59
(13) раньше бухи ждали кнопку "СделатьФсе", теперь и программисты подтянулись.
   SleepyHead
 
18 - 25.05.18 - 09:00
(8) "90% как обычно пишут тупо бред, а помочь или сказать где ошибка никто не может. Базарить не мешки воротить"

Парень, да ты гений. Твоя позиция - "Помогите мне, или вы все (вырезано цензурой)."
   StanislavPrihodko
 
19 - 25.05.18 - 09:00
Проверьте пожалуйста, правильно ли я написал или нет?
   ildary
 
20 - 25.05.18 - 09:03
(16) Вот довели Living Star и Misty, теперь они не заходят с вопросами, приходится читать студентов.
   s03
 
21 - 25.05.18 - 09:03
(19) с точки зрения орфографии и грамматики - возможно, с точки зрения синтаксиса и правильности использования конструкций языка 1С - нет
   0xFFFFFF
 
22 - 25.05.18 - 09:03
(19) Это неправильно
Если А тогда
  Если B тогда
    Если С тогда
      Сообщить("Ошибка");
Иначе 
     Сообщить("Привет");
   МимохожийОднако
 
23 - 25.05.18 - 09:04
(19) неправильно. Т.к. не работает.
   фросия
 
24 - 25.05.18 - 09:05
(20) я никого не доводила
   StanislavPrihodko
 
25 - 25.05.18 - 09:05
(18) в 44 года а со зрением все херова: Вот что у меня вышло проверьте и скажите что не так вот что я написал.
   МимохожийОднако
 
26 - 25.05.18 - 09:06
(20) Они теперь перешли на следующий уровень и не часто балуют своим вниманием. Без них наше тщеславие уменьшается ))
   МимохожийОднако
 
27 - 25.05.18 - 09:07
(25) Специальность офтальмолог?
   dezss
 
28 - 25.05.18 - 09:08
(25) все не так...
надо звать bolobol..
В прошлой теме он все смог быстро и красиво объяснить)
   фросия
 
29 - 25.05.18 - 09:09
(25) а вы хам
   ildary
 
30 - 25.05.18 - 09:10
(24) имел в виду форум целиком.

(26) всё хорошее заканчивается.

(28) не надо никого звать, пусть сам учится. Иначе в итоге и пос.р.ать не сможет без помощи форума.
   dezss
 
31 - 25.05.18 - 09:11
(30) а ты читал прошлую тему?
https://www.forum.mista.ru/topic.php?id=819157&page=2
192-е сообщение)))
   Dotoshin
 
32 - 25.05.18 - 09:12
(0) Это какое-то сферическое задание или оно имеет реальную жизненную основу? Короче переведи этот бред на человеческий язык.
   dezss
 
33 - 25.05.18 - 09:12
(32) не дождешься...автор не переводчик...он программист-отличник)))
геодезист был адекватней и смышленей)))
 
 
   StanislavPrihodko
 
34 - 25.05.18 - 09:14
Я не прошу помощи поймите вы, я просто скинул материал и мне нужно было услышать Правильно или Неправильно и всё.
Если А тогда 
   Иначе Сообщить("Привет");
КонецЕсли;
Если В тогда
  Если НЕ С тогда
     Сообщить("Ошибка");
КонецЕсли;

Так правильно?
   _Дайвер_
 
35 - 25.05.18 - 09:14
(25)
Если А=1 Тогда
 Сообщить("А = 1");
ИначеЕсли А=2 Тогда
 Сообщить("А = 2");
ИначеЕсли А>=3 Тогда
 Сообщить("А больше или равно 3");
Иначе
 Сообщить("А < 1");
КонецЕсли;

Вот так пишутся миллион условий ЕСЛИ, СП тебе в помощь
   Dotoshin
 
36 - 25.05.18 - 09:15
(28) >>В прошлой теме он все смог быстро и красиво объяснить)
Да это был шедевр, достойный быть отлитым в граните :)
   фросия
 
37 - 25.05.18 - 09:15
(34) неправильно
   _Дайвер_
 
38 - 25.05.18 - 09:16
(34) Ты сам понимаешь что пишешь?
ты чего тут с утра насилуешь всем мозги!?
Это так то статья УК 133!
   Dotoshin
 
39 - 25.05.18 - 09:16
(33) Геодезисты они вообще смышленые ребята :)
   StanislavPrihodko
 
40 - 25.05.18 - 09:16
(35) Ты написал как по обычному, а мне надо по формуле которой я написал, так с цифрами я могу
   фросия
 
41 - 25.05.18 - 09:19
(40) надо- делай!
   StanislavPrihodko
 
42 - 25.05.18 - 09:19
(37) в чем ошибка примерно, где-то не то условие или в чем?
   El_Duke
 
43 - 25.05.18 - 09:19
(36) дайте ссылку на шедевр
   фросия
 
44 - 25.05.18 - 09:20
(42) Цитата: Я не прошу помощи поймите вы, я просто скинул материал и мне нужно было услышать Правильно или Неправильно и всё. КонецЦитаты
   Asmody
 
45 - 25.05.18 - 09:20
(0) [ПО ФОРМУЛЕ СИМВОЛ - А] — вот это что за хуета?
   фросия
 
46 - 25.05.18 - 09:20
(43) в (31)
   StanislavPrihodko
 
47 - 25.05.18 - 09:20
(45) Если А тогда 
   Иначе Сообщить("Привет");
КонецЕсли;
Если В тогда
  Если НЕ С тогда
     Сообщить("Ошибка");
КонецЕсли;

А,B,C В условии
   фросия
 
48 - 25.05.18 - 09:21
(45) а почему у вас слово на букву х не зацензурировалось?
   ildary
 
49 - 25.05.18 - 09:22
(48) потому что он - выше правил (вебмастер).
 
 Рекламное место пустует
   Dotoshin
 
50 - 25.05.18 - 09:22
Задание в (0) напоминает вот этот стишок:
Варкалось. Хливкие шорьки
Пырялись по наве.
И хрюкотали зелюки 
Как мюмзики в мове.

О, бойся Бармаглота, сын!
Он так свирлеп и дик,
А в глуще рымит исполин — 
Злопастный Брандашмыг!
Но взял он меч, и взял он щит,
Высоких полон дум.
В глущобу путь его лежит,
Под дерево Тумтум.
Он стал под дерево и ждёт,
И вдруг граахнул гром — 
Летит ужасный Бармаглот
И пылкает огнём!
Раз-два, раз-два! Горит трава,
Взы-взы — стрижает меч.
Ува! Ува! И голова
Барабардает с плеч!

О светозарный мальчик мой!
Ты победил в бою!
О храброславленный герой,
Хвалу тебе пою!
Варкалось. Хливкие шорьки
Пырялись по наве.
И хрюкотали зелюки
Как мюмзики в мове.
   Asmody
 
51 - 25.05.18 - 09:23
(47) Тут синтаксическая ошибка - несогласованы Если и КонецЕсли.
   StanislavPrihodko
 
52 - 25.05.18 - 09:23
(48) Если А тогда
       Иначе Сообщить("Привет");
     КонецЕсли;

     Если НЕ В тогда
       Если НЕ С тогда
        Сообщить("Ошибка);
      КонецЕсли;

Вот я так сделал, здесь должно быть правильно всё
   Asmody
 
53 - 25.05.18 - 09:23
(48) Добролетельным людям можно всё. (с) Волшебник
   Dotoshin
 
54 - 25.05.18 - 09:23
+ (50) ТС - Бармаглот (не оскорбление есичо, а констатация факта)
   StanislavPrihodko
 
55 - 25.05.18 - 09:25
(51) Если А тогда
       Иначе Сообщить("Привет");
     КонецЕсли;

     Если НЕ В тогда
       Если НЕ С тогда
        Сообщить("Ошибка);
      КонецЕсли;
       КонецЕсли;

Вот под правил, никто кроме Asmody синтаксическую ошибку походу не видел что ли, если никто кроме него не написал, спасибо большое, проверьте Asmody правильно ли теперь у меня и все тоже проверьте пожалуйста
   dezss
 
56 - 25.05.18 - 09:25
(45) чувак пытается программить сверху...но у него не получается)
   фросия
 
57 - 25.05.18 - 09:26
(54) а может и хливкий шорёк который напырялся...
   StanislavPrihodko
 
58 - 25.05.18 - 09:26
(56) (57) Дёня, Алина посмотрите выше, там правильный код?
   Dotoshin
 
59 - 25.05.18 - 09:27
   Asmody
 
60 - 25.05.18 - 09:27
(54) ТС - казахский бот.
   Asmody
 
61 - 25.05.18 - 09:27
(58) Там нет кода, там хуета.
   фросия
 
62 - 25.05.18 - 09:27
(58) без ошибок не всегда правильный.
   _Дайвер_
 
63 - 25.05.18 - 09:28
(61) Поддерживаю
   StanislavPrihodko
 
64 - 25.05.18 - 09:33
Ура, ура, ура у меня походу получилось теперь проверьте, я все способы проанализировал:

Если А тогда
 Если B тогда 
   Иначе Сообщить("Привет");
КонецЕсли;

Если С тогда
Сообщить(Ошибка);
   StanislavPrihodko
 
65 - 25.05.18 - 09:33
КонецЕсли;

забыл после Сообщить(Ошибка)
   _Дайвер_
 
66 - 25.05.18 - 09:35
(64)
Если А тогда//А = истина

    //что если здесь А= истина?

Иначе
    Сообщить("Привет");
КонецЕсли;

Если НЕ В Тогда// В = Ложь

    // Что если В = ложь???

    Если НЕ С Тогда// Если В = Истина ты сюда никогда не попадешь!

        Сообщить("Ошибка");// вот тут после ошибка знак (") забыл дописать 

    КонецЕсли;
КонецЕсли;

Ты в блокнотике пишешь что ли??? Я не понимаю :\
   Dotoshin
 
67 - 25.05.18 - 09:37
(65) Держи, проверил за тебя в 1С:
Ожидается ключевое слово 'КонецЕсли' ('EndIf')
   _Дайвер_
 
68 - 25.05.18 - 09:37
(66) Если В = Ложь ты внутрь не попадешь, к условию:
Если НЕ С Тогда...
   dezss
 
69 - 25.05.18 - 09:40
(66) (68) многие пытались ему помочь, но смогли не только лишь все, никто не смог, кроме балабола...
   Dotoshin
 
70 - 25.05.18 - 09:42
(68) Он вообще никуда не попадет, ибо не ясно чему равны А, Б и Ц
   _stay true_
 
71 - 25.05.18 - 09:45
(0)Ливинг стар, это ты? Перелогинься!
   dezss
 
72 - 25.05.18 - 09:46
(71) не, ливинг стар подрос...не похоже на него...
   _Дайвер_
 
73 - 25.05.18 - 09:47
(70) Предположим что он присваивает значения им, только предположим..._)
   _stay true_
 
74 - 25.05.18 - 09:47
(65) нужно не все способы анализировать и владеть тупо на уровне шаманства, а изучать основы программирования 1С(переменные, операторные скобки, циклы, условия, ветвления, запросы и.т.п.), понимать, что и зачем ты делаешь и принимать осознанные решения.
   фросия
 
75 - 25.05.18 - 09:52
(74) нужно просто основы программирования изучать: условия циклы...
   фросия
 
76 - 25.05.18 - 09:52
хотя бы. для начала.
   dezss
 
77 - 25.05.18 - 09:53
кстати..
(0) ты вроде писал про то, что на других языках программируешь нормально...
можешь показать код пары твоих процедур/функций?
   bolobol
 
78 - 25.05.18 - 10:01
Тут слишком многа условий для пятницы...

По порядку...
Если в табличной части Уроки реквизит табличной части Урок не заполнен больше чем в трех строках - УрокиПустыБолее3хРаз

тогда нужно проверить в табличной части Курсовые работы заполнен реквизит табличной части курс во всех полях - КурсВоВсехКурсовых(полях или строках?)

Если курс заполнен у всех, тогда проверить заполнен ли учебный год - УчебныйГодЗаполненВЧёмТо

Если учебный год не заполнен сообщить ошибка:
Если УрокиПустыБолее3хРаз И КурсЗаполненВоВсехКурсовыхПоляхИлиСтроках И НЕ УчебныйГодЗаполненВЧёмТо Тогда
Сообщить("Ошибка");
Возврат;
КонецЕсли;
---

Если в табличной части Уроки реквизит табличной части Урок не заполнен меньше либо ровно чем в трех строках
(сообщать привет):
Если НЕ УрокиПустыБолее3хРаз Тогда
Сообщить("привет");
Возврат;
КонецЕсли;
---

Далее мне непонятно вообще всё, улавливаю, что закодированы условия буквами, но так джентльмены не кодют прилюдно:

Где:   Если в табличной части Уроки реквизит табличной части Урок не заполнен больше чем в трех строках - ПО ФОРМУЛЕ СИМВОЛ - А


тогда нужно проверить в табличной части Курсовые работы заполнен реквизит табличной части курс во всех полях. (Тогда нужно проверить, что у всех курсовых работ заполнен курс).  ПО ФОРМУЛЕ СИМВОЛ - B

Если курс заполнен у всех, тогда проверить заполнен ли учебный год.
Если учебный год не заполнен (сообщить ошибка) - ПО ФОРМУЛЕ СИМВОЛ С

Иначе в табличной части Уроки реквизит табличной части Урок не заполнен меньше либо ровно чем в трех строках (сообщить привет)
   dezss
 
79 - 25.05.18 - 10:16
(78) я разочарован...
я ждал чего-то подобного вчерашнему, а ты вот так вот...эх...
   SleepyHead
 
80 - 25.05.18 - 10:21
(25) в 44 года а со зрением все херова: В

Ты болен. Иди поищи работу там, где у тебя есть к ней способности. Но сначала - к психиатру.
   bolobol
 
81 - 25.05.18 - 10:24
(79) сожалею вашей утрате веры в пятницу)
   bolobol
 
82 - 25.05.18 - 10:26
кхм... у кого тут с "моя-твоя русский язык" отлично, как (81) переписать, чтоб было понятно, что вера не в принципе потерялась сегодня, а в сам день недели вера утратилась?
   dezss
 
83 - 25.05.18 - 10:27
(81) (82) я понял, но вера еще живет...еще не вечер)))
   dezss
 
85 - 25.05.18 - 10:29
(84) ого...это уже сильно...это пахнет баном)
   SleepyHead
 
86 - 25.05.18 - 10:42
(85) Этот перец похоже уже был забанен, только тогда он был с ником василий егоров. И он писал мне, чтобы я взял его на поруки в скайпе, вежливо ему отказал.

Обиделся очень, начал материться. Сочувствую больному.
   igorPetrov
 
87 - 25.05.18 - 10:47
(84) А почему у него мат пролез? Это навевает на мысли.
   bolobol
 
88 - 25.05.18 - 10:50
/шепчет: есть подозрение, шо ето админЪ!
   dezss
 
89 - 25.05.18 - 11:20
(87) а разве мат-фильтр стоит?
материться можно, только за это банят)))
   igorPetrov
 
90 - 25.05.18 - 12:15
(89) стоит
   SleepyHead
 
91 - 25.05.18 - 12:57
(90) Забанен наш автор, без комментариев. А предыдущая инкарнация его же забанена по другой причине (vasiliyegorov)

https://www.forum.mista.ru/ban_list.php


Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует