Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

заблокировать кнопку действия

заблокировать кнопку действия
Я
   _barracuda_
 
24.05.18 - 16:24
Добрый день.Подскажите не получается доступность изменить кнопки действия в УТ обычные формы
Если Стадия=Перечисления.Стадия.Завершен Тогда
                Для каждого Элемент Из ЭтаФорма.ЭлементыФормы цикл 
                    Имя_ = Элемент.Имя;
                    Если имя_="Подменю1" Тогда 
                            Элемент.Доступность= Ложь; 
                    КонецЕсли; 
                КонецЦикла;
        КонецЕсли;
 
 
   1Сергей
 
1 - 24.05.18 - 16:26
ЭтаФорма.ЭлементыФормы.Подменю1.Доступность= Ложь;
   _barracuda_
 
2 - 24.05.18 - 16:27
(1)поле подменю1 не обнаружено
   drei
 
3 - 24.05.18 - 16:28
Интересно, что это такое - поле ввода, небось...
Вангую, что ТС пытается перебрать кнопки командной панели
   hhhh
 
4 - 24.05.18 - 16:30
(2) ну в отладчике посмотри, и нам скажешь какой это элемент.
   _barracuda_
 
5 - 24.05.18 - 16:31
(3)открой типовую утп например на обычных формах.заказ покупателя.вверху ДЕЙСТВИЯ
   _barracuda_
 
6 - 24.05.18 - 16:33
(4)если бы я знал что уже сам бы себе ответил
   drei
 
7 - 24.05.18 - 16:36
(5) Ты предлагаешь мне сделать все за тебя? Ну там, установить УПП, открыть приложение, запустить отладчик, поставить точку останова, разобрать структуру формы и подсмотреть в синтакс-помощник?
Спасибо, но нет.
   _barracuda_
 
8 - 24.05.18 - 16:37
(7)где то звучало предложение?
   drei
 
9 - 24.05.18 - 16:39
(8) А, так это было беспрекословное распоряжение в (5)?
Извини, пожалуйста, я сразу не понял.
   bolobol
 
10 - 24.05.18 - 16:40
А почему в коде тогда ищется "Подменю1" ?
 
 Рекламное место пустует
   _barracuda_
 
11 - 24.05.18 - 16:50
решил проблему.а как по условию  заблокировать кнопку выпадающего контекстного меню где есть ввод на основании?напримр на списке заказов ткнуть на любой и если проверка условия по заказу то контекстное меню не выпадает
   _barracuda_
 
12 - 24.05.18 - 16:50
(9)слава Богу что не понял.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует