Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Значение данных расшифровки отсутствует, либо имеет неправильный тип

Значение данных расшифровки отсутствует, либо имеет неправильный тип
Я
   svchernova1
 
24.05.18 - 12:45
Здравствуйте все,

Не могу сделать расшифровку к отчету.
Вот пример процедуры :

Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    Перем ВыбранноеДействие;
    Перем ПараметрыВыбранногоДействия;
    
    СтандартнаяОбработка = Ложь;
    
    ОбработкаРасшифровки = Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
    //Перечень возможных действий

    ДоступныеДействия = Новый Массив();
    ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение);
    ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.Расшифровать);
    
    // Осуществим выбор действия расшифровки пользователем

    ОбработкаРасшифровки.ВыбратьДействие(Расшифровка, ВыбранноеДействие, ПараметрыВыбранногоДействия, ДоступныеДействия,, Истина);
    
    Если ВыбранноеДействие <> ДействиеОбработкиРасшифровкиКомпоновкиДанных.Нет Тогда
        Если ВыбранноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда
            ОткрытьЗначение(ПараметрыВыбранногоДействия);
        Иначе
            // здесь хочу открыть другой отчет с расшифровкой


        КонецЕсли;
    КонецЕсли;

ОбработкаРасшифровки.ВыбратьДействие дает ошибку
 Значение данных расшифровки отсутствует, либо имеет неправильный тип

При этом параметр #1 "Расшифровка" содержит число


Уже погуглила, сколько могла. Управляемые формы, СКД, платформа 1С 8.3
 
 
   svchernova1
 
1 - 24.05.18 - 13:20
ап (((
   Lexey_
 
2 - 24.05.18 - 13:26
(0) "Уже погуглила"
ну в первых двух ссылках же ответ есть
   svchernova1
 
3 - 24.05.18 - 14:15
(2) Не поняла вас
   svchernova1
 
4 - 24.05.18 - 14:17
(2) Чего только не написано в гугле, полдня бьюсь уже над этой проблемой
   Lexey_
 
5 - 24.05.18 - 15:28
(3) в первых двух ссылках, выдаваемых гуглом по запросу "Значение данных расшифровки отсутствует, либо имеет неправильный тип" есть ответ
   svchernova1
 
6 - 25.05.18 - 08:07
(5) Спасибо, но не подходит это. или просто у меня не получается.
Я записываю результат выполнения отчета в хранилище, но расшифровку оттуда не могу получить. Полная каша в голове!

Процедура для формирования отчета:
&НаСервере
Функция СформироватьОтчетНаСервере() Экспорт
    
    Если Не ПроверитьЗаполнение() Тогда
        Возврат Новый Структура("ЗаданиеВыполнено", Истина);
    КонецЕсли;
    
    ДополнительныеСвойства = Отчет.КомпоновщикНастроек.Настройки.ДополнительныеСвойства;
    
    ИБФайловая = ОбщегоНазначения.ИнформационнаяБазаФайловая();
    
    ДлительныеОперации.ОтменитьВыполнениеЗадания(ИдентификаторЗадания);
    
    ИдентификаторЗадания = Неопределено;
    
    ОбщегоНазначенияКлиентСервер.УстановитьСостояниеПоляТабличногоДокумента(Элементы.Результат, "НеИспользовать");
    
    ПараметрыОтчета = ПодготовитьПараметрыОтчета();
    
    Если ИБФайловая Тогда
        АдресХранилища = ПоместитьВоВременноеХранилище(Неопределено, УникальныйИдентификатор);
        БухгалтерскиеОтчетыВызовСервера.СформироватьОтчет(ПараметрыОтчета, АдресХранилища);
        РезультатВыполнения = Новый Структура("ЗаданиеВыполнено", Истина);
    Иначе
        РезультатВыполнения = ДлительныеОперации.ЗапуститьВыполнениеВФоне(
            УникальныйИдентификатор,
            "БухгалтерскиеОтчетыВызовСервера.СформироватьОтчет",
            ПараметрыОтчета,
            БухгалтерскиеОтчетыКлиентСервер.ПолучитьНаименованиеЗаданияВыполненияОтчета(ЭтаФорма));
            
        АдресХранилища       = РезультатВыполнения.АдресХранилища;
        ИдентификаторЗадания = РезультатВыполнения.ИдентификаторЗадания;
    КонецЕсли;
    
    Если РезультатВыполнения.ЗаданиеВыполнено Тогда
        ЗагрузитьПодготовленныеДанные();
    КонецЕсли;
    
    Элементы.Сформировать.КнопкаПоУмолчанию = Истина;
    
    Возврат РезультатВыполнения;
   svchernova1
 
7 - 25.05.18 - 08:16
У меня управляемые формы, интерфейс Такси.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует