Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

RL 2.1.8.2 Перенос проводок Розница 2.2 - Бухгалтерия 3.0

RL 2.1.8.2 Перенос проводок Розница 2.2 - Бухгалтерия 3.0
Я
   _Vanda_
 
23.05.18 - 22:46
Добрый день!
Переношу данные по документу Отчет о розничных продажах в документ ОперацияБух. Счета переносятся,а вот с субконто проблема. В ПВД Отчет о розничных продажах указываю:[CODE]СубконтоДт = Новый Соответствие;
        СубконтоДт.Вставить(Новый Структура("Код", "00021"), Новый Структура("Код", "00-000014"));
        СубконтоДт.Вставить(Новый Структура("Код", "00027"), Объект.Магазин);
        Строка.СубконтоДт = СубконтоДт; [/CODE]
субконто2(объект.магазин) передается в проводку, а вот субконто1 нет, т.к. не знаю как передать его значение в виде кода, а точнее как передать его в ПКО "Статьи движения денежных средств",в котором указала поиск по коду. Все делала по статье:http://catalog.mista.ru/public/120035/, но значение субкотно, в их случае, есть в базе источника,а в моем нет.
Пробовала также писать в ПКО ОперацияБух после загрузки:
 [CODE]Объект.Организация = Справочники.Организации.НайтиПоКоду("00-000014");
Объект.Движения.Хозрасчетный.Записывать = Истина;
ДвиженияХозрасчет = Объект.Движения.Хозрасчетный;
ТаблДвиж = ДвиженияХозрасчет.Выгрузить();
ДвиженияХозрасчет.Прочитать();
ДвиженияХозрасчет.Очистить();

Для Каждого Стр ИЗ ТаблДвиж Цикл
    Если Стр.СчетДт.Код = "50.02" И Стр.СчетКт.Код = "90.01.3" Тогда
        ВыручкаРозничная = Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоКоду("00-000014");
        Сообщить("Это субконто Дт1:"+Стр.СубконтоДт1);
        Сообщить("Это субконто Дт2:"+Стр.СубконтоДт2);
        Сообщить("Это субконто Дт3:"+Стр.СубконтоДт2);
        Если НЕ ЗначениеЗаполнено(Стр.СубконтоДт1) Тогда
        Стр.СубконтоДт1 = ВыручкаРозничная; 
        КонецЕсли;
    КонецЕсли;
    
КонецЦикла;
ДвиженияХозрасчет.Загрузить(ТаблДвиж);
[/CODE]
но тоже ничего хорошего не вышло, Субконто2 (Объект.магазин) почему то в таблице ТаблДвиж находится в Стр.СубконтоДт1. А когда захожу в перенесенный документ операция бух, он находится в Субконто2 (делала запрос к РБ Хозрасчетный,где регистратор этот  документ операция).Почему он так делает для меня просто мистика. Помогите найти решение.
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует