Вход | Регистрация


Не видит экспортную функцию общего модуля через COM соединение

Не видит экспортную функцию общего модуля через COM соединение
Я
   dka80
 
23.05.18 - 12:36
Добрый день.

Есть Конфигурация 1 (управляемые формы), в ней общий модуль (установлены галки Клиент, Сервер, Внешнее соединение, Вызов сервера) и экспортная функция.
Есть конфигурация 2 (обычные формы), где из внешней обработки вызывается функция общего модуля конфигурации 1. В результате выдается "Метод объекта не обнаружен".

Почему он не видит функцию и что нужно сделать, чтобы увидел?
Спасибо.
 
 
   _Дайвер_
 
1 - 23.05.18 - 12:37
(0) Покажи как обращаешься к ней из обработки
   dka80
 
2 - 23.05.18 - 12:39
V83COMConnector = Новый COMОбъект("V83.COMConnector"); 
Base1С = V83COMConnector.Connect(Параметры);
Результат Base1С.МойОбщийМодуль.МояФункция();
   dka80
 
3 - 23.05.18 - 12:39
*Результат = Base1С.МойОбщийМодуль.МояФункция();
   hhhh
 
4 - 23.05.18 - 12:43
(3) клиент (обычное приложение) может забыл галку.
   _Дайвер_
 
5 - 23.05.18 - 12:43
(3) Подключение к базе то проходит? Отладчиком пробегался?
   dka80
 
6 - 23.05.18 - 12:47
Проходит, пробегался.
(4) в конфигурации 2 нет галки Клиент (обычное приложение). Это ЗУП 3
   dka80
 
7 - 23.05.18 - 12:48
*в конфигурации 1 нет галки Клиент (обычное приложение). Это ЗУП 3
   Малыш Джон
 
8 - 23.05.18 - 12:50
(7) ну возможно именно в этом дело
   hhhh
 
9 - 23.05.18 - 12:52
(7) вообще убери галку Клиент.
   Ненавижу 1С
 
10 - 23.05.18 - 12:52
крак ставили на платформу?
 
 Рекламное место пустует
   lEvGl
 
11 - 23.05.18 - 12:54
ну так препроцессоры же в 8.3
   lEvGl
 
12 - 23.05.18 - 12:54
#ВнешнееСоединение или как там на функцию
   dka80
 
13 - 23.05.18 - 13:16
В базе 1:
#Если ВнешнееСоединение Тогда
&НаСервере
Функция МояФункция() Экспорт
КонецФункции
#КонецЕсли

Галки на общем модуле: Сервер, Внешнее соединение, Вызов сервера.

В базе 2 создал серверный общий модуль. Перенес в него вызов функции. Все равно не видит
   Вафель
 
14 - 23.05.18 - 13:17
у модуля галка внеш.соед стоит?
   Вафель
 
15 - 23.05.18 - 13:17
внешнее соединение - это не на сервере
   hhhh
 
16 - 23.05.18 - 13:18
(13) &НаСервере выкинь.
   Малыш Джон
 
17 - 23.05.18 - 13:18
(13) галка "Вызов сервера" нужна для модулей, содержащих серверные процедуры, вызываемые с клиента
   Малыш Джон
 
18 - 23.05.18 - 13:19
+(17) дело не в ней, просто в (13) она не нужна
   dka80
 
19 - 23.05.18 - 13:26
Ура, товарищи!

#Если ВнешнееСоединение Тогда 

Функция МояФункция() Экспорт
КонецФункции
#КонецЕсли

Вот так отработало.
Всем спасибо.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует