Вход | Регистрация



Как сложить заявки водителей в таблице ?

Как сложить заявки водителей в таблице ?
Я
   s_IDR
 
23.05.18 - 12:11
У меня такой вопрос, у меня в таблице есть водители у каждого из которых есть несколько заявок скажем: у первого 10, у второго 8, у третьего 6. Мне нужно непосредственно в 1С сложить все заявки в "Итого" что бы узнать все заявки водителей, не намекнёте как это можно сделать ? И ещё у меня это работает так у меня есть скажем один реквизит скажем "Всего" на него ссылается каждый водитель,
И как мне сложить их заявки в коде если за них отвечает один реквизит ?
 
 
   Timon1405
 
1 - 23.05.18 - 12:15
Идет вступительный экзамен в институте. Заходит первый абитуриент. Приемная комиссия:
— Сколько будет 2+2?
— 5.
— Нет.
— 6.
— Нет.
— 8.
— Неправильно, но берем — дурак, зато ищущий.
Заходит второй абитуриент. Приемная комиссия:
— Сколько будет 2+2?
— 3.
— Нет.
— 3.
— Нет.
— 3.
— Неправильно, но берем — дурак, зато упорный.
Заходит третий абитуриент. Приемная комиссия:
— Сколько будет 2+2?
— 4, конечно!
— Правильно! Ты смотри, какой умный... извини, но мест больше нет.
   Любопытная
 
2 - 23.05.18 - 12:15
Шо, опять?
   shuhard
 
3 - 23.05.18 - 12:15
(0) схему данных выложи, телепаты в отпуске
   aka AMIGO
 
4 - 23.05.18 - 12:16
(0) Ты пытался написать какой-нибудь код в 1с?
   lodger
 
5 - 23.05.18 - 12:17
(0) задача сформулирована плохо.
сформулируй заново, в процессе поймешь как быть.
   s_IDR
 
6 - 23.05.18 - 12:17
&НаКлиенте
Процедура СостаниеПриИзменении(Элемент)
      
 Если Объект.Состаяние =  ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Недовезён") или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Отменён") Тогда
 
     
    Элементы.ПричинаНедовоза.Доступность = истина;
Иначе
    Элементы.ПричинаНедовоза.Доступность = ложь;
    
КонецЕсли;

    Объект.Всего = Объект.Всего;
    Объект.Выполненны = Объект.Выполненны;
    Объект.ВсегоНеВыполненны = Объект.ВсегоНеВыполненны;
    Объект.Неуважительные = Объект.Неуважительные;
    Объект.Уважительные = Объект.Уважительные;
  

Если Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Принят")
или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.В_работе")
или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Выполнен")
или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Недовезён") 
или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Отменён")  Тогда
    Объект.Всего  = Объект.Всего + 1;

КонецЕсли;

Если Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Принят")
или  Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Выполнен")
или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.В_работе") Тогда
Объект.Выполненны = Объект.Выполненны + 1;
    

КонецЕсли;

Если Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Недовезён") или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Отменён")  Тогда
 Объект.ВсегоНеВыполненны =  Объект.ВсегоНеВыполненны + 1;
КонецЕсли;

Если Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Недовезён") и УважительнаяПричина = Истина
    или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Отменён") и УважительнаяПричина = Истина
    
Тогда    
Объект.Уважительные =  Объект.Уважительные + 1;

КонецЕсли;


Если Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Недовезён") и УважительнаяПричина = Ложь
    или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Отменён") и УважительнаяПричина = Ложь
    
Тогда    
Объект.Неуважительные =  Объект.Неуважительные + 1;

КонецЕсли;

Вот код
   VladZ
 
7 - 23.05.18 - 12:18
(0) Не твое это. Забей.
   Любопытная
 
8 - 23.05.18 - 12:19
(6) О боже, мои глаза(((
   palladyi
 
9 - 23.05.18 - 12:20
тебе нужно сложить уважительные, неуважительные и так далее?
Или "Всего" каждого объекта?
   aka AMIGO
 
10 - 23.05.18 - 12:21
(6) А теперь по исходным данным покажи, как должен выглядеть результат.


(8) :)

lodger в (5) абсолютно прав. Кто ясно мыслит - тот ясно излагает.
 
 Рекламное место пустует
   s_IDR
 
11 - 23.05.18 - 12:21
как сюда кинуть скрин ?
   Малыш Джон
 
12 - 23.05.18 - 12:21
зато старательный)

Объект.Всего = Объект.Всего;
Объект.Выполненны = Объект.Выполненны;
Объект.ВсегоНеВыполненны = Объект.ВсегоНеВыполненны;
Объект.Неуважительные = Объект.Неуважительные;
Объект.Уважительные = Объект.Уважительные;

и недоверчивый)
   VladZ
 
13 - 23.05.18 - 12:22
(6) .....

Смешались в кучу кони, люди,
И залпы тысячи орудий
Слились в протяжный вой...
   aka AMIGO
 
14 - 23.05.18 - 12:23
   _Дайвер_
 
15 - 23.05.18 - 12:23
(0) Твоя задача поставленна не правильно изначально. а вообще делается: выгрузи ТЧ в массив, потом сгруппируй по колонке водитель, так ты по каждому водителю получишь свое "итого"
   Малыш Джон
 
16 - 23.05.18 - 12:23
и судя по коду:

Если Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Принят")
или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.В_работе")
или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Выполнен")
или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Недовезён") 
или Объект.Состаяние = ПредопределенноеЗначение("Перечисление.ПеречислениеСостояний.Отменён")  Тогда
    Объект.Всего  = Объект.Всего + 1;

КонецЕсли;

нужно знать сколько раз изменили "Состаяние" в ходе работы)
   s_IDR
 
17 - 23.05.18 - 12:23
Прекрасное место: цитаты, анекдоты, оскорбления
   Масянька
 
18 - 23.05.18 - 12:24
(1) Сбаша (прямо в тему):
Fribo - робот для тех, кто живет один. Инженеры из Южной Кореи разработали робота Fribo, который, как предполагается, поможет молодым людям, живущим поодиночке, преодолеть социальную изоляцию. Устройство собирает информацию о том, чем занимается человек дома в течение дня, и может делиться ей с его друзьями, у которых также есть Fribo, побуждая к коммуникации.

Fribo-19: Мой сегодня достиг 445 уровня в игре Инди-Кот, ел плохо, еще не не какал

Fribo-67: Нашел Сундук пандоры в Саге о Вампире, Скушал первое с аппетитом, на второе только котлетку, слушал Лепса, хандрил

Неизвестный хакер: ...б%:?ть....!!! лучше б я пошел получать этот гребаный сертификат по 1С....
   Малыш Джон
 
19 - 23.05.18 - 12:25
(17) это что за задание?
тестовое на новом месте работы? или в универе срочно курсовую надо сдать?
   palladyi
 
20 - 23.05.18 - 12:25
(17) так никто не понимает пока, что тебе нужно)
Вот и убивают время)
   s_IDR
 
21 - 23.05.18 - 12:26
Тестовое на новом месте работы
   aka AMIGO
 
22 - 23.05.18 - 12:26
(17) Оскорблений нет, форумчане пытаются понять твою задачу. Пока удается плохо.
   _Дайвер_
 
23 - 23.05.18 - 12:26
(17) Твой код можно смело выкладывать на Говнокод, не работает сайт что-то кстати:\
   s_IDR
 
24 - 23.05.18 - 12:26
Щас попытаюсь хорошо описать
   Малыш Джон
 
25 - 23.05.18 - 12:26
(21) ну тогда, извини... я так твоего работодателя подставлять не буду, тебе рано на это место работы
   0xFFFFFF
 
26 - 23.05.18 - 12:27
Нахрен код. Берем консоль отчетов, пару десятков жмаканий мышкой и никому ненужный отчет готов!
   palladyi
 
27 - 23.05.18 - 12:27
(21) соглашусь с (25)
лучше поищи франч, с местом стажера. На полноценного программиста еще рано
   Timon1405
 
28 - 23.05.18 - 12:27
(19) очевидно же что универ, как грибы по осени вылезают в мае халявщики (21) врет, что это за работа, где на собеседовании просят сложить три числа
   VladZ
 
29 - 23.05.18 - 12:28
(21) Круто, чо. А на какую должность? ;)
   palladyi
 
30 - 23.05.18 - 12:29
(28) а зачем студенту врать, что это тестовое? студенту наоборот, объяснили бы что к чему (надеюсь), что бы понял и смог сделать
   s_IDR
 
31 - 23.05.18 - 12:29
   s_IDR
 
32 - 23.05.18 - 12:29
вот таблица
   la luna llena
 
33 - 23.05.18 - 12:30
почему Объект.СостАяние?
 
 
   Любопытная
 
34 - 23.05.18 - 12:30
(31) Так это отчет? Тогда вам в СКД
   aka AMIGO
 
35 - 23.05.18 - 12:31
(28) Вполне достаточная задача по сложению трех чисел, чтобы представить уровень умения.

(33) да ладно уж :)
В остальном синтаксический контроль 1с рулит :)
   0xFFFFFF
 
36 - 23.05.18 - 12:31
(6) начнем с того, что Состояния (а также Состания и Состаяния и прочие статусы) хранятся не в объекте, а в регистре сведений. Ну это по-правильному, чтобы при изменении состояния не перезаписывать объект. Далее, "вторичные" признаки такие как выполнен и уважительный или нет - можно хранить в том же РС. А установку этих вторичных половых признаков устанавливать в модуле этого РС. Тогда все упростится до макисимума.
   _Дайвер_
 
37 - 23.05.18 - 12:32
(31) Группировку никто не запрещал делать...
   s_IDR
 
38 - 23.05.18 - 12:33
Я понял спасибо! Теперь я и мои СостАяния всё починят.
   igorPetrov
 
39 - 23.05.18 - 12:40
(38) Ну, вот и хорошо. Иди домой.
   aka AMIGO
 
40 - 23.05.18 - 12:45
(38) Да. И почитай еще раз (36), уясни: соответствует-ли схема твоей задаче. Если нет - найди место хранения данных
Тебе уже помогли, как могли.
   Вася Теркин
 
41 - 24.05.18 - 09:43
Точно, больше хохмить не можем. Не то состаяние...
   Вася Теркин
 
42 - 24.05.18 - 09:44
(38) Ухади


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует