Вход | Регистрация


Конвертация данных. Дополнительные реквизиты.

Конвертация данных. Дополнительные реквизиты.
Я
   Margarita_Irk
 
23.05.18 - 07:22
Доброго дня всем.

Настраиваю обмен между 1С УПП и БП 3.0. Нужно перекинуть справочник Основных средств из УПП в БП. Причем часть реквизитов карточки ОС УПП загрузить в Дополнительные реквизиты карточки ОС БП.

Доп реквизиты в БП хранятся в таблице. На текущий момент данные в нее загружаются, но на форму карточки ОС БП не выводятся. В чем может быть проблема?

Код обработчика После загрузки:

Если Не ПараметрыОбъекта = Неопределено     
    и ТипЗнч(ПараметрыОбъекта) = Тип("Структура")Тогда
 
    Объект.ДополнительныеРеквизиты.Очистить();
    Если  ПараметрыОбъекта.Свойство("упп_ВидДвигателя") = Истина Тогда
        НовСтр = Объект.ДополнительныеРеквизиты.Добавить();
        НовСтр.Значение = ПараметрыОбъекта.упп_ВидДвигателя;
        НовСтр.ТекстоваяСтрока= ПараметрыОбъекта.упп_ВидДвигателя;
        НовСтр.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Вид двигателя");
    КонецЕсли;
        Если  ПараметрыОбъекта.Свойство("упп_ГабаритныеРазмеры") = Истина Тогда
        НовСтр = Объект.ДополнительныеРеквизиты.Добавить();
        НовСтр.Значение = ПараметрыОбъекта.упп_ГабаритныеРазмеры;
        НовСтр.ТекстоваяСтрока= ПараметрыОбъекта.упп_ГабаритныеРазмеры;
        НовСтр.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Габаритные размеры");
    КонецЕсли;
        Если  ПараметрыОбъекта.Свойство("упп_ГаражныйНомерТС") = Истина Тогда
        НовСтр = Объект.ДополнительныеРеквизиты.Добавить();
        НовСтр.Значение = ПараметрыОбъекта.упп_ГаражныйНомерТС;
        НовСтр.ТекстоваяСтрока= ПараметрыОбъекта.упп_ГаражныйНомерТС;
        НовСтр.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Гаражный номер ТС");
    КонецЕсли;
        Если  ПараметрыОбъекта.Свойство("упп_ГодИзготовленияТС") = Истина Тогда
        НовСтр = Объект.ДополнительныеРеквизиты.Добавить();
        НовСтр.Значение = ПараметрыОбъекта.упп_ГодИзготовленияТС;
        НовСтр.ТекстоваяСтрока= ПараметрыОбъекта.упп_ГодИзготовленияТС;
        НовСтр.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Год изготовления ТС");
    КонецЕсли;
    
    Если  ПараметрыОбъекта.Свойство("упп_КатегорияТС") = Истина Тогда
        НовСтр = Объект.ДополнительныеРеквизиты.Добавить();
        НовСтр.Значение = ПараметрыОбъекта.упп_КатегорияТС;
        НовСтр.ТекстоваяСтрока= ПараметрыОбъекта.упп_КатегорияТС;
        НовСтр.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Категория ТС");
    КонецЕсли;
        Если  ПараметрыОбъекта.Свойство("упп_КонструкциоонаяМасса") = Истина Тогда
        НовСтр = Объект.ДополнительныеРеквизиты.Добавить();
        НовСтр.Значение = ПараметрыОбъекта.упп_КонструкциоонаяМасса;
        НовСтр.ТекстоваяСтрока= ПараметрыОбъекта.упп_КонструкциоонаяМасса;
        НовСтр.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Конструкционная масса");
    КонецЕсли;
    Объект.Записать();
     КонецЕсли;
 
 
   DrShad
 
1 - 23.05.18 - 07:55
назначение свойств
   Margarita_Irk
 
2 - 23.05.18 - 09:33
то есть?
   hhhh
 
3 - 23.05.18 - 09:37
(2) наверно всё-таки лучше с типовой такие вещи общедоступные копипастить, чем самому мучиться.
   rozer76
 
4 - 23.05.18 - 09:44
(0) намекаю что кроме пвх есть еще спр. НаборыДополнительныхРеквизитовИСведений
   rozer76
 
5 - 23.05.18 - 09:45
(3) + 1
   Margarita_Irk
 
6 - 23.05.18 - 10:47
не помогло

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует