Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Вывести таблицу значений на форму с группировками

Вывести таблицу значений на форму с группировками
Я
   skupidom
 
21.05.18 - 21:16
Нужно вывести результат выборки запроса в таблицу значений с группировками,есть примеры?
 
 
   jsmith82
 
1 - 21.05.18 - 21:18
дерево значений
   Boleev
 
2 - 21.05.18 - 21:47
Стаж: 7 лет 7 месяцев 16 дней
Я совсем перестал разбираться в этой жизни.
   Chameleon1980
 
3 - 21.05.18 - 22:01
ТЗ в запрос
в запросе использовать ИТОГИ ПО
выгрузить результат запроса в дерево

параметр какой-то метода выгрущить

бинго ИМХО
   skupidom
 
4 - 21.05.18 - 22:53
ДеревоЗначОбъект = РеквизитФормыВЗначение("ДеревоЗнач");
    
    Сп = Новый СписокЗначений;
    Сп.Добавить(ПланыСчетов.Хозрасчетный.РасчетыСПоставщикамиИПодрядчиками);    
    
    ЗапросДанные = Новый Запрос;
    ЗапросДанные.Текст =
    "ВЫБРАТЬ
    |    ХозрасчетныйОстатки.Организация КАК Организация,
    |    ХозрасчетныйОстатки.Субконто1 КАК Субконто1,
    |    ХозрасчетныйОстатки.Субконто2 КАК Субконто2,
    |    СУММА(ХозрасчетныйОстатки.СуммаОстатокДт) КАК СуммаОстатокДт,
    |    СУММА(ХозрасчетныйОстатки.КоличествоОстатокДт) КАК КоличествоОстатокДт
    |ИЗ
    |    РегистрБухгалтерии.Хозрасчетный.Остатки(&ТекДата, , , ) КАК ХозрасчетныйОстатки
    |ГДЕ
    |    ХозрасчетныйОстатки.Счет В ИЕРАРХИИ(&Сп)
    |
    |СГРУППИРОВАТЬ ПО
    |    ХозрасчетныйОстатки.Субконто1,
    |    ХозрасчетныйОстатки.Субконто2,
    |    ХозрасчетныйОстатки.Организация
    |ИТОГИ
    |    СУММА(СуммаОстатокДт),
    |    СУММА(КоличествоОстатокДт)
    |ПО
    |    Организация,
    |    Субконто1,
    |    Субконто2";
    ЗапросДанные.УстановитьПараметр("ТекДата",ТекущаяДата());
    ЗапросДанные.УстановитьПараметр("Сп",Сп);
    РезЗапроса = ЗапросДанные.Выполнить();
    ВыборкаСуб1 = РезЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    Пока ВыборкаСуб1.Следующий() Цикл
        НоваяСтр = ДеревоЗначОбъект.Строки.Добавить();
        НоваяСтр.Выбран = Истина;
        ЗаполнитьЗначенияСвойств(НоваяСтр,ВыборкаСуб1);
        ВыборкаСуб2 = ВыборкаСуб1.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
        Пока ВыборкаСуб2.Следующий() Цикл
            НоваяСтр2 = НоваяСтр.Строки.Добавить();
            НоваяСтр2.Выбран = Истина;
            ЗаполнитьЗначенияСвойств(НоваяСтр2,ВыборкаСуб2);
            ВыборкаСуб3 = ВыборкаСуб2.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
            Пока ВыборкаСуб3.Следующий() Цикл
                НоваяСтр3 = НоваяСтр2.Строки.Добавить();
                НоваяСтр3.Выбран = Истина;
                ЗаполнитьЗначенияСвойств(НоваяСтр3,ВыборкаСуб3);                 
            КонецЦикла;
        КонецЦикла;        
    КонецЦикла;
    
    ЗначениеВРеквизитФормы(ДеревоЗначОбъект,"ДеревоЗнач");
   skupidom
 
5 - 21.05.18 - 22:54
в дерево значений вывел, а если во временную таблицу на форму ?
   Cyberhawk
 
6 - 21.05.18 - 22:56
Дерево значений и так выводится в таблицу формы
   Cyberhawk
 
7 - 21.05.18 - 22:57
Никто не запрещает тебе объединить колонки таблицы формы в группы и получить нужную "группировку"
   skupidom
 
8 - 21.05.18 - 23:01
можно пример
   skupidom
 
9 - 21.05.18 - 23:01
реализации
   Cyberhawk
 
10 - 21.05.18 - 23:11
 
 Рекламное место пустует
   skupidom
 
11 - 21.05.18 - 23:35
не серьезно
   Cyberhawk
 
12 - 21.05.18 - 23:36
Теперь Я жду картинку от тебя, на которой будет видно, чего тебе надобно
   SleepyHead
 
13 - 22.05.18 - 05:29
(2) Просто посмотри другие его темы, и все станет ясно.
   hhhh
 
14 - 22.05.18 - 06:13
(2) не стареют душой ветераны.
   catena
 
15 - 22.05.18 - 06:28
Фотка женская, имя - Марфа, пол женский. Пишет о себе в мужском роде. Странно все это.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует