Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Небольшое изменение обработки без знания кодирования в 1С

Небольшое изменение обработки без знания кодирования в 1С
Я
   BayJay
 
21.05.18 - 15:06
Здравствуйте. Приобрели обработку на инфостарте(http://catalog.mista.ru/public/80839/). Как можно маленько переписать обработку, чтобы при запуске обработки в поле "Время автоматической установки дат запрета изменения данных" стояло время "00ч 00мин 10сек" и стаяла галочка включенной по умолчанию "Включить расписание"? На 3м скриншоте видно эти строки.
Код там такой:
Процедура ВключитьРасписаниеПриИзменении(Элемент)
    
    Если ВключитьРасписание = Истина Тогда        
        ПодключитьОбработчикОжидания("УстановитьРазрешенныйПериод",1);
    Иначе
        ОтключитьОбработчикОжидания("УстановитьРазрешенныйПериод");
        ЭлементыФормы.НадписьВремя.Заголовок = "";
    КонецЕсли;
КонецПроцедуры

Процедура УстановитьРазрешенныйПериод()
    ЭлементыФормы.НадписьВремя.Заголовок = Формат(ТекущаяДата(),"ДЛФ=T");
    Если Формат(ТекущаяДата(),"ДЛФ=T") = Формат(ВремяУстановкиЗапрета,"ДЛФ=T") Тогда
        мУстановитьРазрешенныйПериод();
    КонецЕсли;
КонецПроцедуры


Процедура ВремяУстановкиЗапретаНачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ВремяУстановкиЗапрета = ТекущаяДата() + 5;

КонецПроцедуры

Процедура ОсновныеДействияФормыСохранить(Кнопка)
    мСохранить();
    Модифицированность = Ложь;
    мЗаполнитьТаблицуДатыЗапрета();
КонецПроцедуры
 
 
   Вафель
 
1 - 21.05.18 - 15:07
может у разработчика спросить?
   Вафель
 
2 - 21.05.18 - 15:08
а зачем кстать нужна галочка автоматом? ведь расписание настраивается 1 раз
   shuhard
 
3 - 21.05.18 - 15:09
(1) +1
автор получил профит - нехай отдувается
   Tatitutu
 
4 - 21.05.18 - 15:09
   BayJay
 
5 - 21.05.18 - 15:10
Разработчик выложил ее в 11 году.. Я в теме написал, но толку походу не будет.
Если обработку закрыть, то адо будет вбивать время и ставить галочку заного. Для автоматического запуска 1С при перезагрузке, залазить на комп и включать неочень
   Ёпрст
 
6 - 21.05.18 - 15:11
(0)
ВремяУстановкиЗапрета = НачалоДня(ТекущаяДата()) + 10;
   BayJay
 
7 - 21.05.18 - 15:14
(6) Это работает если нажать на троеточие.. Может написать где-нибудь - "При открытии"?
   kda26
 
8 - 21.05.18 - 15:15
ПередОткрытием()
   BayJay
 
9 - 21.05.18 - 15:16
(8) а можно строчку целиком? В коде 1С я 0
   aka AMIGO
 
10 - 21.05.18 - 15:17
(9) Это и есть строчка - имя процедуры.
 
 Рекламное место пустует
   BayJay
 
11 - 21.05.18 - 15:18
(10) а куда ее писать?
ПередОткрытием()ВремяУстановкиЗапрета = НачалоДня(ТекущаяДата()) + 10;
так пишет ошибку
   Кац
 
12 - 21.05.18 - 15:19
Процедура ПередОткрытием() нужна
   kda26
 
13 - 21.05.18 - 15:20
Открой в конфиграторе модуль формы обработки, выбери обработчик ПередОткрытием, создасться процедура, в нее и внеси код из (10)
   BayJay
 
14 - 21.05.18 - 15:21
(13) Вот так пишет ошибку всеравно
Процедура ВремяУстановкиЗапретаНачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Процедура ПередОткрытием()
        ВремяУстановкиЗапрета = НачалоДня(ТекущаяДата()) + 10;
    КонецПроцедуры

КонецПроцедуры
   Кац
 
15 - 21.05.18 - 15:21
а что, без процедуры не сработает?

внизу модуля обработки, напиши эти строки
ВремяУстановкиЗапрета = НачалоДня(ТекущаяДата()) + 10;
   BayJay
 
16 - 21.05.18 - 15:23
(15) он работает если только нажать на три точки. А нужно чтобы время ставилось при открытии обработки
   Кац
 
17 - 21.05.18 - 15:24
(16) вот и напиши это в саамом низу
ВремяУстановкиЗапрета = НачалоДня(ТекущаяДата()) + 10;
   kda26
 
18 - 21.05.18 - 15:25
Процедура в процедуре не описывется.

Процедура ВремяУстановкиЗапретаНачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;

КонецПроцедуры

Процедура ПередОткрытием()
     ВремяУстановкиЗапрета = НачалоДня(ТекущаяДата()) + 10;

ВключитьРасписание (или, что там источником флажка на форме) = Истина;

КонецПроцедуры
   dezss
 
19 - 21.05.18 - 15:29
уже б выложил обработку куда-нибудь и ее бы уже поправили и перевыложили
   BayJay
 
20 - 21.05.18 - 15:31
   aka AMIGO
 
21 - 21.05.18 - 15:31
(19) обработка аж целый доллар стоит. Хитришь :)
   Кац
 
22 - 21.05.18 - 15:33
(21) полбакса, судя по курсу сратмани
   _Дайвер_
 
23 - 21.05.18 - 15:35
   BayJay
 
24 - 21.05.18 - 15:36
(23) СПАСИБО БОЛЬШОЕ!:)
   BayJay
 
25 - 21.05.18 - 15:43
(23) Когда вручную галочку включаешь там показывает текушее время, справа под окошком. Его никак нельзя активировать тоже? Пожалуйста
   exwill
 
26 - 21.05.18 - 15:45
(25) Во! Аппетит приходит во время еды.
   dezss
 
27 - 21.05.18 - 15:46
   BayJay
 
28 - 21.05.18 - 15:46
(26) не, там просто от этого времени идет отсчет когда заблокировать дату запрета. А так получается галочка стоит, время тоже, но в это время не заблокирует
   dezss
 
29 - 21.05.18 - 15:46
я сразу так сделал, просто не выложил, увидев, что кто-то другой уже таво)
   DmitriyDI
 
30 - 21.05.18 - 15:47
(26) ухахах, точно)) как солдат кашу из топора варил))
   BayJay
 
31 - 21.05.18 - 15:47
(29) Во! красота! Спасибо всем большое кто ответил! Всем добра!))
   dezss
 
32 - 21.05.18 - 15:49
вот интересно, а теперь сюда придет Доржи?
а будет ли он ругаться за то, что его обработки забесплатно дают скачивать?))))
   dezss
 
33 - 21.05.18 - 15:50
(32) + а может придет Маня и будет петь про то, как прогнил инфостарт?
 
 


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует