Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Произвольные колонки в списке документов, обычные формы

Произвольные колонки в списке документов, обычные формы
Я
   trey1
 
21.05.18 - 11:26
Приветствую, такой вопрос нужно в список документа добавить произвольную колонку с расчетом по заданной форме. Как это сделать на обычных формах? Про управляемые знаю, что там все делается через динамический список а тут ума не приложу
 
 
   catena
 
1 - 21.05.18 - 11:29
Добавить колонку, заполнять в ПриПолученииДанных.

Но лучше все-таки сделать управляемую форму списка с ДС, работать будет шустрее, разрабатывать проще.
   trey1
 
2 - 21.05.18 - 11:51
(1) Колонку можно программно добавить? Я добавил колонку в список, уже отловил процедуру на форме, но теперь ошибка: Поле объекта недоступно для записи в 1С
   trey1
 
3 - 21.05.18 - 11:52
Про упр. формы знаю что в этом плане проще но тут 10.3 и обычные формы только
   Chameleon1980
 
4 - 21.05.18 - 11:52
(2) не в то пишеш. недолет, скорее, всего
код показывай
   Chameleon1980
 
5 - 21.05.18 - 11:52
+(4) отладчиком смотри
   RomanYS
 
6 - 21.05.18 - 11:54
(2) посмотри в любой типовой поиском ПриПолученииДанных или ПриВыводеСтроки. Изменять надо оформление строк.
   trey1
 
7 - 21.05.18 - 11:55
ну вот :

Процедура ДокументСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    сумма = 0;
    для каждого стр из ДанныеСтроки.Ссылка.СписокПеремещений цикл
    сумма = сумма+ стр.Перемещение.СуммаДокумента;
        
КонецЦикла;
ДанныеСтроки.СуммаДокументов = сумма;

    // Вставить содержимое обработчика.

КонецПроцедуры

мне надо в колонку СуммаДокументов сумму написать, если я ее отвязываю от реквизита то вообще не могу выбрать
   Chameleon1980
 
8 - 21.05.18 - 11:55
ну.
Для Каждого ОформлениеСтроки Из ОформленияСтрок
и попер
   Chameleon1980
 
9 - 21.05.18 - 11:56
В при полученииДанных юзай
   Chameleon1980
 
10 - 21.05.18 - 11:56
ИМХО быстрее
 
 Рекламное место пустует
   Chameleon1980
 
11 - 21.05.18 - 11:56
отладчик уже смотрел?
   catena
 
12 - 21.05.18 - 11:57
Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
Для каждого Строка Из ОформленияСтрок Цикл
    Регистратор = Строка.ДанныеСтроки.Ссылка;
КонецЦикла


Устанавливать так же.
   trey1
 
13 - 21.05.18 - 12:05
(11) Да спасибо, разобрался.

ОформлениеСтроки.Ячейки.СуммаДокументов.Текст = сумма;

и все заработало
   RomanYS
 
14 - 21.05.18 - 12:08
(13) если ты про (7), то оно ужасно. Даже если ошибок нет.
Для нормальной работы обязательно переделать на ПриПолученииДанных и запрос.
   trey1
 
15 - 21.05.18 - 13:03
(14) Ну да, лучше так, я прост написал для общего понимания себе т.к вообще не работал с ОФ

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует