Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Редактирование прайс-листа в УТ 10.3

Редактирование прайс-листа в УТ 10.3
Я
   drunken_ikarus
 
18.05.18 - 07:58
Понимаю что подобные вопросы для знатоков как зубная боль, но честно пытался найти ответ и справиться самостоятельно.
В общем тривиальная задача, в макет прайс-листа вывести полное наименование вместо краткого, думал банально найти в коде Наименование и заменить на НаименованиеПолное, но фига с два я его там нашел, выручайте, знатоки!!!
 
 
   Metman
 
1 - 18.05.18 - 08:13
Либо правь в запросе, либо в настройках добавь поле с полным наименованием.
   shuhard
 
2 - 18.05.18 - 08:13
(0) попробуй вместо эмоций описать проблему
   drunken_ikarus
 
3 - 18.05.18 - 08:38
(2) проблема в том что я чайник в 1с, и прошу готового кода и места куда воткнуть
   mehfk
 
4 - 18.05.18 - 08:49
(3) Воткни в 42 строку.
   Михаил Козлов
 
5 - 18.05.18 - 09:28
Попробуйте найти в модуле обработки ПечатьПрайсЛиста процедуру
ЗаполнитьПостроительОтчетаПоЦенамНоменклатуры.
И  в тексте запроса вместо 
|    ЗапросПрайс.Номенклатура.Представление КАК НоменклатураПредставление,
написать
|    ВЫРАЗИТЬ(ЗапросПрайс.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)) КАК НоменклатураПредставление,
это строка № 250 в моей УТ.
   drunken_ikarus
 
6 - 18.05.18 - 10:59
(5) Михаил, благодарю привелико, все получилось
   drunken_ikarus
 
7 - 18.05.18 - 11:05
(5) Стоп, вру! поторопился, не получилось, то же краткое наименование
   Михаил Козлов
 
8 - 18.05.18 - 11:33
(7) Да, группировки НоменклатураПредставление не используется.
Если будет время, попробую разобраться и напишу.
   Доминошник
 
9 - 18.05.18 - 12:45
(8) Да всё сделано, осталось только в настройках в сортировке указать не номенклатуру, а НоменклатураПредставление
   drunken_ikarus
 
10 - 18.05.18 - 13:04
(9) Действительно, теперь выводит полное наименование, только при этом в иерархии у групп нет наименования
 
 Рекламное место пустует
   Михаил Козлов
 
11 - 18.05.18 - 13:09
(10) Попробуйте в запросе для групп в качестве представления указать Наименование:
ВЫБОР КОГДА ЗапросПрайса.Номенклатура.ЭтоГруппа ТОГДА      ЗапросПрайс.Номенклатура.Представление ИНАЧЕ <текст с полным наименованием> КОНЕЦ КАК НоменклатураПредставление,
   drunken_ikarus
 
12 - 18.05.18 - 14:23
если вот так:
<code>
|    ВЫБОР КОГДА ЗапросПрайс.Номенклатура.ЭтоГруппа ТОГДА
|        ЗапросПрайс.Номенклатура.Представление
|    ИНАЧЕ
|    ВЫРАЗИТЬ(ЗапросПрайс.Номенклатура.НаименованиеПолное КАК СТРОКА(1000))
|    КОНЕЦ КАК НоменклатураПредставление,
</code>
то не работает
   Михаил Козлов
 
13 - 18.05.18 - 14:50
(12) Не работает в смысле при выводе в иерархии у папок нет наименования? Или не выводит полное наименование у элементов?
   Доминошник
 
14 - 18.05.18 - 15:38
(11) (12) (13) Выбор Когда в запросе - лишнее.
В запросе идёт работа по детальным записям.

Соответственно, что бы выводило всё правильно, надо в процедуре ВывестиСтрокуПрайса поменять условие
            Если КолонкиРезультата.Найти(НазваниеГруппировки + "Представление") = Неопределено Тогда
                ПредставлениеГруппировки = Выборка[НазваниеГруппировки];
            Иначе
                ПредставлениеГруппировки = Выборка[НазваниеГруппировки + "Представление"];
            КонецЕсли;

на

            Если КолонкиРезультата.Найти(НазваниеГруппировки + "Представление") = Неопределено Тогда
                ПредставлениеГруппировки = Выборка[НазваниеГруппировки];
            Иначе
                Если Выборка[НазваниеГруппировки + "Представление"] = NULL Тогда
                    ПредставлениеГруппировки = Выборка[НазваниеГруппировки];
                Иначе
                    ПредставлениеГруппировки = Выборка[НазваниеГруппировки + "Представление"];
                КонецЕсли;
            КонецЕсли;
   drunken_ikarus
 
15 - 21.05.18 - 07:57
(5) (9) (14) Отлично! Все работает! В итоге:
1.
ЗаполнитьПостроительОтчетаПоЦенамНоменклатуры.
И  в тексте запроса вместо 
|    ЗапросПрайс.Номенклатура.Представление КАК НоменклатураПредставление,
написать
|    ВЫРАЗИТЬ(ЗапросПрайс.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)) КАК НоменклатураПредставление,

2.
В процедуре ВывестиСтрокуПрайса поменять условие 
            Если КолонкиРезультата.Найти(НазваниеГруппировки + "Представление") = Неопределено Тогда
                ПредставлениеГруппировки = Выборка[НазваниеГруппировки];
            Иначе
                ПредставлениеГруппировки = Выборка[НазваниеГруппировки + "Представление"];
            КонецЕсли;

на

            Если КолонкиРезультата.Найти(НазваниеГруппировки + "Представление") = Неопределено Тогда
                ПредставлениеГруппировки = Выборка[НазваниеГруппировки];
            Иначе
                Если Выборка[НазваниеГруппировки + "Представление"] = NULL Тогда
                    ПредставлениеГруппировки = Выборка[НазваниеГруппировки];
                Иначе
                    ПредставлениеГруппировки = Выборка[НазваниеГруппировки + "Представление"];
                КонецЕсли;
            КонецЕсли;

3. В настройках в сортировке указать не номенклатуру, а НоменклатураПредставление

Всем приогромнейшее спасибо!!!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует