Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Вопрос по вызову ВПФ

Вопрос по вызову ВПФ
Я
   Ignatiy
 
15.05.18 - 11:30
Добрый день. Возникла такая проблема.

Внешней обработкой вызываю ВПФ УПД из справочника.

&&На Сервере
Функция НайтиВПФУПД()
Возврат    Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("УПД ТЕСТОВАЯ (внешняя)");
КонецФункции



&&На Клиенте
Процедура Печать ВПФ(Команда)
    
    ВПФ_УПД =  НайтиВПФУПД();
    
    НовДок = ПолучитьНовыйДокумент();
        
    //Выводим УПД

    Если ВПФ_УП.Пустая() Тогда
    Сообщить("УПД Нет");
            Возврат;
        Иначе
//    

    Сообщить("Обработка по УПД есть");    
    
    ОбъектыНазначения = Новый Массив;
    ОбъектыНазначения.Добавить(НовДок);
    
    ПараметрыОткрытия = Новый Структура("Источник Данных, Параметры Источника");
    Параметры Открытия.Источник Данных = В ПФ_УПД;
    ПараметрыОткрытия.ПараметрыИсточника = Новый Структура("ИдентификаторКоманды, ОбъектыНазначения");
    ПараметрыОткрытия.ПараметрыИсточника.ИдентификаторКоманды = ""ПФ_MXL_Универсальный Передаточный Документ";
    ПараметрыОткрытия.ПараметрыИсточника.ОбъектыНазначения = ОбъектыНазначения;
    
    ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия);    
    КонецЕсли;

КонецПроцедуры

 Показать

Вылетает с ошибкой 

{{Общий Модуль.УправлениеПечатью.Модуль(1214)}: В обработчике печати не был сформирован табличный документ для: ПФ_MXL_УниверсальныйПередаточныйДокумент 
ВызватьИсключение(ТекстСообщенияОбОшибке); 

Макет передается, документ реализация, который надо печатать тоже передается.

Из реализации ВПФ печатается без ошибок.

Не понимаю куда копать.
 
 
   Волшебник
 
1 - 15.05.18 - 11:32
Копай здесь
Общий Модуль.УправлениеПечатью.Модуль(1214)
   kabanoff
 
2 - 15.05.18 - 13:12
(0) Не пойму, как вот этот код должен вообще работать?

ПараметрыОткрытия = Новый Структура("Источник Данных, Параметры Источника");
Параметры Открытия.Источник Данных = В ПФ_УПД;


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует