Вход | Регистрация


Возврат массива с сервера

Возврат массива с сервера
Я
   mayet
 
13.05.18 - 16:57
В чем особенность передачи массива с реквизитами?

&НаСервере
Функция ПолучитьНовыеРеквизиты(Книга)
    
    
    нРеквизиты = Новый Массив;
    
    а = 0;
    Для Каждого ном из Книга цикл
    Реквизит = Новый РеквизитФормы("Реквизит" + а, Новый ОписаниеТипов("Строка"), , "Созданное поле", Истина);

            нРеквизиты.Добавить(Реквизит);
        КонецЕсли;
        а = а+1;
    КонецЦикла;
    ИзменитьРеквизиты(нРеквизиты);
    Возврат нРеквизиты;
КонецФункции


в процессе вознивает вот такая вот ошибка:

{Обработка.РабочийСтол.Форма.УчетНЗ.Форма(18)}: Ошибка при вызове метода контекста (ПолучитьНовыеРеквизиты)
    РеквизитыЗаписей = ПолучитьНовыеРеквизиты(Книга);
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'ret':
    форма: Элемент
    имя: {http://v8.1c.ru/8.2/managed-application/modules}ret
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'Value':
    форма: Элемент
    имя: {http://v8.1c.ru/8.1/data/core}Value
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'РеквизитФормы'
 
 
   mayet
 
1 - 13.05.18 - 16:59
Если возвращать не реквизиты то все ок
   craxx
 
2 - 13.05.18 - 17:03
(0) Тебе же русским языком написали, отсутствует отображение для типа, передавай на клиента строковые наименования.
   zwei
 
3 - 13.05.18 - 17:04
Гм. А что написано в СП по поводу мест существования типа "РеквизитФормы" ?
   mayet
 
4 - 13.05.18 - 17:06
Понял,

"РеквизитФормы"
Доступность:

Сервер, мобильное приложение(сервер).
Спасибо за объяснения, иначе бы сидел и дальше голову ломал

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует