Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Передача параметра(структуры) из одной формы в другую

Передача параметра(структуры) из одной формы в другую
Я
   DiFas
 
11.05.18 - 10:52
Всем добрый день. Подскажите, пожалуйста.
Есть справочник Контрагенты. На форме его элемента есть кнопка, при нажатии которой открывается внешняя обработка(модально), в которой создается структура. Нужно при закрытии этой внешней обработки передать созданную структуру обратно в элемент справочника Контрагенты. Пробовал при закрытии обработки задавать параметр закрытия - не помогает.
 
 
   DiFas
 
1 - 11.05.18 - 10:53
Закрыть(ДанныеКонтрагента) и ЭтаФорма.Закрыть(ДанныеКонтрагента) не помогают
   Lexey_
 
2 - 11.05.18 - 11:01
(1) весь код показывай
   DiFas
 
3 - 11.05.18 - 11:04
(2) В элементе справочника:
Процедура ДействияФормыЗаполнить(Кнопка) Экспорт
        
Обработка = МТИ.ПолучитьВнешнуюОбработку(МТИ.ПолучитьЗначениеКонстанты("ЗаполнитьКонтрагента").Код);    
ФормаРедактора = Обработка.ЭтотОбъект.ПолучитьФорму("Форма");
ФормаРедактора.ОткрытьМодально();

КонецПроцедуры

В обработке:

Процедура ЗаписьКонтрагента()

ДанныеКонтрагента = Новый Структура;
...Заполняю структуру...
Закрыть(ДанныеКонтрагента);

КонецПроцедуры
   DiFas
 
4 - 11.05.18 - 11:06
(2) Пробовал еще вот так:
Процедура ДействияФормыЗаполнить(Кнопка) Экспорт
        
Обработка = МТИ.ПолучитьВнешнуюОбработку(МТИ.ПолучитьЗначениеКонстанты("ЗаполнитьКонтрагента").Код);    
ФормаРедактора = Обработка.ЭтотОбъект.ПолучитьФорму("Форма");
ФормаРедактора.ОткрытьМодально();

КонецПроцедуры

Процедура ЗаписьКонтрагента()

ДанныеКонтрагента = Новый Структура;
...Заполняю структуру...
Оповестить("ДанныеКонтрагента", ДанныеКонтрагента);
Закрыть();
КонецПроцедуры

В элементе справочника:

Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    
Если ИмяСобытия = "ДанныеКонтрагента" Тогда
    ДанныеКонтрагента= Параметр;
КонецЕсли;
    
КонецПроцедуры
   Lexey_
 
5 - 11.05.18 - 11:08
(3) и где ты хочешь увидеть результат закрытия?
   Lexey_
 
6 - 11.05.18 - 11:09
(3) в СП про ОткрытьМодально() читал?
   Zmich
 
7 - 11.05.18 - 11:09
(3). Структура = ФормаРедактора.ОткрытьМодально();
   DiFas
 
8 - 11.05.18 - 11:10
(5) Результат нужен в элементе справочника после закрытия обработки
   DiFas
 
9 - 11.05.18 - 11:12
(6) Т.е. ОткрытьМодально() не возвращает параметр?..
   Lexey_
 
10 - 11.05.18 - 11:12
(9) как раз возвращает
 
 Рекламное место пустует
   DiFas
 
11 - 11.05.18 - 11:18
(7) Сработало!!! Спасибо!!!
   DiFas
 
12 - 11.05.18 - 11:18
(10) Спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует