Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

ТабЗначений: вывод в макет с группировкой и итогами по Подразделению

ТабЗначений: вывод в макет с группировкой и итогами по Подразделению
Я
   dft2014
 
10.05.18 - 18:10
Добрый день!
Есть готовая таблица значений, которая сейчас выводит данные в макет в виде:
Сотрудник - Подразделение - КоличествоЧасов

Подскажите, как сделать группировку по подразделениям, с выводом итогового количества часов по подразделению? сейчас код выврода такой:


функция ЗаполнимТабДок (тз,НачалоПериода,КонецПериода,КолВоЧасовПоГрафикуЗаПериод)
    ТабДок = Новый ТабличныйДокумент;            
    Макет = Отчет.РеквизитМакет;
    
    ОбластьШапка = Макет.ПолучитьОбласть("Шапка");       
    ОбластьШапка.Параметры.ДатаНачала = Формат (НачалоПериода,"ДФ=dd.MM.yyyy");
    ОбластьШапка.Параметры.ДатаОкончания = Формат (КонецПериода,"ДФ=dd.MM.yyyy");
    ТабДок.Вывести(ОбластьШапка);
    
    Если тз.Количество() > 0 Тогда
        Для каждого СтрокаТЗ из ТЗ цикл
            Если СтрокаТЗ.Часы <> 0 Тогда
                
                ОбластьСтрокаТЧ = Макет.ПолучитьОбласть("СтрокаТЧ");           
                ЗаполнитьЗначенияСвойств(ОбластьСтрокаТЧ.Параметры,СтрокаТЗ);
                ТабДок.Вывести(ОбластьСтрокаТЧ);
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
    
    ОбластьИтоги = Макет.ПолучитьОбласть("Итоги");           
    ОбластьИтоги.Параметры.Итоги = КолВоЧасовПоГрафикуЗаПериод;
    ТабДок.Вывести(ОбластьИтоги);
    ТабДок.ФиксацияСверху = 3;
    
    Возврат ТабДок
    
КонецФункции
 
 
   dft2014
 
1 - 10.05.18 - 18:16
+(0) В ТЗ данные уже хранятся в виде:
Сотрудник - Подразделение - КоличествоЧасов
   lubitelxml
 
2 - 10.05.18 - 18:17
(1) ну и группируй их запросом как тебе надо
   dft2014
 
3 - 10.05.18 - 18:19
(2) Запрос очень сложный, выгружает данные в ТЗ в уже готовом виде: Сотрудник - Подразделение - КоличествоЧасов
А вот как теперь при выводе этой ТЗ в макет сделать группировку и итоги по Подразделениям (с выводом и сотрудников)?
   lubitelxml
 
4 - 10.05.18 - 18:20
(3) добавь группировки в запрос
   lubitelxml
 
5 - 10.05.18 - 18:21
ну либо как в 7.7 - сортируй, и сравнивай в каждой строке подразделение с предыдущим значением, если изменилось - то считай итог и обнуляй его, но это все от лукавого, запросом надо делать
   dft2014
 
6 - 10.05.18 - 18:22
(4) Запрос не трогаем. Можно ли только крутить/вертеть ТЗ?
   Базис
 
7 - 10.05.18 - 18:22
Свернуть копию ТЗ, аккуратно выводить - строки из основной, итоги из копии.
   lubitelxml
 
8 - 10.05.18 - 18:22
(6) напиши запрос с группировками - где источником будет твоя ТЗ
   dft2014
 
9 - 10.05.18 - 18:23
(5), (7), (8) Спасибо, но хотелось бы реальные примеры...
   lubitelxml
 
10 - 10.05.18 - 18:30
 
 Рекламное место пустует
   dft2014
 
11 - 14.05.18 - 13:08
(10) Спасибо! Очень помогло!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует