Вход | Регистрация


Проверить по COM тип объекта

Проверить по COM тип объекта
Я
   myr4ik07
 
10.05.18 - 16:05
УзелВншСист = БД.ПланыОбмена.Обмен.НайтиПоКоду("02");
    ВыборкаИзменений = БД.ПланыОбмена.ВыбратьИзменения(УзелВншСист, 1);
    
    Пока ВыборкаИзменений.Следующий()  Цикл
        КонецЦикла;

Если ссылочный тип тогда легко получить имя 
ДанныеИмя = Данные.Ссылка.Метаданные().Name;    

а если регистр сведений, как обработать, что бы не было прерывания, а было типа
Если Регистр Тогда
ДанныеИмя = Данные.Метаданные().Name;    
Иначе
ДанныеИмя = Данные.Ссылка.Метаданные().Name;    
КонецЕсли;
 
 
   myr4ik07
 
1 - 10.05.18 - 16:06
через
Попытка
ДанныеИмя = Данные.Ссылка.Метаданные().Name;    
Исключение
ДанныеИмя = Данные.Метаданные().Name;    
КонецПопытки

?
   myr4ik07
 
2 - 10.05.18 - 16:10
вроде норм, есть идеи по красоте сделать?
   Вафель
 
3 - 10.05.18 - 16:18
А БД.ТипЗнч не работатет?
   myr4ik07
 
4 - 10.05.18 - 16:22
(3) ТипЗнч(Данные) = COM Объект
   Hmster
 
5 - 10.05.18 - 16:30
(4) Тебе типы надо сравнивать в БД!!!

Сравнение = БД.NewObject("СравнениеЗначений");
РезультатСравнения = Сравнение.Сравнить(Значение1,Значение2);
Если РезультатСравнения = 0 Тогда
//равны

Иначе    
//не равны    

КонецЕсли;
   myr4ik07
 
6 - 10.05.18 - 16:34
(5) о, вот это толково, спасибо
   Serginio1
 
7 - 10.05.18 - 17:53

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует