Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Таблица в режиме ввода данных (только просмотр)

v7: Таблица в режиме ввода данных (только просмотр)
Я
   Franchiser
 
10.05.18 - 12:55
Хочу сделать следующую возможность:
Пользователь нажимает кнопку, открывается новый отчет (в режиме ввода данных), в этот отчет из эксель пользователь через буфер вставляет колонку и по кнопке клолонка загружается в первоначально открытую обработку.
Как сделать, чтобы в отчет в режиме ввода данных можно было вставить данные из буфера, не могу отключить "только просмотр" ?
 
 
   ugorchina
 
1 - 10.05.18 - 13:02
(0) что значит не можете отключить "только просмотр" ?
   HawkEye
 
2 - 10.05.18 - 13:03
(0) самое правильно решение - не использовать таблицу в РВД )))
   ugorchina
 
3 - 10.05.18 - 13:04
(2) в Рукавах высокого давления? :-)
   HawkEye
 
4 - 10.05.18 - 13:05
(3) в них тоже не надо )))
   ugorchina
 
5 - 10.05.18 - 13:08
(4) поржал )
   vtolga
 
6 - 10.05.18 - 13:12
Возьми обычную таблицу. А если нужно обрабатывать введенные данные, то веди их и прочитать можно. Как-то так:
для ке=2 по ном цикл  
 ячейка7=Таблица.Область("R"+Сокрлп(строка(ке))+"C7");
 КоличествоВЗаказ=Число(Ячейка7.Текст);
 Если Число(КоличествоВЗаказ)<>0 тогда   
 ячейка=Таблица.Область("R"+Сокрлп(строка(ке))+"C13");
 номенклатураВЗаказ=ячейка.расшифровка();
 ТаблицаДляЗаявки.НоваяСтрока();
 ТаблицаДляЗаявки.номенклатура=номенклатураВЗаказ;
 ТаблицаДляЗаявки.Количество=КоличествоВЗаказ;
 ячейка7.текст=0;
конецесли;    
    конеццикла;
   Franchiser
 
7 - 10.05.18 - 13:43
(6) если брать обычную таблицу, то ее нужно как-то сохранять а потом выбирать файл - так не интересно.
Может кто помнит что нужно чтобы в РВД можно было печатать данные, или там только в конкретные поля можно?
   vtolga
 
8 - 10.05.18 - 13:44
Не надо ее сохранять. В свойствах формы ставишь не "таблица в режиме ввода данных", а "использовать таблицу"->"Пустую".
В остальном работа аналогична.
   vtolga
 
9 - 10.05.18 - 13:46
В эту таблицу можешь вывести любой отчет с использованием макета. Но - ее можно читать и обрабатывать.
   vtolga
 
10 - 10.05.18 - 13:47
И в нее можно вставлять из буфера.
 
 Рекламное место пустует
   ugorchina
 
11 - 10.05.18 - 13:52
посветите мне что есть РВД?
   1C programmer
 
12 - 10.05.18 - 14:09
Режим Ввода Данных
   Franchiser
 
13 - 10.05.18 - 14:20
(9) если указать пустую таблицу, как пользователь поймет в какую колонку вбивать данные?
Тут я сделал заготовку: назвал столбец по-своему, сделал рамочки на колонке.
   Franchiser
 
14 - 10.05.18 - 14:21
(10) не вставляется из буфера и в пустую таблицу
   Franchiser
 
15 - 10.05.18 - 14:23
Хотя нет вставляется если вручную отключить режим просмотра
   vtolga
 
16 - 10.05.18 - 14:26
В эту пустую таблицу вывести можно что угодно (в том числе и заголовки) с использованием обычного макета, как при печати.
   Franchiser
 
17 - 10.05.18 - 14:27
хорошо а как к ней вообще обратиться? Например, хочу программно снять "только просмотр" при открытии.
   Franchiser
 
18 - 10.05.18 - 14:33
Разобрался:     Таблица.ТолькоПросмотр(0);
OpenConf смутил - не дает набить слово Таблица.
   vtolga
 
19 - 10.05.18 - 14:36
Таблица.ВывестиСекцию("Шапка");    
Таблица.показать();
    Таблица.Толькопросмотр(0);
   Franchiser
 
20 - 10.05.18 - 14:42
(19) Шапка же в другой таблице, не в пустой...

     Таб=СоздатьОбъект("Таблица");
     Таб.ИсходнаяТаблица("Таблица");
     Таб.ВывестиСекцию("Шапка"); 
     Таблица  = Таб;///тут как нужно?   

     Таблица.Толькопросмотр(0);
   Franchiser
 
21 - 10.05.18 - 14:48
(19) отлично, все получилось. Таблица (пустая) которая является расширением формы вывелась одноименная таблица из макете)
   Злопчинский
 
22 - 11.05.18 - 02:58
буквально на днях тупо нанрисовал обработку
1. копируем из экселя нужные данные
2. вставляем на форму в строку неограниченной длины (поле ввода, сногострочное)
3. вставляется с разделением табуляторами
4. жмем загрузить и зашибись..

прикрутил эту хрень как ВПФ с системой плугинов (типа как плагины для UChoice) - под каждый справочник своя загрузка

https://www.screencast.com/t/rHk6ZPrwjVRF
   ADirks
 
23 - 11.05.18 - 08:14
(22) А если используется 1С++, то можно и без реквизита на форме.

оКлипборд = СоздатьОбъект("БуферОбмена");
стрНомера = оКлипборд.Получить();

дальше уж дело техники
   Franchiser
 
24 - 11.05.18 - 11:12
(22), (23) круто, а можно ли встать на список значений на форме и вставить значения из буфера?
   Franchiser
 
25 - 11.05.18 - 11:20
+(24) используя контекстное меню по правой кнопке?
   Franchiser
 
26 - 11.05.18 - 13:04
(23) сделал, через "БуферОбмена" )
   Злопчинский
 
27 - 11.05.18 - 13:17
(23) спсб за подсказку.
   Franchiser
 
28 - 11.05.18 - 13:28
оКлипборд = СоздатьОбъект("БуферОбмена");
            стрКодыМХ = оКлипборд.Получить();
            
            
            
            стрКодыМХ = СтрЗаменить(
            СтрЗаменить(стрКодыМХ,Симв(10),","),
            Симв(13),"");
            
            
            
            стрКодыМХ = СтрЗаменить(
            стрКодыМХ,
            ",",""",""");
            
            
            стрКодыМХ = """" + стрКодыМХ;
            
            
            стрКодыМХ = стрКодыМХ+"""";
            
            
            
            СпКодов = СоздатьОбъект("СписокЗначений");
            СпКодов.ИзСтрокиСРазделителями(стрКодыМХ);
            
            
            СпрМестаХранения = СоздатьОбъект("Справочник.МестаХранения");
            
            
            СписокМХИмпорта = СоздатьОбъект("СписокЗначений");
            
            
            
            Для Сч = 1 По СпКодов.РазмерСписка() Цикл
                КодСклада = СокрЛП(СпКодов.ПолучитьЗначение(Сч));
                
                Если КодСклада <>"" Тогда
                    
                    Если  СпрМестаХранения.НайтиПоКоду(КодСклада) = 1 Тогда
                        СписокМХИмпорта.ДобавитьЗначение(СпрМестаХранения.ТекущийЭлемент(), КодСклада);    
                    КонецЕсли;
                    
                    
                КонецЕсли;
                
            КонецЦикла;
            
            СписокМХИмпорта.Выгрузить(ВыбМХ);
   Злопчинский
 
29 - 11.05.18 - 13:41
тоже [U]впендюрил[/U] внедрил в загрузку
https://www.screencast.com/t/1fzPSU7F4y4f


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует