Вход | Регистрация

  1  2   
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Из ПКО идет печать чека с НДС 18%, в документе стоит без НДС

v7: Из ПКО идет печать чека с НДС 18%, в документе стоит без НДС
Я
   falselight
 
08.05.18 - 07:34
1с 7.7, Комплексная конфигурация.
Из ПКО идет печать чека с НДС 18%, в документе стоит без НДС.
Как установить что бы печать соответствовала тому что установленно
в документе?
 
 
   falselight
 
1 - 08.05.18 - 07:37
В 1с такого макета чека нет, то есть он печатается 
фискальным регистратором. Печать происходит по нажатию
кнопки Чек в документе ПКО. Почему в чеке идет НДС 18%,
когда нужно что бы было без НДС. Как установленно в документе?
   M-Mad
 
2 - 08.05.18 - 07:41
Смотри значение пользователя по умолчанию в ставке НДС.
   falselight
 
3 - 08.05.18 - 07:52
По кнопке чек, не вот эта ли строка отвечает за ставку НДС?


Список.НДС        = глНачисляемыйНДС(?(СтавкаНДС.Выбран() = 1, СтавкаНДС, глЗначениеПоУмолчанию("ОсновнаяСтавкаНДС")))*100;
   falselight
 
4 - 08.05.18 - 07:53
(2) А значение какого пользователя? Текущего? Кто нажимает на кнопку чек?
   МимохожийОднако
 
5 - 08.05.18 - 07:54
(3) Отладчик до этого места доходит?
   falselight
 
6 - 08.05.18 - 07:59
(5) Пробую, выявить документ на котором проверить, пока не доходил.
   falselight
 
7 - 08.05.18 - 08:04
(5) Сейчас прошел, но там возвратилось 0
   МимохожийОднако
 
8 - 08.05.18 - 08:04
(6) Значит не там ищешь. Поставь точку останова на момент пробития чека и помаленьку доберись до кода.
Проверь настройки кассы через родной драйвер кассы (не из 1С) там есть таблица с налогами
   M-Mad
 
9 - 08.05.18 - 08:10
(4) Который на кнопку жмет
   falselight
 
10 - 08.05.18 - 08:18
Смотрю процедуру ПечатьЧека()

(9) Сегодня я жму, так как проверяю, отлавливаю. Счас дойду посмотрю. Это в настройках пользователя?
 
 Рекламное место пустует
   M-Mad
 
11 - 08.05.18 - 08:19
(10) Да.
   falselight
 
12 - 08.05.18 - 08:21
Проходя вот это выбирает 4, то есть без ндс, как я вижу.
            Если НДСЕсть = 1 Тогд//Печатаем НДС

                
                // В настройках ФР надо настроить ставки:

                // Налог 1 = 18% - НДС 18%

                // Налог 2 = 10% - НДС 10%

                // Налог 3 = 20% - НДС 20%

                // Налог 4 =  0% - без НДС

                // и Тип налога = 2 (Налог на каждую продажу)

        
                Если СписокТоваров.НДС = 18 Тогда
                    Объект.Department = 1;
                ИначеЕсли СписокТоваров.НДС = 10 Тогда
                    Объект.Department = 2;
                ИначеЕсли СписокТоваров.НДС = 20 Тогда
                    Объект.Department = 3;
                Иначе
                    Объект.Department = 4;
                КонецЕсли;
            Иначе
                Объект.Department = 4;
            КонецЕсли;
   falselight
 
13 - 08.05.18 - 08:29
(11) Так берется же из документа?
Я посомтрел по коду берется без ндс, а печатается с НДС 18%. Почему? Что поправить?
   Масянька
 
14 - 08.05.18 - 08:31
(12) СписокТоваров - где в ПКО?
   hhhh
 
15 - 08.05.18 - 08:33
(13) посмотри в налоговой как зарегистрировано. Может там общая система с ндс.
   falselight
 
16 - 08.05.18 - 08:34
(14) К нему привязанно счет фактура, может быть в ней?
Как это в ПКО список товаров?

(15) А где это посмотреть?
   Tatitutu
 
17 - 08.05.18 - 08:35
   Масянька
 
18 - 08.05.18 - 08:39
(16) Чек печатается потоварно (так реализовано в стандарте).
Поэтому, для ПКО нужно допиливать...
Помой руки, возьми напильник и вперед.
   falselight
 
19 - 08.05.18 - 08:50
(18) Знать бы как, посоветуйте?!!!!
   falselight
 
20 - 08.05.18 - 08:52
(17) Посмотрел в картинках, да я это видел в параметрах
То есть нужно сделать так как на картинках?
   Масянька
 
21 - 08.05.18 - 08:53
(19)
//******************************************************************************

Процедура СделатьЧек()
    
    // расшифрока номенклатуры - из документа-основания

    мДокРасшифр = ДокОснование.ТекущийДокумент();
    
    // вводим новый чек 

    ДокЧек = СоздатьОбъект("Документ.ЧекККМ");
    
    ДокЧек.Новый();
    ДокЧек.Склад    = глПользователь.ОсновнойСклад;
    ДокЧек.Касса     = Константа.КассаККМ;
    ДокЧек.Валюта     = Валюта;
    ДокЧек.Получено = Сумма;
    ДокЧек.ВидОперации     = Перечисление.ВидыОперацийЧекККМ.ЧекПКО;
    ДокЧек.ДокОснование = ТекущийДокумент();
    ДокЧек.СуммаВклНДС     = ДокОснование.СуммаВклНДС;
    ДокЧек.УчитыватьНДС = ДокОснование.УчитыватьНДС;
    ДокЧек.ТипЦен     = ДокОснование.ТипЦен;
    ДокЧек.Фирма     = Фирма;
    ДокЧек.ЮрЛицо     = Фирма.ЮрЛицо;
    ДокЧек.Автор    = глПользователь;

    // таб. часть - если есть контроль, то номенклатуру берем из него

    Если (ДокОснование.Контроль = 1) Тогда
        мДокРасшифр = ДокОснование.ХранилищеРеализация.ТекущийДокумент();
    Иначе
        мДокРасшифр = ДокОснование.ТекущийДокумент();
    КонецЕсли;    
    
    мДокРасшифр.ВыбратьСтроки();
    Пока мДокРасшифр.ПолучитьСтроку() = 1 Цикл
        ДокЧек.НоваяСтрока();
        ДокЧек.Номенклатура    = мДокРасшифр.Номенклатура;
        ДокЧек.Количество     = мДокРасшифр.Количество;
        ДокЧек.Единица         = мДокРасшифр.Единица;
        ДокЧек.Коэффициент     = мДокРасшифр.Коэффициент;
        ДокЧек.Цена         = мДокРасшифр.Цена;
        ДокЧек.Сумма         = мДокРасшифр.Сумма;
        ДокЧек.СтавкаНДС     = мДокРасшифр.СтавкаНДС;
        ДокЧек.СуммаНДС     = мДокРасшифр.СуммаНДС;
    КонецЦикла;

    ДокЧек.Записать();
    ДокЧек.Провести();

    // печатаем новый чек

    Конт = 0;
    ОткрытьФорму(ДокЧек.ТекущийДокумент(), Конт);
    Конт.ПробитьЧекНаККМ();
    Конт.Форма.Закрыть();

КонецПроцедуры// ВвестиЧек


//******************************************************************************

Процедура ПоКнопкеПечатьКассовый()
    
    Ответ = Вопрос("Печатать кассовый чек?", "Да+Нет+Отмена", 60);
    Если (Ответ = "Да") Тогда
        СделатьЧек();
    Иначе        
        СтатусВозврата(0);
        Возврат;
    КонецЕсли;

КонецПроцедуры// ПоКнопкеПечатьКассовый
   falselight
 
22 - 08.05.18 - 08:59
(21) Тут нужно изучать только сколько что это у вас, печать чека. Но а то что в конфигурации что выкинуть?

Совет из (17) вот нужно применять или как?
   Lexey_
 
23 - 08.05.18 - 09:01
"изучать только сколько что это у вас, печать чека"
нужен переводчик с ливингстарского
   Масянька
 
24 - 08.05.18 - 09:06
(22) Ну, извини... Я программистом работаю, а не копирайтером.
   falselight
 
25 - 08.05.18 - 09:06
(17) В этой базе вообще вот так.

https://cloud.mail.ru/public/35ux/uZ2wh71XQ
   falselight
 
26 - 08.05.18 - 09:12
(24) Я очень уважительно к вам отношусь.
Но при чем тут ЧекККМ?
То где печатается НДС 18% и нужно БезНДС,
это чек из фискального регистратора, для него нет макетов в 1с.
Я возможно не все сразу схватываю, извиняюсь ещё раз.

Но вот эту настройку (25) Нужно привести как показано на рисунке в (17) ?
   falselight
 
27 - 08.05.18 - 09:19
Они там везде 6 поставили так как без ндс везде
   Масянька
 
28 - 08.05.18 - 09:22
(26) "Я очень уважительно к вам отношусь." - извини еще раз, но не могу сказать так же.
При чем тут макет?
Ты так и не внял советам "разбираться с матчастью"...
   falselight
 
29 - 08.05.18 - 09:28
(11) Этот совет не помогает.
   falselight
 
30 - 08.05.18 - 09:31
Сработает ли если в (25) везде поставить 4 за место 6 ?







            Если НДСЕсть = 1 Тогд//Печатаем НДС

                
                // В настройках ФР надо настроить ставки:

                // Налог 1 = 18% - НДС 18%

                // Налог 2 = 10% - НДС 10%

                // Налог 3 = 20% - НДС 20%

                // Налог 4 =  0% - без НДС

                // и Тип налога = 2 (Налог на каждую продажу)

        
                Если СписокТоваров.НДС = 18 Тогда
                    Объект.Department = 1;
                ИначеЕсли СписокТоваров.НДС = 10 Тогда
                    Объект.Department = 2;
                ИначеЕсли СписокТоваров.НДС = 20 Тогда
                    Объект.Department = 3;
                Иначе
                    Объект.Department = 4;
   Builder
 
31 - 08.05.18 - 09:40
(0) Ты хоть модель ККМ озвучил бы, хотя по скриншоту видно что это АТОЛ.
И обработку через которую печатаешь чек. И систему налогов. И как это все связано.
   falselight
 
32 - 08.05.18 - 09:52
(31) Обработка печати FR_COMM.ert судя по всему.
Модель да АТОЛ наверное.
Система налогов ЕНВД.
На документе выбирается без НДС, что передается по коду как
Объект.Department = 4; в (12). Но на чеке идет НДС 18%
   falselight
 
33 - 08.05.18 - 09:54
(32+) Модель АТОЛ ЭОФ
связь через порт COM3
 
 
   falselight
 
34 - 08.05.18 - 09:59
Что не менял всегда печатает НДС 18%, так что чт оправить не знаю? Нужно что бы всегда было Без НДС и все.
   falselight
 
35 - 08.05.18 - 10:04
(24) Мне нужно просто на чеке вывести БезНДС и все больше ничего.
   falselight
 
36 - 08.05.18 - 10:30
пользуется кто АТОЛ? как сделать без ндс в чеке?
   hhhh
 
37 - 08.05.18 - 11:06
(35) разберись со списокТоваров, что у тебя там? и реально там стоит СуммаНДС = 0 ??
   Builder
 
38 - 08.05.18 - 12:42
(32) Обработка точно FR_COMM.ert?

// Применяемая система налогообложения в чеке:ОСН - 1;УСН доход - 2;УСН доход-расход - 4;ЕНВД - 8;ЕСН - 16;ПСН - 32;


Объект.AttrNumber=1055;
Объект.AttrValue=СистемаНалогообложения;
Объект.WriteAttribute();
   falselight
 
39 - 08.05.18 - 13:26
Можно ли использовать какой либо эмулятор для предварительного просмотра чека????? Что бы не отправлять его а просматривать что там выходит?
   alxxsssar
 
40 - 08.05.18 - 13:33
а нет ли какой константы типа основная ставка ндс? или в настройках организации что-то стоять. Плохо помню семерку комплексную
   falselight
 
41 - 08.05.18 - 13:49
(40) не тут все по коду идет без НДС!!!!!
как в (12) идет значение 4 то есть без ндс и ндс 0
но вот на чеке НДС 18 % постоянно, где это поменять не пойму
   falselight
 
42 - 08.05.18 - 13:50
Знать бы где, раз и сменить.
   alxxsssar
 
43 - 08.05.18 - 14:26
(41) тогда реально рой что такое списоктоваров и откуда он формируется при печати. ПКО связан с расходным документом. Смотри в нем что стоит или в самой номенклатуре.
   alxxsssar
 
44 - 08.05.18 - 14:29
если в (19) твой код, смотри отладчиком что стоит в докосновании
   falselight
 
45 - 08.05.18 - 14:41
(44) В (19) нет кода.

В ПКО стоит Без НДС.

Список формируется вот как, и далее передается в функцию,
где идет уже как список товаров.


    Список = СоздатьОбъект("ТаблицаЗначений");
    Список.НоваяКолонка("ТовНаим"   , "Строка");
    Список.НоваяКолонка("Цена"      , "Число");
    Список.НоваяКолонка("Количество", "Число");
    Список.НоваяКолонка("НДС"       , "Число");
    
    Список.НоваяСтрока();
    Список.ТовНаим    = ?(ПустаяСтрока(ПринятоОт)=0,"Принято от ","")+СокрЛП(СокрЛП(ПринятоОт)+" "+СокрЛП(Основание));
    Список.Цена       = Сумма;
    Список.Количество = 1;
    Список.НДС        = глНачисляемыйНДС(?(СтавкаНДС.Выбран() = 1, СтавкаНДС, глЗначениеПоУмолчанию("ОсновнаяСтавкаНДС")))*100;
    
    СуммаЧека         = Сумма;
    Получено          = Сумма;
    Скидка            = 0;
    ПризнВозврата     = 0;
    НомерСекции       = 1;
    НомерЧека         = 0;
    
    Если глФРПечататьЧек(Список, СуммаЧека, Получено, Скидка, ПризнВозврата, НомерСекции, НомерЧека) = 1 Тогда
   falselight
 
46 - 08.05.18 - 14:44
Объект        = Парам.Получить("Объект");
            Пароль        = Парам.Получить("ПарольПользователя");
            СписокТоваров = Парам.Получить("СписокТоваров");
            СуммаЧека     = Парам.Получить("СуммаЧека");
            Получено      = Парам.Получить("Получено");
            ЧекНаВозврат  = Парам.Получить("Возврат");
            НомерСекции   = Парам.Получить("НомерСекции");
            Скидка        = Парам.Получить("Скидка");
            ДлинаСтроки   = Парам.Получить("ДлинаСтроки");
            
            ОписаниеРезультата = ПроверкаПароля (Пароль);
            Если ОписаниеРезультата <> "" Тогда                
                Рез = 0;
            Иначе
                Рез = ПечататьЧек(Объект, Пароль, СписокТоваров, СуммаЧека, Получено, Скидка, ЧекНаВозврат, НомерСекции, НомерЧека, ДлинаСтроки);
            КонецЕсли;
   alxxsssar
 
47 - 08.05.18 - 14:47
глНачисляемыйНДС - ??? Лезь в глобальный модуль, смотри что кажет эта функция
   falselight
 
48 - 08.05.18 - 14:48
Ещё раз. НДС точно 0. По этому Объект.Department = 4
Что это Объект.Department ? Если НДС 0 оно равно 4
что это дает???? В чеке идет все равно НДС 18 %



        Если ПризнВозврата = 0 Тогда            
            
            Если НДСЕсть = 1 Тогд//Печатаем НДС

                
                // В настройках ФР надо настроить ставки:

                // Налог 1 = 18% - НДС 18%

                // Налог 2 = 10% - НДС 10%

                // Налог 3 = 20% - НДС 20%

                // Налог 4 =  0% - без НДС

                // и Тип налога = 2 (Налог на каждую продажу)

        
                Если СписокТоваров.НДС = 18 Тогда
                    Объект.Department = 1;
                ИначеЕсли СписокТоваров.НДС = 10 Тогда
                    Объект.Department = 2;
                ИначеЕсли СписокТоваров.НДС = 20 Тогда
                    Объект.Department = 3;
                Иначе
                    Объект.Department = 4;
                КонецЕсли;
            Иначе
                Объект.Department = 4;
            КонецЕсли;
                
            Объект.Регистрация();
        Иначе
            Объект.Возврат();
        КонецЕсли;
   falselight
 
49 - 08.05.18 - 14:50
(47) А что там смотреть? Она возвращает 0, что и нужно.
Суть в том что после всего вот этого в чеке печатается НДС 18 % !



//  глНачисляемыйНДС(Ставка)

// 
// Параметры: 

//     Ставка - значение типа "Перечисление.СтавкиНДС".
//

// Возвращаемое значение: 
//  Числовой коэффициент НДС.

//
// Описание:

//     По ставке НДС (Перечисление) получаем числовой коэффициент НДС, на который
//  необходимо умножить число при начислении НДС сверху для получения суммы НДС.

//  
Функция глНачисляемыйНДС(Ставка) Экспорт
    Если ПустоеЗначение(Ставка)=1 Тогда
        Возврат 0;
    ИначеЕсли(Ставка=Перечисление.СтавкиНДС.БезНДС) Тогда
        Возврат 0;
    ИначеЕсли (Ставка=Перечисление.СтавкиНДС.НДС10) Тогда
        Возврат 0.1;
    ИначеЕсли (Ставка=Перечисление.СтавкиНДС.НДС20) Тогда
        Возврат 0.2;
    ИначеЕсли (Ставка=Перечисление.СтавкиНДС.НДС18) Тогда
        Возврат 0.18;
    ИначеЕсли (Ставка=Перечисление.СтавкиНДС.НДС9_09) Тогда
        Возврат 0.09998900010999890001099989000// Это 0.0909/0.9091;

    ИначеЕсли (Ставка=Перечисление.СтавкиНДС.НДС16_67) Тогда
        Возврат 0.20004800192007680307212288492// Это 0.1667/0.8333, только более точно в последнем знаке;

    Иначе
        Сообщить("Функция глНачисляемыйНДС(Ставка): неверная ставка");
        Возврат 0;
    КонецЕсли;
КонецФункции//глНачисляемыйНДС()
 
 Рекламное место пустует
   falselight
 
50 - 08.05.18 - 14:50
Объект = НеизвестныйОбъект

вот это что такое????
   Builder
 
51 - 08.05.18 - 14:58
Ну сколько можно уже...
1. Идешь в драйвер, смотришь таблицу налогов.
2. В таблице отделов присваиваешь отделам нужные налоги.
3. Есть еще система налогообложения - она присваивается так:
Объект.AttrNumber=1055;
Объект.AttrValue=СистемаНалогообложения;
Объект.WriteAttribute();
// Применяемая система налогообложения в чеке:ОСН - 1;УСН доход - 2;УСН доход-расход - 4;ЕНВД - 8;ЕСН - 16;ПСН - 32;

4. Объект.Department - присваивается в цикле по ТОВАРАМ.
   falselight
 
52 - 08.05.18 - 14:58
Подскажите пожалуйста как посмотреть глФР
Думаю в нем задается НДС, и как можно увидеть через него только



Функция глФРПечататьЧек(СписокТоваров, СуммаЧека, Получено, Скидка, ПризнВозврата, НомерСекции, НомерЧека)  Экспорт
    
    Рез = 0;
    
    Если глФРВкл = 1 Тогда
        Параметры = СоздатьОбъект("СписокЗначений");
        Параметры.Установить("Процесс"           , "печатать_чек");
        Параметры.Установить("Объект"            , глФР);
        Параметры.Установить("ПарольПользователя", глФРПарольПользователя);
        Параметры.Установить("СписокТоваров"     , СписокТоваров);
        Параметры.Установить("СуммаЧека"         , СуммаЧека);
        Параметры.Установить("Получено"          , Получено);
        Параметры.Установить("Скидка"            , Скидка);
        Параметры.Установить("Возврат"           , ПризнВозврата);
        Параметры.Установить("НомерСекции"       , НомерСекции);
        Параметры.Установить("ПриемНаличныхОтЮрЛиц", глФРДляПриемаНаличныхОтЮрЛиц);
        
        РезТекст = глОборудованиеКоманда("ФР", глФРОбработка, Параметры);
        Если ПустоеЗначение(РезТекст) = 0 Тогда
            Сообщить(РезТекст);
        Иначе
            Если Параметры.Получить("Результат") = 0 Тогда
                Сообщить("Фискальный регистратор: ошибка при печати чека");
                Сообщить(Параметры.Получить("ОписаниеРезультата"));
            Иначе
                НомерЧека = Параметры.Получить("НомерЧека");
                Рез = 1;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
    
    Возврат Рез;
    
КонецФункции// глФРПечататьЧек()
   falselight
 
53 - 08.05.18 - 15:01
(51) Да сколько. Сделать то как нужно илди как то иначе не получилось ни разу.
   alxxsssar
 
54 - 08.05.18 - 15:01
(49) если только 0 то тогда в драйвер ККМ тебе дорога
   falselight
 
55 - 08.05.18 - 15:03
(54) То есть нужно смотреть не код, а настройки драйвера ККМ в сервис-параметры ?
   Builder
 
56 - 08.05.18 - 15:04
(53) Ну сделай уже все из (51) как нужно.
   falselight
 
57 - 08.05.18 - 15:05
(56) Я же пробовал. Заходил туда менял.
Что бы что то понять что что то печатается иначе.
Но печатается все одно и тоже.
Могу привести эти настройки на снимках.
   falselight
 
58 - 08.05.18 - 15:06
Сервис-Параметрв-Свойства-Параметры оборудования

Первая таблица Налоги
   falselight
 
59 - 08.05.18 - 15:07
Наименование налога 6 - без НДС - ставка 0 - тег 1105
Наименование налога 1 - НДС 18% - ставка 18 - тег 1102
   falselight
 
60 - 08.05.18 - 15:09
таблица секции

Наименование - секции с 1 по 16 - налог - везде стоит значение 6

6 это же без НДС ??????
   alxxsssar
 
61 - 08.05.18 - 15:10
так у тебя в (48) с нулем возвращается 4 а не 6. Пробовал поменять и не получилось или не пробовал?
   falselight
 
62 - 08.05.18 - 15:12
(61) То есть тут значение поставить везде не 6 а 4 ????
Так как нужно сделать что бы было только без ндс.


Наименование - секции с 1 по 16 - налог - везде стоит значение 6
   falselight
 
63 - 08.05.18 - 15:14
(51) Поставил везде 4 применил. Послал на печать.
Достаточно ли изменить и применить?
Может что то ещё нужно делать?
   falselight
 
64 - 08.05.18 - 15:15
Поставил везде 4 применил, из документа отправил на печать
так же пишет НДС 18%/
   falselight
 
65 - 08.05.18 - 15:16
Достаточно ли просто применить в настройках? Может что ещё нужно делать?

(56) Видите я делаю все как нужно, даже одну и туже цифру проставляю во все секции, но ничего не меняется ((((((
   falselight
 
66 - 08.05.18 - 15:17
может не в 1с эти настройки где то заданы?????\
   falselight
 
67 - 08.05.18 - 15:21
модель регистратора ФРЕГАИС Атол.
Я же меняю настройки через сервис параметры, почему ФР их не усваивает.
Может его нужно перегрузить?

Как задать то без НДС ?
   falselight
 
68 - 08.05.18 - 15:26
В коде можно отловить этот момент, когда идет на печать чек???? Как объект, как его посмотреть, что бы программно принудительно задать????????


Пишет Объект = НеизвестныйОбъект

Как посмотреть, задать его свойства программно?
Можно ли это, на настройки через параметры не реагирует
   kda26
 
69 - 08.05.18 - 15:27
(67) Версия ФФД 1.05?
   falselight
 
70 - 08.05.18 - 15:29
(69) что такое ФФД подскажите пожалуйста
   falselight
 
71 - 08.05.18 - 15:31
(69)

Тест драйвера ККМ:                        8.12.0.0

Сведения о драйвере:
Вариант:                               Бесплатный
Драйвер:                                  8.12.0.0
Сервисный модуль:                         8.12.0.0
   kda26
 
72 - 08.05.18 - 15:31
(70) Формат фискальных данных. Ранее был ФФД 1.0 теперь ставят при перепрошивке ФФД1.05, у него более широкий набор тегов и изменены ставки НДС.
   kda26
 
73 - 08.05.18 - 15:33
(72) 8.12 устарел сейчас пользуют дрова Атол 8.15.1 минимум.
   kda26
 
74 - 08.05.18 - 15:33
(73) Сорри 8.16.1
   falselight
 
75 - 08.05.18 - 15:34
(74) ну работать то должен.
Ставку выдавать какую нужно. Управлять им можно думаю.
Но как? Как задать что бы всегда печатал на чеке без ндс ?
   kda26
 
76 - 08.05.18 - 15:35
   falselight
 
77 - 08.05.18 - 15:38
(76) А как этим предметно воспользоваться не известно?

Я же менял все....
   Builder
 
78 - 08.05.18 - 15:39
(77) С такими вопросами позовите все таки специалиста.
   falselight
 
79 - 08.05.18 - 15:39
(78) Говорите задавай все как нужно и все, ну так я задаю ничего не меняется же.
   kda26
 
80 - 08.05.18 - 15:42
Неделю назад в ЦТО нам перепрошивали ККМ Атол 55Ф и устанавливали ФН с ФФД 1.05, до этого был ФФд1.0, сказали установить дрова 8.16.1, но у нас ОСН и все взлетело норм, а для УСН порядок ставок НДС в ФФД 1.05 изменен.
   falselight
 
81 - 08.05.18 - 15:43
(80) Мне важно понять как задать принудительно????????
То что нужно, где?
   Масянька
 
82 - 08.05.18 - 16:06
(81) В (30) перед строчкой         Если НДСЕсть = 1 Тогд//Печатаем НДС

вставь строку:
сообщить("" + НДСЕсть); - что выведет?
   Builder
 
83 - 08.05.18 - 16:13
(82) Забей, ТС не хочет разбираться, ему просто задать принудительно :)
   falselight
 
84 - 08.05.18 - 16:15
(82) Сейчас там драйвера обновляют. Не посмотреть.
Но дело в том что я это излазил все. Там все нормлаьно.

Выведет 0 наверное и     Иначе
                    Объект.Department = 4;

Там нормально все.

Я вот только что где не менял, на чеке печатается НДС 18% все равно. Такое ощущение что не реагирует на настройки вообще.

Я вот и спрашивал, Объект, это этот чек? Можно как то посмотреть что он выведет? Должна же быть информация как это решить.
   falselight
 
85 - 08.05.18 - 16:16
(83) Как это не хочу разбираться.
Уже озадачили людей обновлять драйвера.
Я теперь только и буду этим разбираться пока не сделаю!!!!
   kda26
 
86 - 08.05.18 - 16:21
// Если ФФД1.05, то в функции  

//  ПолучитьXMLПакетДляФискализацияЧека, так в УТ10.3

Если НЕ ПустаяСтрока(ТекущаяПозиция.СтавкаНДС) Тогда 
                        Если ТекущаяПозиция.СтавкаНДС = 118 Тогда
                            ЗначениеСтавкаНДС = "18/118";
                        ИначеЕсли ТекущаяПозиция.СтавкаНДС = 110 Тогда
                            ЗначениеСтавкаНДС = "10/110";
                        Иначе
                            ЗначениеСтавкаНДС = ТекущаяПозиция.СтавкаНДС;
                        КонецЕсли;
                    Иначе
                        ЗначениеСтавкаНДС = "none";
                    КонецЕсли;
                    
                    ЗаписьXML.ЗаписатьАтрибут("Tax", XMLСтрока(ЗначениеСтавкаНДС));
   hhhh
 
87 - 08.05.18 - 16:26
(85) ну 16й драйвер поставил?
   ugorchina
 
88 - 08.05.18 - 16:31
(82) точку останова поставьте посмотрите что там? Дали бы доступ уже давно вам бы сделал все
   Масянька
 
89 - 08.05.18 - 16:33
(84) "Наверное" и "вывело" - разные сущности. Не находишь?
   ugorchina
 
90 - 08.05.18 - 16:34
(84) выведет 0 наверно? Или точно?
   Масянька
 
91 - 08.05.18 - 16:36
(83) Комсомолец думаешь?
   Builder
 
92 - 08.05.18 - 16:51
(86) Не катит, у тс работа напрямую с драйвером, без XML-прокладки от 1с.
   ugorchina
 
93 - 08.05.18 - 16:52
Если ТС и дальше будет отвечать подобно (84) то мы вряд ли ему поможем
   falselight
 
94 - 08.05.18 - 16:53
(86) Не, это сказки. Я искал более углубленный код, как свойства объекта например.

Говорят все решилось после переустановки, установки драйверов, стало печатать как нужно. Ставка НДС 0%.
   ugorchina
 
95 - 08.05.18 - 16:56
Поздровляю
   Масянька
 
96 - 08.05.18 - 16:59
Жаль... До сотки не дотянули...
   piter3
 
97 - 08.05.18 - 17:00
0 не равно без ндс
   Масянька
 
98 - 08.05.18 - 17:00
(97) Точно!
Продолжаем...
   falselight
 
99 - 08.05.18 - 17:16
(97) Но мне сказали что все нормально.
Ну а если там нужно печатать именно "Без НДС", то я
налазился там сегодня. Могу и продолжить.
После обновления драйверов пока ещё не смотрел как там да
что реагирует. Я так понимаю что меняться эта надпись 
должна, либо при задания разных значений тут

Объект.Department = 4;

Либо при задании разных значений в таблицах настройки
драйвера фискального регистратора. Чем следовало бы 
поиграться и увидеть изменения.
   piter3
 
100 - 08.05.18 - 17:18
(99) А нам все равно))))
Ну вот дотянули до сотни
  1  2   

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует