Вход | Регистрация


Не показываются опции синхронизации в БП 3.0

Не показываются опции синхронизации в БП 3.0
Я
   falselight
 
07.05.18 - 14:47
При установке галки "синхронизация данных" выдает ошибку, -

Не удалось записать: "Покупателями исполняются обязанности налогового агента по НДС"!

И опции самого обмена что должны появляться после не активны.
Не подскажете что это за ошибка и как её устранить?
 
 
   falselight
 
1 - 07.05.18 - 14:47
{Обработка.ПанельАдминистрированияБСП.Форма.СинхронизацияДанных.Форма(361)}: Ошибка при вызове метода контекста (Установить)
            КонстантаМенеджер.Установить(КонстантаЗначение);
по причине:
Ошибка при выполнении обработчика - 'ПриЗаписи'
по причине:
{Обработка.ФункциональностьПрограммы.МодульМенеджера(2862)}: Ошибка при вызове метода контекста (Записать)
        НаборКонстант.Записать();
по причине:
Не удалось записать: "Покупателями исполняются обязанности налогового агента по НДС"!
   falselight
 
2 - 07.05.18 - 14:51
Ошибка возникает при установке галки, вот в этой процедуре, на НаборКонстант.Записать();




// При установке флага Синхронизация Данных, включаем зависимые функциональные возможности

Процедура УстановитьКонстантыЗависимыеОтОбменов() Экспорт
    
    Если Константы.ИспользоватьСинхронизациюДанных.Получить() Тогда
        
        МассивИменКонстант = МассивИменКонстантФункциональностиДляОбменов();
        СтрокаИменКонстант = СтрСоединить(МассивИменКонстант, ",");
        
        НаборКонстант = Константы.СоздатьНабор(СтрокаИменКонстант);
        НаборКонстант.Прочитать();
        Для Каждого ИмяКонстанты Из МассивИменКонстант Цикл
            НаборКонстант[ИмяКонстанты] = Истина;
        КонецЦикла;
        НаборКонстант.Записать();
        
    КонецЕсли;
    
КонецПроцедуры
   lodger
 
3 - 07.05.18 - 14:53
   falselight
 
4 - 07.05.18 - 14:57
(3) BP_3.0.60.46 такой подойдет?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует