Вход | Регистрация


Как в УФ СКД по независимому Рег.сведений сделать расшифровку ?

Как в УФ СКД по независимому Рег.сведений сделать расшифровку ?
Я
   budnik
 
03.05.18 - 10:14
Как в правляемом интерфейсе в отчете СКД по независимому регистру сведений сделать расшифровку ?
 
 
   los_hooliganos
 
1 - 03.05.18 - 12:32
(0) Опишите задачу конкретнее.
По умолчанию расшифровка равна значению в ячейке.
Если вы хотите что-то другое, то используйте расшифровку через создание на закладке Макет ячейки нужного поля и свойствах пропишите нужное значение расшифровки.
   budnik
 
2 - 03.05.18 - 13:39
(1)
Есть независимый регистр сведений .
Строим отчет СКД по всем измерениям и ресурсам .
Как с расшифровки отчета открыть запись регистра сведений для редактирования .
   Mankubus
 
3 - 03.05.18 - 15:26
(2) вопрос как это сделать в расшифровке или как открыть форму регистра?
   budnik
 
4 - 03.05.18 - 15:50
(3) нет регистратора , независимый он .
   budnik
 
5 - 03.05.18 - 15:54
(4) не то написал  .
не понятно что и как передать в расшифровку , ссылки нету , как например у документа или справочника.
   los_hooliganos
 
6 - 04.05.18 - 06:01
(5) В таком случае надо писать свою ОбработкаРасшифровки для табличного документа.
   los_hooliganos
 
7 - 04.05.18 - 06:16
Вот пример с ИТС переделанной обработки расшифровки.
Процедура РезультатОбработкаРасшифровки приязана к событию ОбработкаРасшифровки табличного документа.
Вам нужно написать свою функцию ОткрытьЗначение(ПараметрыВыбранногоДействия) с открытием формы регистра сведений

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
 
  Перем ВыбранноеДействие;
  Перем ПараметрыВыбранногоДействия;
 
  СтандартнаяОбработка = Ложь;
  ОбработкаРасшифровки =  Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных(Отчет));
 
  ОбработкаРасшифровки.ВыбратьДействие(Расшифровка, ВыбранноеДействие, ПараметрыВыбранногоДействия);
 
  Если ВыбранноеДействие <> ДействиеОбработкиРасшифровкиКомпоновкиДанных.Нет Тогда
    Если ВыбранноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда
      ОткрытьЗначение(ПараметрыВыбранногоДействия);
    Иначе
      Парам = Новый Структура;
      Парам.Вставить("СформироватьПриОткрытии", Истина);
      Парам.Вставить("Расшифровка", Новый ОписаниеОбработкиРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, Расшифровка, ПараметрыВыбранногоДействия));
      ОткрытьФорму("Отчет.РаботаСРасшифровкой.Форма", Парам, , Истина);
    КонецЕсли;
  КонецЕсли;
 
КонецПроцедуры
   Mankubus
 
8 - 04.05.18 - 06:27
(5) передавай все значения измерений и ресурсов и открывай форму записи регистра с уже заполненными значениями

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует