Вход | Регистрация



Как проще всего ТаблицуЗначений выгрузить в текстовый файл с разделителями

Как проще всего ТаблицуЗначений выгрузить в текстовый файл с разделителями
Я
   Вася Теркин
 
03.05.18 - 08:44
Типа у кого получится лучше всех. В экселе есть такая стандартная функция.
Разделитель - точка с запятой. Выгружать колонки по стандартному представлению 1С в той же последовательности.
Могут быть любые данные.
 
 
   Вася Теркин
 
1 - 03.05.18 - 08:45
Процедура ВыгрузитьВТекстовыйФайлСРазделителями(Таблица)
....
....
КонецПроцедуры
   ShAV
 
2 - 03.05.18 - 08:48
(1) ахах +100
   mehfk
 
3 - 03.05.18 - 08:50
(0) Как говорят математики: "Приведем задачу к задаче, решение которой нам известно...".
   Вася Теркин
 
4 - 03.05.18 - 09:10
Есть шанс попасть в книгу знаний...
   hhhh
 
5 - 03.05.18 - 09:24
(4) уже всё придумано до нас:

ЗначениеВСтрокуXML(ТЗ)

есть в любой типовой, пользуйся.
   Вася Теркин
 
6 - 03.05.18 - 10:44
(5) ??? Теплое от мягкого не отличаешь? Где там текст с разделителями?
   Boleev
 
7 - 03.05.18 - 10:46
Сохранить в Excel, а из него уже csv
   1Сергей
 
8 - 03.05.18 - 10:48
Можно в ТабДок, а там просто
   1Сергей
 
9 - 03.05.18 - 10:50
хотя, в табдок не просто
   Вася Теркин
 
10 - 03.05.18 - 10:52
Двоешники. Вот ответ.

    ТекстДок = Новый ТекстовыйДокумент;
    ТекстДок.ДобавитьСтроку(лев(строка(НачПериода),10)+";"+лев(строка(КонПериода),10));
    Для каждого Стр из ТаблицаЗагрузки Цикл
        Строка = "%%%№";
        Для а  = 0 по ТаблицаЗагрузки.Количество() - 1 Цикл
            Строка =Строка + ";" + Стр[а];
        КонецЦикла;
        Строка = СтрЗаменить(Строка,"%%%№;","");
        ТекстДок.ДобавитьСтроку(Строка);
    КонецЦикла;
    
ТекстДок.Записать(ПутьКФайлу);
 
 Рекламное место пустует
   Вася Теркин
 
11 - 03.05.18 - 10:53
Втроая строка лишняя
   1Сергей
 
12 - 03.05.18 - 10:54
(10) имена колонок не выгрузил
   Вася Теркин
 
13 - 03.05.18 - 10:54
Не нужны
   Вася Теркин
 
14 - 03.05.18 - 10:56
Хотя может можно в этот ваш эксемель зафурычить и там СТРЗаменить... Но он агрегатные данные вытянет не по представлению, а всю структуру... Не катит.
   Вася Теркин
 
15 - 03.05.18 - 10:57
Почему запрос в ТЗ выгрузить можно, а в файл с разделителями нельзя? Это не правильно.
   lEvGl
 
16 - 03.05.18 - 10:57
(10) ппц какое уникальное решение
   1Сергей
 
17 - 03.05.18 - 10:57
(15) можно в файл, но не csv
   Вася Теркин
 
18 - 03.05.18 - 11:00
(16) Уникальное ищется...
   Sammo
 
19 - 03.05.18 - 11:00
(10) Как минимум через записьтекста
   lEvGl
 
20 - 03.05.18 - 11:01
я бы сказал, что гонять туда сюда файлы - не задача, а попытка реализации чего то. это что то и надо решать, почему через файл, в век веб сервисов и прочего, кому сейчас нужны файлы?
   Boleev
 
21 - 03.05.18 - 11:01
(10) вот смешно будет, если название будет содержать разделитель
   Вася Теркин
 
22 - 03.05.18 - 11:02
(20) Есть кому.. И достаточно дорого.
   Вася Теркин
 
23 - 03.05.18 - 11:02
(21) Да, будем заново переделывать за отдельные деньги.
   1Сергей
 
24 - 03.05.18 - 11:03
(18) Зачем уникальное?
   lEvGl
 
25 - 03.05.18 - 11:04
грузи данные напрямую и добавь ценник за универсальность за счет того что мороки с выгрузкой загрузкой файла не будет
   Boleev
 
26 - 03.05.18 - 11:04
(24) чтобы можно было продать за дорого и за отдельные деньги (уникальный прайс) тебе же написали уже.
   Вася Теркин
 
27 - 03.05.18 - 11:05
(25) А на второй стороне программистов уволят? Их там целый отдел...
   Вася Теркин
 
28 - 03.05.18 - 11:05
(24) От скуки.
(26) Не правильный ответ...
   lEvGl
 
29 - 03.05.18 - 11:05
(27) от того твой ценник только растет
   lEvGl
 
30 - 03.05.18 - 11:06
обмен то между какими системами?
   lEvGl
 
31 - 03.05.18 - 11:06
ну что одна - 1с я понял, а приемник?
   МимохожийОднако
 
32 - 03.05.18 - 11:10
"Эх,Вася, Вася..."
   Вася Теркин
 
33 - 03.05.18 - 11:10
(31) Целый отдел приемник пишет. С незапамятных годов...
 
 
   Вася Теркин
 
34 - 03.05.18 - 11:11
(32) Ну чо, всех несовременных под нож? Сразу чуть чего ЕРП расчихлять и мочить всех?
   hhhh
 
35 - 03.05.18 - 11:14
(34) ну выгрузка в csv тоже есть в типовой, если что. Непонятно что ты паришься? пишешь одну строчку вызовы функции общего модуля, получаешь бабло.
   Вася Теркин
 
36 - 03.05.18 - 11:15
Это где такая?
   lEvGl
 
37 - 03.05.18 - 11:16
(35) да он уже свою написал в (10) какая разница. просто если кодом выгружать - это одно, проблем то, но ищется же универсальное решение, xml я так понял потому и был призван
   lEvGl
 
38 - 03.05.18 - 11:17
(33) оч. серьезная система видимо, на файликах, ага
   Вася Теркин
 
39 - 03.05.18 - 11:32
(38) Почти файловая...
   Вася Теркин
 
40 - 03.05.18 - 11:33
(37) Нет. Та система хмл не приемлет, раньше родилась.
   lEvGl
 
41 - 03.05.18 - 11:39
ну озвучь, может тут кто то с ней работал, поможет простое решение найти
   Вася Теркин
 
42 - 03.05.18 - 11:49
Ну да...
   Вася Теркин
 
43 - 03.05.18 - 11:49
простое решение в 10
   lEvGl
 
44 - 03.05.18 - 11:52
(32)
   lEvGl
 
45 - 03.05.18 - 11:52
:)
   d4rkmesa
 
46 - 03.05.18 - 12:37
(0)
ПострПечать = Новый ПостроительОтчета;
ПострПечать.ИсточникДанных = Новый ОписаниеИсточникаДанных(ТаблицаТоваров);
ПострПечать.МакетОформления = ПолучитьМакетОформления(СтандартноеОформление.Интерфейс);     
ПострПечать.Выполнить();
Для каждого Колонка Из ПострПечать.ВыбранныеПоля Цикл
    Колонка.Представление = ТаблицаТоваров.Колонки[Колонка.Имя].Заголовок;
КонецЦикла; 
ПострПечать.Вывести(ДокументРезультат);

ДокументРезультат.Записать(ПолноеИмяФайла, ПараметрыФормата.ТипФайла);

//заменяем разделитель с символа табуляции на ;

ВременныйФайл = Новый ЧтениеТекста(ПолноеИмяФайла);                        
ПолноеИмяФайлаЗаписьCSV = ПолучитьИмяВременногоФайла(".csv");                        
ЗаписьCSV = Новый ЗаписьТекста(ПолноеИмяФайлаЗаписьCSV, КодировкаТекста.ANSI);
ТекРазделитель = Символы.Таб;
ТекСтр = ВременныйФайл.ПрочитатьСтроку();
Пока ТекСтр <> Неопределено Цикл    
    СписокЯчеекСтроки = ИзСтрокиСРазделителями(ТекСтр, ТекРазделитель, Ложь);
    
    ЗаписьCSV.ЗаписатьСтроку(ВСтрокуСРазделителями(СписокЯчеекСтроки, ";", Истина));
    ТекСтр = ВременныйФайл.ПрочитатьСтроку();                            
КонецЦикла;
ВременныйФайл.Закрыть();
ЗаписьCSV.Закрыть();
   Вася Теркин
 
47 - 03.05.18 - 13:58
(46) оТЛИЧНО
   Вася Теркин
 
48 - 03.05.18 - 13:58
В смысле наоборот...


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует