Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Дерево значений скрыть строку

Дерево значений скрыть строку
Я
   inanity1992
 
02.05.18 - 06:29
Здравствуйте! На форме есть реквизит по которому хочу сделать отбор в ДеревеЗначений, для этого добавила колонку "Скрыть" с типом булево. Но никаких изменений не происходит. Что не верно делаю???

&НаСервере
Процедура Отбор  ()
    
    ТЗДеревоПоказаний = РеквизитФормыВЗначение("ДеревоПоказаний", Тип("ДеревоЗначений"));
        
    Для каждого СтрокаДерева Из ТЗДеревоПоказаний.Строки Цикл
        
        Если СтрокаДерева.ЛС= ОтборЛС Тогда
            СтрокаДерева.Скрыть=ложь;
        иначе
            СтрокаДерева.Скрыть=истина;
        КонецЕсли;
        
    КонецЦикла;
    
    УстановитьУсловноеОформление("ДеревоПоказаний.Скрыть", Истина, "ДеревоПоказаний");

КонецПроцедуры


&НаСервере
Процедура УстановитьУсловноеОформление(ЛевоеЗначение, ПравоеЗначение, ОформляемыйЭлемент)
    
    Элемент = УсловноеОформление.Элементы.Добавить();
    
    ПолеЭлемента = Элемент.Поля.Элементы.Добавить();
    ПолеЭлемента.Поле = Новый ПолеКомпоновкиДанных(ОформляемыйЭлемент);
    
    ОтборЭлемента = Элемент.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ОтборЭлемента.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(ЛевоеЗначение);
    ОтборЭлемента.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ОтборЭлемента.ПравоеЗначение = ПравоеЗначение;

    Если ЛевоеЗначение = "ДеревоПоказаний.Скрыть"  Тогда
        Элемент.Оформление.УстановитьЗначениеПараметра("Видимость", Ложь);
        Элемент.Оформление.УстановитьЗначениеПараметра("Отображать", Ложь);
    КонецЕсли;
    
КонецПроцедуры
 
 
   МимохожийОднако
 
1 - 02.05.18 - 06:35
Добавь ЗначениеФормыВРеквизит
   inanity1992
 
2 - 03.05.18 - 03:15
Добавила, но не хотят строки скрываться

ЗначениеВДанныеФормы(ТЗДеревоПоказаний, ДеревоПоказаний);

Вообще строки у ДереваЗначений можно скрыть?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует