Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

глобальная видимость объектов

глобальная видимость объектов
Я
   illi_dan
 
01.05.18 - 21:46
Добрый вечер. Есть форма, в которой пользователь выбирает текстовый файл и документ, а по нажатию кнопки происходят некоторые действия с ними
перем ДокСсылка;
перем ПутьКФайлу;

&НаСервере
Функция ГенерДок()
     
     возврат Документы.ТипВсеСсылки();
КонецФункции



&НаКлиенте
Процедура ПутьКДокументуНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    Документы=ГенерДок();
    
    ВвестиЗначение(ДокСсылка,,Документы);
    Объект.ПутьКДокументу=ДокСсылка;
    ИмяРеквизита = "Дата";

КонецПроцедуры

&НаКлиенте
Процедура ПутьКФайлуНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Фильтр = "(*.txt)|*.txt";
    ДиалогОткрытияФайла.Фильтр = Фильтр;
    ДиалогОткрытияФайла.ПроверятьСуществованиеФайла = Истина;
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
    ДиалогОткрытияФайла.Заголовок = "Выберите текстовый файл";
 
    Если ДиалогОткрытияФайла.Выбрать() Тогда             
                Объект.ПутьКФайлу = ДиалогОткрытияФайла.ПолноеИмяФайла;
            Иначе
                Сообщить("Выбран не текстовый формат");
                
                
        Возврат;
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ВыгрузитьДокумент(Команда)
    Если (ДокСсылка<>Неопределено) И (объект.ПутьКФайлу<>Неопределено) Тогда
        Метаданные=ДокСсылка.Метаданные();
    КонецЕсли
    
КонецПроцедуры

ДокСсылка=Неопределено;
ПутьКФайлу=Неопределено;


Завел две глобальные переменные,и по нажатию кнопки,если они определенны, должен выполнять код. Но у меня почему-то пишет,что они неопределенны(даже если их значение по умолчанию равны  любому числу или строке) Можно как-то решить эту проблему?
 
 
   vde69
 
1 - 01.05.18 - 21:59
переменная не доступна одновременно на сервере и клиенте
   illi_dan
 
2 - 01.05.18 - 22:10
(1) ее можно просто вернуть из отдельной функции,в которой существует переменная или есть другой подход?
   illi_dan
 
3 - 01.05.18 - 22:41
(1) и там же получается везде где используются эти переменные, контекст "на клиенте"
   Cyberhawk
 
4 - 01.05.18 - 22:45
Параметр формы с флажком "Ключевой" или реквизит формы
   illi_dan
 
5 - 01.05.18 - 23:01
(4) можно,пожалуйста,поподробнее. В реквизитах формы есть только пункт "основной реквизит"
   Fram
 
6 - 01.05.18 - 23:02
(5) ты заметил в его фразе союз "или"? https://ru.wikipedia.org/wiki/Или
   illi_dan
 
7 - 01.05.18 - 23:06
(6) да,заметил. Это не помогло,переменные так же "неопределенны". Еще я заметил там слово "ключевой",которое не равно слову "основной",но близко по смыслу.Поэтому предположил,что это не одно и тоже.
   Fram
 
8 - 01.05.18 - 23:23
(7) значит у тебя сложности с пониманием русского языка. "ключевой параметр" и "реквизит формы"! чуешь разницу?
   illi_dan
 
9 - 01.05.18 - 23:35
(8) чую лишь то,что ты унылый тролль.https://ru.wikipedia.org/wiki/Тролль. Похож?
   ВРедная
 
10 - 01.05.18 - 23:43
(9) А он троллиную полосочку прокачивает. Видишь, под ником, какая длинная?
 
 Рекламное место пустует
   Fram
 
11 - 01.05.18 - 23:59
(10) тут не ясельки, чтобы ему разжёвывать и в рот класть. пытаемся намеками (да, саркастическими порой) довести до правильного решения
   illi_dan
 
12 - 02.05.18 - 00:29
(11) Разобрался.Прошу прощения за чрезмерную эмоциональность.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует