Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Розница 2.2 Не пробивает чек с бонусами

Розница 2.2 Не пробивает чек с бонусами
Я
   zvivla
 
01.05.18 - 14:22
Здравствуйте.
Столкнулись с такой проблемой, при оплате бонусами чек не пробивается.
Ссылаясь на то что сумма в строке не заполнена.
http://ssmaker.ru/4fe42e3d/
Раньше все проходило нормально. После установки онлайн кассы вылетает вот такая ошибка.
Как ее победить?
 
 
   VKS
 
1 - 01.05.18 - 14:52
Что-то не правильно. Сумма чека 1249, скидка 1248. Эта скидка бонусами?
В строке №1 не указана сумма. Если 1248 это бонусами, то эта сумма должна быть указана.
   zvivla
 
2 - 01.05.18 - 15:08
1248 сумма бонусами. Если на тестовой базе поставить ккт-эмулятор, то чек пробивается спокойно. На другой точке ККТ без передачи данных, в строке с бонусами суммы тоже нет, пробивается спокойно.

В модулях нашла такой код:
Функция ПроверяемыеРеквизитыПозицийЧека(МассивФФД, СоответствиеРеквизитов)
    
    МассивРеквизитов = Новый Массив;
    
    Для каждого ФорматФД Из МассивФФД Цикл
        Если ФорматФД = "1.0" Тогда
            МассивРеквизитов.Добавить("Цена");// тег 1079

            СоответствиеРеквизитов.Вставить("Цена", НСтр("ru = 'Цена'"));
            
            МассивРеквизитов.Добавить("Количество");// тег 1023

            СоответствиеРеквизитов.Вставить("Количество", НСтр("ru = 'Количество'"));
            
            МассивРеквизитов.Добавить("СтавкаНДС");// тег 1199

            СоответствиеРеквизитов.Вставить("СтавкаНДС", НСтр("ru = 'Ставка НДС'"));
            
            МассивРеквизитов.Добавить("Сумма");// тег 1191

            СоответствиеРеквизитов.Вставить("Сумма", НСтр("ru = 'Сумма'"));
            
        ИначеЕсли ФорматФД = "1.05" Тогда
            
        ИначеЕсли ФорматФД = "1.1" Тогда
            МассивРеквизитов.Добавить("ПризнакПредметаРасчета");// тег 1212

            СоответствиеРеквизитов.Вставить("ПризнакПредметаРасчета", НСтр("ru = 'Признак предмета расчета'"));
            
            МассивРеквизитов.Добавить("ПризнакСпособаРасчета");// тег 1214

            СоответствиеРеквизитов.Вставить("ПризнакСпособаРасчета", НСтр("ru = 'Признак способа расчета'"));
            
        КонецЕсли;
        
    КонецЦикла;
    
    Возврат МассивРеквизитов;
    
КонецФункции


Какое у меня количество для бонусов, а ставка ндс?
   zvivla
 
3 - 01.05.18 - 15:09
ФорматФД на кассе стоит 1.05, но в модуле программы 1.0 автоматом еще добавляется к массиву
   zvivla
 
4 - 01.05.18 - 15:31
Неужели никто на рознице с баллами не работал на онлайн кассах?
   lenochka-semicova
 
5 - 01.05.18 - 15:31
Потому что оплата бонусами - это тоже скидка. таким образом, сумма 1248 распределяется по строкам товаров - в каждой строке остается маленькая сумма, часть от оставшегося 1 руб наличными. А дальше срабатывает форматно-логический контроль, который требует, чтобы Количество * Цена = Сумма. А там цена расчетная  = Сумма / количество, она и дает погрешность округления. Система в итоге разделяет 1 строку на 2 - в одной из которых ставит 0 сумму. А в последних релизах форматно-логический контроль нулевую сумму не пропускает. Хотя на партнерском форуме было обсуждение и 1С отвечали, что запросили разъяснения в ФНС
   lenochka-semicova
 
6 - 01.05.18 - 15:32
(4) Все работали.
   zvivla
 
7 - 01.05.18 - 15:42
(5) да я видела разбивку на 2 суммы, т.е. получается пока никакого решения данной проблемы нет?
   zvivla
 
8 - 01.05.18 - 15:57
списывать просто товар получается, а клиенту товарный чек без кассового выдавать?
   Звездец
 
9 - 01.05.18 - 17:31
у меня сейчас тоже есть проект с бонусами. Оставил их на последок, пока много вопросов по реализации их. С одной стороны в рознице есть настройка, позволяющая оплачивать 100% бонусами. А вот нужен ли чек при таком случае? с одной стороны нет денежных расчетов, и вроде как чек не нужен. Ну а с другой - желание налоговой видеть все и вся и требование бить чеки при отгрузке в кредит (хотя в этот момент тоже расчетов нет, и не факт что они будут наличными)
   zvivla
 
10 - 01.05.18 - 18:00
(9) на многих форумах пишут совершенно разные вещи, кто-то говорит что можно без чека (как тогда списывать товар? просто проводить чек и не пробивать?)

Кто-то говорит, что оплата должна быть хотя бы рубль
 
 Рекламное место пустует
   Звездец
 
11 - 01.05.18 - 18:33
(10) вопрос только в том, как НДС учесть при этом

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует