Вход | Регистрация


Не заполняется характеристика

Не заполняется характеристика
Я
   tabarigen
 
30.04.18 - 16:23
Всем добра, мне бабла. Парни хелпуйте, плиз.

Есть простой код.

Хочу сохдать характеристики, и заполнить их в ТЧ документа Поступление Товаров и Услуг.

&НаСервере
Процедура Расш1_СоздатьХарактеристикиПослеНаСервере()
    Документ = РеквизитФормыВЗначение("Объект");
    Для Каждого Товар Из Документ.Товары Цикл
        НоваяПартия = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
        НоваяПартия.ор_СерияПроизводителя = Прав(Объект.Номер, 6);
        НоваяПартия.ор_СрокГодности = ДобавитьМесяц(ТекущаяДата(), 36);
        НоваяПартия.Владелец = Товар.Номенклатура;
        НоваяПартия.Наименование = "Накл. №" + Прав(Объект.Номер, 6) + " от " + Формат(ТекущаяДата(), "ДЛФ=DD");
        НоваяПартия.Записать();
        Товар.Характеристика = НоваяПартия.Ссылка;
    КонецЦикла;
    ЗначениеВРеквизитФормы(Документ, "Объект");
КонецПроцедуры

&НаКлиенте
Процедура Расш1_СоздатьХарактеристикиПосле(Команда)
    Если Не ЗначениеЗаполнено(Объект.Ссылка) тогда
        Сообщить("Необходимо записать документ!");          
    Иначе
        Расш1_СоздатьХарактеристикиПослеНаСервере();
        ЭтаФорма.Прочитать();
    КонецЕсли;
КонецПроцедуры


Почему то характеристика не прописывается для строки ТЧ, хотя и создается. Где затык?
 
 
   Boleev
 
1 - 30.04.18 - 16:27
А зачем это все?
На сервере
    Для Каждого Товар Из Объект.Товары Цикл
        НоваяПартия = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
        НоваяПартия.ор_СерияПроизводителя = Прав(Объект.Номер, 6);
        НоваяПартия.ор_СрокГодности = ДобавитьМесяц(ТекущаяДата(), 36);
        НоваяПартия.Владелец = Товар.Номенклатура;
        НоваяПартия.Наименование = "Накл. №" + Прав(Объект.Номер, 6) + " от " + Формат(ТекущаяДата(), "ДЛФ=DD");
        НоваяПартия.Записать();
        Товар.Характеристика = НоваяПартия.Ссылка;
    КонецЦикла;

+ надо проверить ведется ли для номенклатуры учет по характеристикам
   tabarigen
 
2 - 30.04.18 - 16:32
(1) братюнь. я конечно нуб, но не столько же.
подразумевается что если я задал этот вопрос, то учет по характеристикам включен и ведется.
   2S
 
3 - 30.04.18 - 17:09
бп3 доработан через расширение?
   Boleev
 
4 - 30.04.18 - 17:12
(3) это похоже на Розницу, отраслевку для Аптек
   tabarigen
 
5 - 30.04.18 - 19:32
(4) оно и есть
   МимохожийОднако
 
6 - 30.04.18 - 22:01
(5) Отладчиком смотрел, в каком месте теряется инфа?
   tabarigen
 
7 - 30.04.18 - 22:01
Господь Боже, надо было прописать

Стр.Характеристика = НоваяПартия.Ссылка;

кто нить объяснит чем отличается НоваяПартия от НоваяПартия.Ссылка в контексте вышеприведенного кода..
   МимохожийОднако
 
8 - 30.04.18 - 22:04
НоваяПартия - это Справочник Объект. В отладчике смотри
   tabarigen
 
9 - 01.05.18 - 08:55
(8) да все верно. на будущее учту

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует