Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Не установлен приемник XML

Не установлен приемник XML
Я
   Roma1314704
 
28.04.18 - 22:48
8.3 Клиент-серверная

Не могу понять ошибку: Не установлен приемник XML

Вот сам код
&НаКлиенте
Процедура Команда(Команда)
ЗаписатьФайл();
    
КонецПроцедуры

&НаСервере
Процедура ЗаписатьФайл()
    МассивДанных = ПолучитьМассивДанных();
    КаталогХМЛ = Строка("D:\documents\Xml\файл.xml");
    Файл  = Новый ТекстовыйДокумент;
    Файл.Записать(КаталогХМЛ);
    Запись  = Новый ЗаписьXML;
    Запись.ЗаписатьНачалоЭлемента("Документ");
    Для Каждого ЭлементМассива  Из МассивДанных Цикл
        Запись.ЗаписатьНачалоЭлемента("Документ");
        
        
        Запись.ЗаписатьКонецЭлемента();
        Запись.ЗаписатьАтрибут("Код",ЭлементМассива.Код);
        Запись.ЗаписатьНачалоЭлемента("Детально");
        Запись.ЗаписатьАтрибут("Наименование", ЭлементМассива.Наименование);
        Запись.ЗаписатьАтрибут("ЦенаПродажи", ЭлементМассива.ЦенаПродажи);
        
    КонецЦикла;
    
    
    Запись.ЗаписатьКонецЭлемента();

    
Конецпроцедуры

&НаСервере
Функция ПолучитьМассивДанных()
    
    МассивДанных = Новый Массив;
        //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

    // Данный фрагмент построен конструктором.

    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    Номенклатура.Код КАК Код,
        |    Номенклатура.Наименование КАК Наименование,
        |    Номенклатура.ЦенаПродажи КАК ЦенаПродажи,
        |    Номенклатура.ТоварРоз КАК ТоварРоз
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |    Номенклатура.ТоварРоз = &Истина";
    
    Запрос.УстановитьПараметр("Истина", Истина);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        НоваяЗапись = Новый Структура("Код, Наименование, ЦенаПродажи");
        НоваяЗапись.Код = Строка(ВыборкаДетальныеЗаписи.Код);
        НоваяЗапись.Наименование = Строка(ВыборкаДетальныеЗаписи.Наименование);
        НоваяЗапись.ЦенаПродажи = Строка(ВыборкаДетальныеЗаписи.ЦенаПродажи);
        МассивДанных.Добавить(НоваяЗапись);
        
        
    КонецЦикла;
    
    Возврат МассивДанных;
    
КонецФункции
 
 
   Lexey_
 
1 - 28.04.18 - 23:26
(0) КаталогХМЛ нигде не используешь для записи
   Roma1314704
 
2 - 29.04.18 - 00:50
Спасибо, уже сам нашел косяки

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует